summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-21 00:23:05 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-21 00:23:05 +0000
commitfeffec9fd91e719587ea54e315a4e99475ad4a2c (patch)
tree2de0f341bf521394e49ea48d17ec40046da35aa7 /media-libs/alsa-lib
parentremove unused x11-base/x11-drm:gatos use flag (diff)
downloadgentoo-2-feffec9fd91e719587ea54e315a4e99475ad4a2c.tar.gz
gentoo-2-feffec9fd91e719587ea54e315a4e99475ad4a2c.tar.bz2
gentoo-2-feffec9fd91e719587ea54e315a4e99475ad4a2c.zip
Add masked ebuild of alsa-lib with extra useflags. Experimental.
(Portage version: 2.1.2_rc3-r8)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.14_rc1-r1.ebuild84
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc1-r13
3 files changed, 94 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index e726f4366cb6..a7c992cbb249 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.210 2006/12/11 19:46:14 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.211 2006/12/21 00:23:04 flameeyes Exp $
+
+*alsa-lib-1.0.14_rc1-r1 (21 Dec 2006)
+
+ 21 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-lib-1.0.14_rc1-r1.ebuild:
+ Add masked ebuild of alsa-lib with extra useflags. Experimental.
*alsa-lib-1.0.14_rc1 (11 Dec 2006)
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.14_rc1-r1.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.14_rc1-r1.ebuild
new file mode 100644
index 000000000000..fa5ac352cda1
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.14_rc1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.14_rc1-r1.ebuild,v 1.1 2006/12/21 00:23:05 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file null empty share meter hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable midi instr) \
+ $(use_enable midi seq) $(use_enable midi aload) \
+ "--with-pcm-plugins=${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ einfo ""
+ einfo "Please try media-sound/alsa-driver before filing bugs about unstable"
+ einfo "or missing output with in-kernel drivers. Misaligned versions of"
+ einfo "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc1-r1 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc1-r1
new file mode 100644
index 000000000000..a74bd0f72656
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.14_rc1-r1
@@ -0,0 +1,3 @@
+MD5 6e45bb92e9162ffaeb26395e8210971f alsa-lib-1.0.14rc1.tar.bz2 714549
+RMD160 c4520ff469fcfb68da4f1646e2b153cce805e892 alsa-lib-1.0.14rc1.tar.bz2 714549
+SHA256 a0acfe840b519b9ab90f94878941ff2e77aac07c1e4d08c07f6d8c96661150ca alsa-lib-1.0.14rc1.tar.bz2 714549