summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-01-19 15:06:06 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-01-19 15:06:06 +0000
commitb7e62e2370d905e7b56dbd74a9f7d801ddf4ad4f (patch)
treebaad01fe338a94f8c708024be95fb86d7c0116d9 /media-libs/alsa-lib
parentVersion bump. The ChangeLog may interest you, which you can find here: http:/... (diff)
downloadgentoo-2-b7e62e2370d905e7b56dbd74a9f7d801ddf4ad4f.tar.gz
gentoo-2-b7e62e2370d905e7b56dbd74a9f7d801ddf4ad4f.tar.bz2
gentoo-2-b7e62e2370d905e7b56dbd74a9f7d801ddf4ad4f.zip
Version bump. The ChangeLog may interest you, which you can find here: http://www.alsa-project.org/main/index.php/Changes_v1.0.18_v1.0.19
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog10
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.19.ebuild99
2 files changed, 107 insertions, 2 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 85c05dc6466c..63ea6b9a7567 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.272 2008/12/22 16:26:34 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.273 2009/01/19 15:06:06 chainsaw Exp $
+
+*alsa-lib-1.0.19 (19 Jan 2009)
+
+ 19 Jan 2009; <chainsaw@gentoo.org> +alsa-lib-1.0.19.ebuild:
+ Version bump. The ChangeLog may interest you, which you can find here:
+ http://www.alsa-project.org/main/index.php/Changes_v1.0.18_v1.0.19
22 Dec 2008; Raúl Porcel <armin76@gentoo.org> alsa-lib-1.0.17a.ebuild:
ia64 stable wrt #245517
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.19.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.19.ebuild
new file mode 100644
index 000000000000..f8a20eba2650
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.19.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.19.ebuild,v 1.1 2009/01/19 15:06:06 chainsaw Exp $
+
+inherit eutils libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug alisp midi python"
+
+RDEPEND="python? ( dev-lang/python )"
+DEPEND="${RDEPEND}
+ >=media-sound/alsa-headers-${PV}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+IUSE_PCM_PLUGIN="copy linear route mulaw alaw adpcm rate plug multi shm file
+null empty share meter mmap_emul hooks lfloat ladspa dmix dshare dsnoop asym iec958
+softvol extplug ioplug"
+
+for plugin in ${IUSE_PCM_PLUGIN}; do
+ IUSE="${IUSE} alsa_pcm_plugins_${plugin}"
+done
+
+pkg_setup() {
+ if [ -z "${ALSA_PCM_PLUGINS}" ] ; then
+ ewarn "You haven't selected _any_ PCM plugins. Either you set it to something like the default"
+ ewarn "(which is being set in the profile UNLESS you unset them) or alsa based applications"
+ ewarn "are going to *misbehave* !"
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ --disable-resmgr \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ $(use_enable midi rawmidi) \
+ $(use_enable midi seq) \
+ $(use_enable midi aload) \
+ --with-pcm-plugins="${ALSA_PCM_PLUGINS}" \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO || die
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ elog ""
+ elog "Please try in-kernel ALSA drivers instead of the alsa-drivers ebuild."
+ elog "If alsa-drivers works for you where a *recent* kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}