summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-28 06:58:51 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-28 06:58:51 +0000
commit94ec2cc4fe4bc23aadf13542564bf77364893bf1 (patch)
tree353edeea367adc3a16c1d6f2d97405ec5190798b /media-libs/alsa-lib
parentVersion bump. (diff)
downloadgentoo-2-94ec2cc4fe4bc23aadf13542564bf77364893bf1.tar.gz
gentoo-2-94ec2cc4fe4bc23aadf13542564bf77364893bf1.tar.bz2
gentoo-2-94ec2cc4fe4bc23aadf13542564bf77364893bf1.zip
Version bump.
(Portage version: 2.1.2_pre1-r3)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.13_rc3.ebuild73
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-1.0.13_rc33
3 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 51f894cc9f0f..b95c2f61fbc2 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.190 2006/09/24 17:37:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.191 2006/09/28 06:58:51 flameeyes Exp $
+
+*alsa-lib-1.0.13_rc3 (28 Sep 2006)
+
+ 28 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-lib-1.0.13_rc3.ebuild:
+ Version bump.
24 Sep 2006; Diego Pettenò <flameeyes@gentoo.org> alsa-lib-1.0.10.ebuild,
alsa-lib-1.0.11.ebuild, alsa-lib-1.0.11-r1.ebuild, alsa-lib-1.0.12.ebuild,
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.13_rc3.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.13_rc3.ebuild
new file mode 100644
index 000000000000..fdf9697449d7
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.13_rc3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.13_rc3.ebuild,v 1.1 2006/09/28 06:58:51 flameeyes Exp $
+
+WANT_AUTOMAKE="1.9"
+
+inherit eutils autotools libtool
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc debug"
+
+RDEPEND="virtual/alsa
+ >=media-sound/alsa-headers-${PV}"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.10_rc3-hardened.patch"
+ epatch "${FILESDIR}/${PN}-1.0.10-no-wordexp-header.patch"
+
+ eautomake
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ # needed to avoid gcc looping internaly
+ use hppa && export CFLAGS="-O1 -pipe"
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with debug) \
+ || die "configure failed"
+
+ emake || die "make failed"
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc ChangeLog TODO
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ ewarn "Starting from alsa 1.0.11_rc3 the configuration for dmix is changed."
+ ewarn "Leaving around old asound.conf or ~/.asoundrc might make all apps"
+ ewarn "using ALSA output crash."
+ ewarn "Note that dmix output is enabled by default on the 'default' device"
+ ewarn "since ALSA 1.0.9."
+ einfo ""
+ einfo "Please try media-sound/alsa-driver before filing bugs about unstable"
+ einfo "or missing output with in-kernel drivers. Misaligned versions of"
+ einfo "alsa-lib and drivers used can cause problems."
+}
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-1.0.13_rc3 b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.13_rc3
new file mode 100644
index 000000000000..5ab625adeafa
--- /dev/null
+++ b/media-libs/alsa-lib/files/digest-alsa-lib-1.0.13_rc3
@@ -0,0 +1,3 @@
+MD5 d739702cab09e3e76ae6bb1724bb5535 alsa-lib-1.0.13rc3.tar.bz2 709851
+RMD160 bb86944337171c1a77d16f566b8cf89803831686 alsa-lib-1.0.13rc3.tar.bz2 709851
+SHA256 6ef5bde536dfbb4ce5723108dc8fa1b60c709d092c9548176afa38cba091cbf8 alsa-lib-1.0.13rc3.tar.bz2 709851