summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-09-07 12:57:19 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-09-07 12:57:19 +0000
commit461481d6d92d99e863b65f68bbaacb571517d2bc (patch)
tree1d4f77e12ff8acef3ce1d2d7c588b778e5da6a46 /media-libs/alsa-lib
parentversion bump (diff)
downloadgentoo-2-461481d6d92d99e863b65f68bbaacb571517d2bc.tar.gz
gentoo-2-461481d6d92d99e863b65f68bbaacb571517d2bc.tar.bz2
gentoo-2-461481d6d92d99e863b65f68bbaacb571517d2bc.zip
Version bump, as announced by Jaroslav Kysela on alsa-devel.
(Portage version: 2.1.11.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog7
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.26.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 7c3925829cbc..498b154a529b 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.332 2012/04/01 15:11:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.333 2012/09/07 12:57:19 chainsaw Exp $
+
+*alsa-lib-1.0.26 (07 Sep 2012)
+
+ 07 Sep 2012; Tony Vroon <chainsaw@gentoo.org> +alsa-lib-1.0.26.ebuild:
+ Version bump, as announced by Jaroslav Kysela on alsa-devel.
01 Apr 2012; Raúl Porcel <armin76@gentoo.org> alsa-lib-1.0.25-r1.ebuild:
alpha/ia64/sh/sparc stable wrt #406101
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild
new file mode 100644
index 000000000000..7f1050706b18
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.26.ebuild,v 1.1 2012/09/07 12:57:19 chainsaw Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="python? 2"
+
+inherit autotools base python multilib
+
+MY_P=${P/_rc/rc}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/lib/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc debug alisp python"
+
+DEPEND=">=media-sound/alsa-headers-1.0.25
+ doc? ( >=app-doc/doxygen-1.2.6 )"
+RDEPEND=""
+PATCHES=( "${FILESDIR}/${PV}-extraneous-cflags.diff" )
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ fi
+}
+
+src_prepare() {
+ eautoreconf
+ epunt_cxx
+}
+
+src_configure() {
+ local myconf
+ use elibc_uclibc && myconf="--without-versioned"
+
+ econf \
+ --enable-shared \
+ --disable-resmgr \
+ --enable-rawmidi \
+ --enable-seq \
+ --enable-aload \
+ $(use_with debug) \
+ $(use_enable alisp) \
+ $(use_enable python) \
+ --disable-dependency-tracking \
+ ${myconf}
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ emake doc || die "failed to generate docs"
+ fgrep -Zrl "${S}" "${S}/doc/doxygen/html" | \
+ xargs -0 sed -i -e "s:${S}::"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+ find "${ED}"/usr/$(get_libdir)/alsa-lib -name '*.a' -exec rm -f {} +
+
+ dodoc ChangeLog TODO || die
+ use doc && dohtml -r doc/doxygen/html/*
+}
+
+pkg_postinst() {
+ elog "Please try in-kernel ALSA drivers instead of the alsa-driver ebuild."
+ elog "If alsa-driver works for you where a *recent* kernel does not, we want "
+ elog "to know about this. Our e-mail address is alsa-bugs@gentoo.org"
+ elog "However, if you notice no sound output or instability, please try to "
+ elog "upgrade your kernel to a newer version first."
+}