summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-10 11:57:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-11-10 11:57:53 +0000
commit28fb454ca27e7e29853d3cc006d3b6bdcc8953d1 (patch)
treeadd6d356817034b6f4f08c854deb76d5d81106d8 /media-libs/alsa-lib
parentNew release. (diff)
downloadgentoo-2-28fb454ca27e7e29853d3cc006d3b6bdcc8953d1.tar.gz
gentoo-2-28fb454ca27e7e29853d3cc006d3b6bdcc8953d1.tar.bz2
gentoo-2-28fb454ca27e7e29853d3cc006d3b6bdcc8953d1.zip
Added patch to not link tests statically (should fix bug #99764) and patch to remove omixer test and fix code.c for GCC4 (bug #112025).
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/ChangeLog8
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild13
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-hardened.patch12
-rw-r--r--media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-test.patch70
4 files changed, 100 insertions, 3 deletions
diff --git a/media-libs/alsa-lib/ChangeLog b/media-libs/alsa-lib/ChangeLog
index 61bf19c1c2da..789eef8f4ddc 100644
--- a/media-libs/alsa-lib/ChangeLog
+++ b/media-libs/alsa-lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/alsa-lib
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.128 2005/11/08 12:19:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/ChangeLog,v 1.129 2005/11/10 11:57:53 flameeyes Exp $
+
+ 10 Nov 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/alsa-lib-1.0.10_rc3-hardened.patch,
+ +files/alsa-lib-1.0.10_rc3-test.patch, alsa-lib-1.0.10_rc3.ebuild:
+ Added patch to not link tests statically (should fix bug #99764) and patch
+ to remove omixer test and fix code.c for GCC4 (bug #112025).
*alsa-lib-1.0.10_rc3 (08 Nov 2005)
diff --git a/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild b/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild
index bb5b268b0f75..252caf27c102 100644
--- a/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild
+++ b/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild,v 1.1 2005/11/08 12:19:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-1.0.10_rc3.ebuild,v 1.2 2005/11/10 11:57:53 flameeyes Exp $
-inherit eutils
+inherit eutils autotools
MY_P="${P/_rc/rc}"
S="${WORKDIR}/${MY_P}"
@@ -25,6 +25,15 @@ DEPEND="${RDEPEND}
PDEPEND="jack? ( =media-plugins/alsa-jack-${PV/_rc*/}* )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-hardened.patch"
+ epatch "${FILESDIR}/${P}-test.patch"
+
+ eautoreconf
+}
+
src_compile() {
# needed to avoid gcc looping internaly
use hppa && export CFLAGS="-O1 -pipe"
diff --git a/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-hardened.patch b/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-hardened.patch
new file mode 100644
index 000000000000..a064c702dc4a
--- /dev/null
+++ b/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-hardened.patch
@@ -0,0 +1,12 @@
+Index: alsa-lib-1.0.10rc3/test/Makefile.am
+===================================================================
+--- alsa-lib-1.0.10rc3.orig/test/Makefile.am
++++ alsa-lib-1.0.10rc3/test/Makefile.am
+@@ -16,6 +16,6 @@ queue_timer_LDADD=../src/libasound.la
+ code_CFLAGS=-Wall -pipe -g -O2
+
+ INCLUDES=-I$(top_srcdir)/include
+-AM_CFLAGS=-static -Wall -pipe -g
++AM_CFLAGS=-Wall -pipe -g
+
+ EXTRA_DIST=seq-decoder.c seq-sender.c midifile.h midifile.c midifile.3
diff --git a/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-test.patch b/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-test.patch
new file mode 100644
index 000000000000..6c2e706ef107
--- /dev/null
+++ b/media-libs/alsa-lib/files/alsa-lib-1.0.10_rc3-test.patch
@@ -0,0 +1,70 @@
+Index: alsa-lib-1.0.10rc3/test/Makefile.am
+===================================================================
+--- alsa-lib-1.0.10rc3.orig/test/Makefile.am
++++ alsa-lib-1.0.10rc3/test/Makefile.am
+@@ -1,6 +1,6 @@
+ check_PROGRAMS=control pcm latency seq \
+ playmidi1 timer rawmidi midiloop \
+- omixer code oldapi queue_timer
++ code oldapi queue_timer
+
+ control_LDADD=../src/libasound.la
+ pcm_LDADD=../src/libasound.la
+@@ -10,7 +10,6 @@ playmidi1_LDADD=../src/libasound.la
+ timer_LDADD=../src/libasound.la
+ rawmidi_LDADD=../src/libasound.la
+ midiloop_LDADD=../src/libasound.la
+-omixer_LDADD=../src/libasound.la
+ oldapi_LDADD=../src/libasound.la
+ queue_timer_LDADD=../src/libasound.la
+ code_CFLAGS=-Wall -pipe -g -O2
+Index: alsa-lib-1.0.10rc3/test/code.c
+===================================================================
+--- alsa-lib-1.0.10rc3.orig/test/code.c
++++ alsa-lib-1.0.10rc3/test/code.c
+@@ -96,8 +96,8 @@ void mix_areas_srv(unsigned int size,
+ {
+ while (size-- > 0) {
+ atomic_add(sum, *src);
+- ((char*)src) += src_step;
+- ((char*)sum) += sum_step;
++ src = (((char*)src) + src_step);
++ sum = (((char*)sum) + sum_step);
+ }
+ }
+
+@@ -113,8 +113,8 @@ void saturate(unsigned int size,
+ *dst = 0x7fff;
+ else
+ *dst = sample;
+- ((char*)dst) += dst_step;
+- ((char*)sum) += sum_step;
++ dst = (((char*)dst) + dst_step);
++ sum = (((char*)sum) + sum_step);
+ }
+ }
+
+@@ -133,9 +133,9 @@ void mix_areas0(unsigned int size,
+ *dst = 0x7fff;
+ else
+ *dst = sample;
+- ((char *)dst) += dst_step;
+- ((char *)src) += src_step;
+- ((char *)sum) += sum_step;
++ dst = (((char*)dst) + dst_step);
++ src = (((char*)src) + src_step);
++ sum = (((char*)sum) + sum_step);
+ }
+ }
+
+@@ -167,8 +167,8 @@ void mix_areas2(unsigned int size,
+ *dst = sample;
+ } while (unlikely(sample != *sum));
+ sum++;
+- ((char *)dst) += dst_step;
+- ((char *)src) += src_step;
++ dst = (((char*)dst) + dst_step);
++ src = (((char*)src) + src_step);
+ }
+ }
+