summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-10 17:20:42 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-10 17:20:42 +0000
commita86e9e9a211b0027cb0dcc57d4062b54fca63288 (patch)
tree517a7f2c93f0b50700adcda85e0cc7a9ac2271ab /media-libs/adplug/adplug-2.1.ebuild
parentMask the Gnome 2.22.1 meta until all deps are in portage (diff)
downloadgentoo-2-a86e9e9a211b0027cb0dcc57d4062b54fca63288.tar.gz
gentoo-2-a86e9e9a211b0027cb0dcc57d4062b54fca63288.tar.bz2
gentoo-2-a86e9e9a211b0027cb0dcc57d4062b54fca63288.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'media-libs/adplug/adplug-2.1.ebuild')
-rw-r--r--media-libs/adplug/adplug-2.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/adplug/adplug-2.1.ebuild b/media-libs/adplug/adplug-2.1.ebuild
new file mode 100644
index 000000000000..d0e2fe260ddc
--- /dev/null
+++ b/media-libs/adplug/adplug-2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/adplug/adplug-2.1.ebuild,v 1.1 2008/04/10 17:20:42 drac Exp $
+
+DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
+HOMEPAGE="http://adplug.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-cpp/libbinio-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-dependency-tracking $(use_enable debug)
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}