summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-10-27 22:02:48 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-10-27 22:02:48 +0000
commit5d55ed71208113f10c7a9c492773c0b2f5502261 (patch)
tree187e24cd5d8e385dfe571ed7d524ce983cacf53f /media-libs/SoQt
parentfix building by fetching an existing icon (bug #287467) (diff)
downloadgentoo-2-5d55ed71208113f10c7a9c492773c0b2f5502261.tar.gz
gentoo-2-5d55ed71208113f10c7a9c492773c0b2f5502261.tar.bz2
gentoo-2-5d55ed71208113f10c7a9c492773c0b2f5502261.zip
Updating patch to compile against gcc 4.4 , detecting if >=media-libs/coin-3* is installed
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-libs/SoQt')
-rw-r--r--media-libs/SoQt/ChangeLog7
-rw-r--r--media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch21
2 files changed, 22 insertions, 6 deletions
diff --git a/media-libs/SoQt/ChangeLog b/media-libs/SoQt/ChangeLog
index ec88f769621c..ed6f19fb148a 100644
--- a/media-libs/SoQt/ChangeLog
+++ b/media-libs/SoQt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/SoQt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/ChangeLog,v 1.22 2009/10/04 14:56:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/SoQt/ChangeLog,v 1.23 2009/10/27 22:02:48 vostorga Exp $
+
+ 27 Oct 2009; Víctor Ostorga <vostorga@gentoo.org>
+ files/SoQt-1.4.1-gcc44.patch:
+ Updating patch to compile against gcc 4.4 , detecting if
+ >=media-libs/coin-3* is installed
04 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> SoQt-1.4.1.ebuild:
Replace -Wl,--no-as-needed with function from flag-o-matic eclass.
diff --git a/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch b/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch
index 1f0954ca6754..f8777b037c54 100644
--- a/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch
+++ b/media-libs/SoQt/files/SoQt-1.4.1-gcc44.patch
@@ -1,11 +1,22 @@
---- ./src/Inventor/Qt/SoQtComponent.cpp.orig 2006-10-30 16:09:20.000000000 -0600
-+++ ./src/Inventor/Qt/SoQtComponent.cpp 2009-08-17 08:07:57.000000000 -0500
-@@ -100,7 +100,7 @@
+diff -ru soqt-1.4.1~/src/Inventor/Qt/SoQtComponent.cpp soqt-1.4.1/src/Inventor/Qt/SoQtComponent.cpp
+--- soqt-1.4.1~/src/Inventor/Qt/SoQtComponent.cpp 2009-02-25 07:55:02.000000000 -0800
++++ soqt-1.4.1/src/Inventor/Qt/SoQtComponent.cpp 2009-02-25 07:56:36.000000000 -0800
+@@ -100,10 +100,17 @@
this->parent->removeEventFilter(this);
}
--static void delete_dict_value(unsigned long key, void * value)
-+static void delete_dict_value(SbDictKeyType key, void * value)
++#if COIN_MAJOR_VERSION >= 3
++static void delete_dict_value(SbDict::Key key, void * value)
++{
++ delete (QCursor *)value;
++}
++#else // COIN_MAJOR_VERSION >= 3
+ static void delete_dict_value(unsigned long key, void * value)
{
delete (QCursor *)value;
}
++#endif // COIN_MAJOR_VERSION < 3
+
+ void
+ SoQtComponentP::atexit_cleanup()
+