summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-27 07:08:43 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-27 07:08:43 +0000
commitf2376f7543704a41e82ec9f53f8e528850d4a277 (patch)
treed96d1741cc55d62735a1e15774bb2d0e156e54f9 /media-gfx
parent[bump] virtual/perl-Math-BigInt-FastCalc-0.280.0 (diff)
downloadgentoo-2-f2376f7543704a41e82ec9f53f8e528850d4a277.tar.gz
gentoo-2-f2376f7543704a41e82ec9f53f8e528850d4a277.tar.bz2
gentoo-2-f2376f7543704a41e82ec9f53f8e528850d4a277.zip
Initial import (bug #272205). Ebuild by me.
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/panini/ChangeLog10
-rw-r--r--media-gfx/panini/files/panini.desktop10
-rw-r--r--media-gfx/panini/metadata.xml9
-rw-r--r--media-gfx/panini/panini-0.71.104.ebuild32
4 files changed, 61 insertions, 0 deletions
diff --git a/media-gfx/panini/ChangeLog b/media-gfx/panini/ChangeLog
new file mode 100644
index 000000000000..b6db6f9fccd2
--- /dev/null
+++ b/media-gfx/panini/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-gfx/panini
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/panini/ChangeLog,v 1.1 2011/02/27 07:08:43 radhermit Exp $
+
+*panini-0.71.104 (27 Feb 2011)
+
+ 27 Feb 2011; Tim Harder <radhermit@gentoo.org> +panini-0.71.104.ebuild,
+ +files/panini.desktop, +metadata.xml:
+ Initial import (bug #272205). Ebuild by me.
+
diff --git a/media-gfx/panini/files/panini.desktop b/media-gfx/panini/files/panini.desktop
new file mode 100644
index 000000000000..cffd55d5a02a
--- /dev/null
+++ b/media-gfx/panini/files/panini.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Panini
+GenericName=Panini perspective tool
+Comment=Perspective views from panoramic images
+Exec=panini %f
+Terminal=false
+Type=Application
+Icon=panini
+Categories=Graphics;
+MimeType=video/quicktime;image/jpeg;image/tiff;image/png;
diff --git a/media-gfx/panini/metadata.xml b/media-gfx/panini/metadata.xml
new file mode 100644
index 000000000000..ce74d099b974
--- /dev/null
+++ b/media-gfx/panini/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>graphics</herd>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-gfx/panini/panini-0.71.104.ebuild b/media-gfx/panini/panini-0.71.104.ebuild
new file mode 100644
index 000000000000..47bc8d3c0316
--- /dev/null
+++ b/media-gfx/panini/panini-0.71.104.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/panini/panini-0.71.104.ebuild,v 1.1 2011/02/27 07:08:43 radhermit Exp $
+
+EAPI=3
+
+inherit qt4-r2 eutils
+
+MY_P="${P/p/P}-src"
+DESCRIPTION="OpenGL-based panoramic image viewer"
+HOMEPAGE="http://sourceforge.net/projects/pvqt/"
+SRC_URI="mirror://sourceforge/pvqt/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt-core:4
+ x11-libs/qt-opengl:4
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ newbin Panini panini
+ dodoc panini-usage.txt panini-0.71-release.txt
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon ui/panini-icon-blue.jpg ${PN}.jpg
+}