summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-09-02 02:10:42 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-09-02 02:10:42 +0000
commite5a378206dc10a35df2e26d84db205e6dbbbb9c5 (patch)
tree83a9e175019785e679a941cc37dbdd426f6e9ac5 /media-gfx
parentfix desktop file (diff)
downloadgentoo-2-e5a378206dc10a35df2e26d84db205e6dbbbb9c5.tar.gz
gentoo-2-e5a378206dc10a35df2e26d84db205e6dbbbb9c5.tar.bz2
gentoo-2-e5a378206dc10a35df2e26d84db205e6dbbbb9c5.zip
Version bump, adjust deps.
(Portage version: 2.2.0_alpha123-r1/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/nomacs/ChangeLog8
-rw-r--r--media-gfx/nomacs/nomacs-0.4.0.ebuild (renamed from media-gfx/nomacs/nomacs-0.3.2.ebuild)18
2 files changed, 19 insertions, 7 deletions
diff --git a/media-gfx/nomacs/ChangeLog b/media-gfx/nomacs/ChangeLog
index 9ff43738fc58..fd510066a187 100644
--- a/media-gfx/nomacs/ChangeLog
+++ b/media-gfx/nomacs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/nomacs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/nomacs/ChangeLog,v 1.1 2012/06/29 07:37:18 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/nomacs/ChangeLog,v 1.2 2012/09/02 02:10:42 pesa Exp $
+
+*nomacs-0.4.0 (02 Sep 2012)
+
+ 02 Sep 2012; Davide Pesavento <pesa@gentoo.org> +nomacs-0.4.0.ebuild,
+ -nomacs-0.3.2.ebuild:
+ Version bump, adjust deps.
*nomacs-0.3.2 (29 Jun 2012)
diff --git a/media-gfx/nomacs/nomacs-0.3.2.ebuild b/media-gfx/nomacs/nomacs-0.4.0.ebuild
index 62890d15481a..4f9e28f97305 100644
--- a/media-gfx/nomacs/nomacs-0.3.2.ebuild
+++ b/media-gfx/nomacs/nomacs-0.4.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/nomacs/nomacs-0.3.2.ebuild,v 1.1 2012/06/29 07:37:18 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/nomacs/nomacs-0.4.0.ebuild,v 1.1 2012/09/02 02:10:42 pesa Exp $
EAPI=4
+
#LANGS="als de en ru zh" TODO: translation handling
inherit cmake-utils
@@ -16,19 +17,24 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="raw"
-RDEPEND=">=media-gfx/exiv2-0.20[xmp,zlib]
+RDEPEND="
+ >=media-gfx/exiv2-0.20[zlib]
>=x11-libs/qt-core-4.7.0:4
>=x11-libs/qt-gui-4.7.0:4
- raw? ( media-libs/libraw
- media-libs/opencv[qt4] )"
+ raw? (
+ >=media-libs/libraw-0.14
+ >=media-libs/opencv-2.4.0[qt4]
+ )"
DEPEND="${RDEPEND}
- app-arch/unzip"
+ app-arch/unzip
+ virtual/pkgconfig
+"
S=${WORKDIR}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable raw RAW)
+ $(cmake-utils_use_enable raw)
)
cmake-utils_src_configure
}