summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-01-27 15:40:40 +0000
committerMichael Januszewski <spock@gentoo.org>2007-01-27 15:40:40 +0000
commite389a1e35284c1288a6790d5c0b20a8e3d98cba5 (patch)
treed761a3741e8d3f5717ad25a9731e076cf9653413 /media-gfx
parentFixed the patch not too sensitive about duplicated slashes, #163536 (diff)
downloadgentoo-2-e389a1e35284c1288a6790d5c0b20a8e3d98cba5.tar.gz
gentoo-2-e389a1e35284c1288a6790d5c0b20a8e3d98cba5.tar.bz2
gentoo-2-e389a1e35284c1288a6790d5c0b20a8e3d98cba5.zip
Fix bug #163552.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/splashutils/ChangeLog9
-rw-r--r--media-gfx/splashutils/files/splashutils-1.3-initrd-chvt.patch68
-rw-r--r--media-gfx/splashutils/splashutils-1.3-r2.ebuild9
-rw-r--r--media-gfx/splashutils/splashutils-1.3-r3.ebuild9
4 files changed, 87 insertions, 8 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 3b41380b7a13..3c8c50e1afdb 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.70 2006/11/26 17:31:52 spock Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.71 2007/01/27 15:40:40 spock Exp $
+
+ 27 Jan 2007; Michał Januszewski <spock@gentoo.org>
+ +files/splashutils-1.3-initrd-chvt.patch, splashutils-1.3-r2.ebuild,
+ splashutils-1.3-r3.ebuild:
+ Fix bug #163552.
26 Nov 2006; Michał Januszewski <spock@gentoo.org>
splashutils-1.3-r3.ebuild:
diff --git a/media-gfx/splashutils/files/splashutils-1.3-initrd-chvt.patch b/media-gfx/splashutils/files/splashutils-1.3-initrd-chvt.patch
new file mode 100644
index 000000000000..71220ea2e602
--- /dev/null
+++ b/media-gfx/splashutils/files/splashutils-1.3-initrd-chvt.patch
@@ -0,0 +1,68 @@
+diff --git a/gentoo/initrd.splash b/gentoo/initrd.splash
+index 5871ba6..e16cba4 100644
+--- a/gentoo/initrd.splash
++++ b/gentoo/initrd.splash
+@@ -7,23 +7,23 @@
+ # This file is a part of splashutils.
+ #
+ # NOTE: The code here has to be compatible with ash and with the busybox
+-# versions of all the standard system utilities. That means: no
++# versions of all the standard system utilities. That means: no
+ # extended regular expressions, no pattern substitution in variables,
+ # and no fancy GNU command line options.
+
+ splash() {
+ local cmd="$1"
+ splash_setup
+-
++
+ [ ! -x /sbin/splash_helper ] && return
+ [ "${SPLASH_MODE_REQ}" != 'silent' ] && return
+
+ case "${cmd}" in
+ set_msg)
+- export BOOT_MSG="$2"
++ export BOOT_MSG="$2"
+ /sbin/splash_helper 2 'repaint'
+ ;;
+- init)
++ init)
+ if [ -n "$2" ]; then
+ export BOOT_MSG="$2"
+ elif [ "${CDROOT}" -eq '1' ]; then
+@@ -34,19 +34,23 @@ splash() {
+ /sbin/splash_helper 2 'repaint'
+ ;;
+ verbose)
+- /bin/chvt 1
++ if [ -x /bin/chvt ]; then
++ /bin/chvt 1
++ elif [ -x /bin/busybox ]; then
++ /bin/busybox chvt 1
++ fi
+ echo "verbose"
+ ;;
+ esac
+ }
+
+ splash_setup() {
+- # If it's already set up, let's not waste time on parsing the config
++ # If it's already set up, let's not waste time on parsing the config
+ # files again
+ if [ "${SPLASH_THEME}" != '' -a "${SPLASH_TTY}" != '' -a "$1" != 'force' ]; then
+ return 0
+ fi
+-
++
+ export SPLASH_MODE_REQ="off"
+ export SPLASH_THEME="default"
+ export SPLASH_TTY="16"
+@@ -54,7 +58,7 @@ splash_setup() {
+
+ if [ -f /proc/cmdline ]; then
+ options=$(sed -e 's/.*splash=\([^ ]*\).*/\1/' -e 's/,/ /g' /proc/cmdline)
+-
++
+ for i in ${options} ; do
+ case ${i%:*} in
+ theme) SPLASH_THEME=${i#*:} ;;
diff --git a/media-gfx/splashutils/splashutils-1.3-r2.ebuild b/media-gfx/splashutils/splashutils-1.3-r2.ebuild
index 3efcbfe069aa..5aef54de0ef4 100644
--- a/media-gfx/splashutils/splashutils-1.3-r2.ebuild
+++ b/media-gfx/splashutils/splashutils-1.3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r2.ebuild,v 1.5 2007/01/13 22:54:04 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r2.ebuild,v 1.6 2007/01/27 15:40:40 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -63,8 +63,11 @@ src_unpack() {
# is being configured. Either that, or we end up with a segfaulting kernel
# helper.
rm ${S}/libs/zlib-${V_ZLIB}/Makefile
- cd ${S}
+ cd ${SG}
+ epatch ${FILESDIR}/splashutils-1.3-initrd-chvt.patch
+
+ cd ${S}
epatch ${FILESDIR}/splashutils-1.3-r2.patch
epatch ${FILESDIR}/splashutils-1.3-r2-fbsplash.patch
diff --git a/media-gfx/splashutils/splashutils-1.3-r3.ebuild b/media-gfx/splashutils/splashutils-1.3-r3.ebuild
index 8d3aa1bf9ea1..f6049ab45082 100644
--- a/media-gfx/splashutils/splashutils-1.3-r3.ebuild
+++ b/media-gfx/splashutils/splashutils-1.3-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r3.ebuild,v 1.3 2006/11/26 17:34:49 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.3-r3.ebuild,v 1.4 2007/01/27 15:40:40 spock Exp $
inherit eutils multilib toolchain-funcs
@@ -63,8 +63,11 @@ src_unpack() {
# is being configured. Either that, or we end up with a segfaulting kernel
# helper.
rm ${S}/libs/zlib-${V_ZLIB}/Makefile
- cd ${S}
+ cd ${SG}
+ epatch ${FILESDIR}/splashutils-1.3-initrd-chvt.patch
+
+ cd ${S}
epatch ${FILESDIR}/splashutils-1.3-r2.patch
epatch ${FILESDIR}/splashutils-1.3-r2-fbsplash.patch