summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2010-03-19 17:31:05 +0000
committerDenis Dupeyron <calchan@gentoo.org>2010-03-19 17:31:05 +0000
commite0d315b943dd58a516e536ffce9a191dba1eb7ef (patch)
treef45634a0bfd3d41f868fa3d8c5714a6a221eec6c /media-gfx
parentAlso add warning and dont install useless files without QEMU_SOFTMMU_TARGETS=... (diff)
downloadgentoo-2-e0d315b943dd58a516e536ffce9a191dba1eb7ef.tar.gz
gentoo-2-e0d315b943dd58a516e536ffce9a191dba1eb7ef.tar.bz2
gentoo-2-e0d315b943dd58a516e536ffce9a191dba1eb7ef.zip
Saved in extremis from complete removal by Oliver Borm who provided a patch to build against Qt4, thanks a lot (bug #310125). Fixed bug #299788 also thanks to Oliver Borm.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/engauge/ChangeLog10
-rw-r--r--media-gfx/engauge/engauge-4.1-r1.ebuild51
2 files changed, 60 insertions, 1 deletions
diff --git a/media-gfx/engauge/ChangeLog b/media-gfx/engauge/ChangeLog
index 80382331d71e..03e452e38cf4 100644
--- a/media-gfx/engauge/ChangeLog
+++ b/media-gfx/engauge/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/engauge
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/ChangeLog,v 1.5 2010/03/09 11:35:13 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/ChangeLog,v 1.6 2010/03/19 17:31:05 calchan Exp $
+
+*engauge-4.1-r1 (19 Mar 2010)
+
+ 19 Mar 2010; <calchan@gentoo.org> +engauge-4.1-r1.ebuild,
+ +files/engauge-4.1_qt4.patch:
+ Saved in extremis from complete removal by Oliver Borm who provided a
+ patch to build against Qt4, thanks a lot (bug #310125). Fixed bug #299788
+ also thanks to Oliver Borm.
09 Mar 2010; Jonathan Callen <abcd@gentoo.org> engauge-4.1.ebuild:
QA: When not using an absolute path, you MUST NOT use a file extension
diff --git a/media-gfx/engauge/engauge-4.1-r1.ebuild b/media-gfx/engauge/engauge-4.1-r1.ebuild
new file mode 100644
index 000000000000..ac4bdf557dff
--- /dev/null
+++ b/media-gfx/engauge/engauge-4.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/engauge-4.1-r1.ebuild,v 1.1 2010/03/19 17:31:05 calchan Exp $
+
+EAPI=3
+
+inherit versionator qt4 eutils
+
+DESCRIPTION="Convert an image file showing a graph or map into numbers"
+HOMEPAGE="http://digitizer.sourceforge.net/"
+SRC_URI="mirror://sourceforge/digitizer/digit-src-$(replace_version_separator . _).tar.gz -> ${P}.tar.gz
+ http://dev.gentoo.org/~calchan/distfiles/${P}_qt4.patch.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="x11-libs/qt-qt3support
+ sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${DISTDIR}"/${P}_qt4.patch.xz
+
+ # Some patching and using the DEBIAN_PACKAGE ifdef is necessary to make sure the
+ # documentation is looked for in the proper directory
+ sed -i -e "s:/usr/share/doc/engauge-digitizer-doc:${ROOT}/usr/share/doc/${PF}:" \
+ src/digitmain.cpp || die "sed failed"
+ sed -i -e '/unix {/a DEFINES += DEBIAN_PACKAGE' \
+ digitizer.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 digitizer.pro
+}
+
+src_install() {
+ dobin bin/engauge
+ newicon src/img/lo32-app-digitizer.png "${PN}.png"
+ make_desktop_entry engauge "Engauge Digitizer" ${PN} Graphics
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins -r usermanual || die "install documentation failed"
+ fi
+ if use examples; then
+ doins -r samples || die "install examples failed"
+ fi
+}