summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-21 05:18:14 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-21 05:18:14 +0000
commitd644d6ea44c8b63a3fc0b98565ec3a89b628bb0d (patch)
tree3e816ffc492c8a897dff249df6f558577822b95c /media-gfx
parentversion bump (bug #453118) (diff)
downloadgentoo-2-d644d6ea44c8b63a3fc0b98565ec3a89b628bb0d.tar.gz
gentoo-2-d644d6ea44c8b63a3fc0b98565ec3a89b628bb0d.tar.bz2
gentoo-2-d644d6ea44c8b63a3fc0b98565ec3a89b628bb0d.zip
Fix cross-compiling with freetype while upstream sorts it out.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphicsmagick/ChangeLog9
-rw-r--r--media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch32
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild10
3 files changed, 45 insertions, 6 deletions
diff --git a/media-gfx/graphicsmagick/ChangeLog b/media-gfx/graphicsmagick/ChangeLog
index bb9da00ce0af..83e572cea458 100644
--- a/media-gfx/graphicsmagick/ChangeLog
+++ b/media-gfx/graphicsmagick/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/graphicsmagick
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.108 2012/10/15 06:03:16 radhermit Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.109 2013/01/21 05:18:13 vapier Exp $
+
+ 21 Jan 2013; Mike Frysinger <vapier@gentoo.org>
+ +files/graphicsmagick-1.3.17-freetype.patch, graphicsmagick-1.3.17.ebuild:
+ Fix cross-compiling with freetype while upstream sorts it out.
*graphicsmagick-1.3.17 (15 Oct 2012)
@@ -341,4 +345,3 @@
02 Aug 2008; Janne Rönkkö (jroo) <jroo@iki.fi>
+graphicsmagick-1.2.5.ebuild, +metadata.xml:
New Ebuild for bug 190372.
-
diff --git a/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch
new file mode 100644
index 000000000000..3ae4ad49f00b
--- /dev/null
+++ b/media-gfx/graphicsmagick/files/graphicsmagick-1.3.17-freetype.patch
@@ -0,0 +1,32 @@
+https://sourceforge.net/tracker/?func=detail&aid=3601612&group_id=73485&atid=537940
+
+--- a/configure
++++ b/configure
+@@ -26488,7 +26488,6 @@
+ # directory as GraphicsMagick installation prefix.
+ #LDFLAGS="$LDFLAGS -L$LIB_DIR"
+ #CPPFLAGS="$CPPFLAGS -I$INCLUDE_DIR"
+-MAGICK_API_CPPFLAGS="-I$INCLUDE_DIR/GraphicsMagick $MAGICK_API_CPPFLAGS"
+
+ #
+ # Find the X11 RGB database
+@@ -29490,8 +29490,8 @@
+ then
+ freetype_prefix=`${freetype_config} --prefix`
+ freetype_exec_prefix=`${freetype_config} --exec-prefix`
+- LDFLAGS="$LDFLAGS -L${freetype_exec_prefix}/lib"
+- CPPFLAGS="$CPPFLAGS -I${freetype_prefix}/include/freetype2"
++ LDFLAGS="$LDFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --libs`"
++ CPPFLAGS="$CPPFLAGS `${PKG_CONFIG:-pkg-config} freetype2 --cflags`"
+ fi
+
+ dnl First see if there is a library
+@@ -35767,7 +35767,7 @@
+
+ MAGICK_API_CFLAGS=$CFLAGS
+ MAGICK_API_CPPFLAGS=`echo $MAGICK_API_CPPFLAGS | sed -e 's/ */ /g'`
+-MAGICK_API_LDFLAGS="-L$LIB_DIR $LDFLAGS"
++MAGICK_API_LDFLAGS="$LDFLAGS"
+ MAGICK_API_DEP_LIBS="$MAGICK_DEP_LIBS $MAGICK_API_LIBLTDL"
+ MAGICK_API_LIBS="-lGraphicsMagick $MAGICK_API_DEP_LIBS"
+
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild
index 9fc6c935525b..8df3ddaefb48 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild,v 1.1 2012/10/15 06:03:16 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.17.ebuild,v 1.2 2013/01/21 05:18:13 vapier Exp $
EAPI=5
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
MY_P=${P/graphicsm/GraphicsM}
@@ -44,6 +44,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.3.17-freetype.patch
+}
+
src_configure() {
local depth=8
use q16 && depth=16