summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2009-10-01 07:53:21 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2009-10-01 07:53:21 +0000
commitb209d7160480ffe9a927662bab08003189025a43 (patch)
treef4a696ade2a0bcaa5aed114923e8f51246aa0aae /media-gfx
parentFix dependency on nxnode (diff)
downloadgentoo-2-b209d7160480ffe9a927662bab08003189025a43.tar.gz
gentoo-2-b209d7160480ffe9a927662bab08003189025a43.tar.bz2
gentoo-2-b209d7160480ffe9a927662bab08003189025a43.zip
Initial import from bug #274625.
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/iscan-plugin-gt-f720/ChangeLog11
-rw-r--r--media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild68
-rw-r--r--media-gfx/iscan-plugin-gt-f720/metadata.xml17
3 files changed, 96 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-gt-f720/ChangeLog b/media-gfx/iscan-plugin-gt-f720/ChangeLog
new file mode 100644
index 000000000000..04865074044d
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/iscan-plugin-gt-f720
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/iscan-plugin-gt-f720/ChangeLog,v 1.1 2009/10/01 07:53:21 elvanor Exp $
+
+*iscan-plugin-gt-f720-0.0.1 (01 Oct 2009)
+
+ 01 Oct 2009; Jean-Noël Rivasseau <elvanor@gentoo.org>
+ +iscan-plugin-gt-f720-0.0.1.ebuild:
+ Initial import from bug #274625. Ebuild contributed by W. Trevor King and
+ Will Lepofsky, thanks guys.
+
diff --git a/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild
new file mode 100644
index 000000000000..fa09af524bf7
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/iscan-plugin-gt-f720-0.0.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+EAPI="2"
+
+inherit rpm
+
+# Revision used by upstream
+SRC_REV="2"
+
+MY_P="esci-interpreter-gt-f720-${PV}"
+
+DESCRIPTION="Epson Perfection V300 PHOTO scanner plugin for SANE 'epkowa' backend."
+HOMEPAGE="http://www.avasys.jp/english/linux_e/dl_scan.html"
+SRC_URI="
+ x86? ( http://linux.avasys.jp/drivers/scanner-plugins/GT-F720/${MY_P}-${SRC_REV}.i386.rpm )
+ amd64? ( http://linux.avasys.jp/drivers/scanner-plugins/GT-F720/${MY_P}-${SRC_REV}.x86_64.rpm )"
+
+LICENSE="AVASYS"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+IUSE_LINGUAS="ja"
+
+for X in ${IUSE_LINGUAS}; do IUSE="${IUSE} linguas_${X}"; done
+
+DEPEND=">=media-gfx/iscan-2.21.0"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # install scanner firmware
+ insinto /usr/share/esci
+ doins "${WORKDIR}/usr/share/esci/"*
+
+ # install docs
+ if use linguas_ja; then
+ dodoc "usr/share/doc/${MY_P}/AVASYSPL.ja.txt"
+ else
+ dodoc "usr/share/doc/${MY_P}/AVASYSPL.en.txt"
+ fi
+
+ # install scanner plugins
+ insinto "${MY_LIB}/esci"
+ INSOPTIONS="-m0755"
+ doins "${WORKDIR}/usr/$(get_libdir)/esci/"*
+}
+
+pkg_postinst() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ # Needed for scaner to work properly.
+ iscan-registry --add interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+ elog
+ elog "Firmware file esfw8b.bin for Epson Perfection V300 PHOTO"
+ elog "has been installed in /usr/share/esci and registered for use."
+ elog
+}
+
+pkg_prerm() {
+ local MY_LIB="/usr/$(get_libdir)"
+
+ iscan-registry --remove interpreter usb 0x04b8 0x0131 "${MY_LIB}/esci/libesci-interpreter-gt-f720 /usr/share/esci/esfw8b.bin"
+}
+
diff --git a/media-gfx/iscan-plugin-gt-f720/metadata.xml b/media-gfx/iscan-plugin-gt-f720/metadata.xml
new file mode 100644
index 000000000000..1abde9039699
--- /dev/null
+++ b/media-gfx/iscan-plugin-gt-f720/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>elvanor@gentoo.org</email>
+ <name>Jean-Noël Rivasseau</name>
+ </maintainer>
+ <longdescription lang="en">
+ Proprietary plugin for several EPSON scanner models with the epkowa SANE backend (provided by media-gfx/iscan).
+ This particular plugin (f720) seems to be required for:
+ Epson GT-F720
+ Epson GT-S620
+ Epson Perfection V30
+ Epson Perfection V300 Photo
+ </longdescription>
+</pkgmetadata>