summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-03-26 02:53:24 +0000
committerTim Harder <radhermit@gentoo.org>2012-03-26 02:53:24 +0000
commit9c7f3cb979f8b7ce1b179e8a0b212513bb714729 (patch)
tree97ab81d37889d135d284990eedc7dcd490ab43f9 /media-gfx
parentAdd clutter-gst-1.5 to the clutter mask (diff)
downloadgentoo-2-9c7f3cb979f8b7ce1b179e8a0b212513bb714729.tar.gz
gentoo-2-9c7f3cb979f8b7ce1b179e8a0b212513bb714729.tar.bz2
gentoo-2-9c7f3cb979f8b7ce1b179e8a0b212513bb714729.zip
Version bump.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/feh/ChangeLog7
-rw-r--r--media-gfx/feh/feh-2.5.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/media-gfx/feh/ChangeLog b/media-gfx/feh/ChangeLog
index 0fed0fbc39f0..09f7b3b7356a 100644
--- a/media-gfx/feh/ChangeLog
+++ b/media-gfx/feh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/feh
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.104 2012/03/20 01:12:04 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/ChangeLog,v 1.105 2012/03/26 02:53:24 radhermit Exp $
+
+*feh-2.5 (26 Mar 2012)
+
+ 26 Mar 2012; Tim Harder <radhermit@gentoo.org> +feh-2.5.ebuild:
+ Version bump.
20 Mar 2012; Tim Harder <radhermit@gentoo.org> -feh-1.16.2.ebuild,
-feh-2.2.ebuild:
diff --git a/media-gfx/feh/feh-2.5.ebuild b/media-gfx/feh/feh-2.5.ebuild
new file mode 100644
index 000000000000..4e2d99b22ccc
--- /dev/null
+++ b/media-gfx/feh/feh-2.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-2.5.ebuild,v 1.1 2012/03/26 02:53:24 radhermit Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fast, lightweight imageviewer using imlib2"
+HOMEPAGE="http://feh.finalrewind.org/"
+SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug curl exif test xinerama"
+
+COMMON_DEPEND=">=media-libs/giblib-1.2.4
+ media-libs/imlib2
+ >=media-libs/libpng-1.2:0
+ x11-libs/libX11
+ curl? ( net-misc/curl )
+ exif? ( media-libs/libexif )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/jpeg"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/libXt
+ x11-proto/xproto
+ test? (
+ >=dev-lang/perl-5.10
+ dev-perl/Test-Command
+ )"
+
+pkg_setup() {
+ use_feh() { usex $1 1 0; }
+
+ fehopts=(
+ DESTDIR="${D}"
+ PREFIX=/usr
+ doc_dir='${main_dir}'/share/doc/${PF}
+ example_dir='${main_dir}'/share/doc/${PF}/examples
+ curl=$(use_feh curl)
+ debug=$(use_feh debug)
+ xinerama=$(use_feh xinerama)
+ exif=$(use_feh exif)
+ )
+}
+
+src_compile() {
+ tc-export CC
+ emake "${fehopts[@]}"
+}
+
+src_install() {
+ emake "${fehopts[@]}" install
+}