summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-07-21 06:33:54 +0000
committerJustin Lecher <jlec@gentoo.org>2014-07-21 06:33:54 +0000
commit81e8102e326745e1606d614d7e4fe9aa912946a9 (patch)
tree9947505a4ca8368b20123744156c7aa0791f040e /media-gfx
parentBump, hackfix for 3rdparty/dyncall compilation (diff)
downloadgentoo-2-81e8102e326745e1606d614d7e4fe9aa912946a9.tar.gz
gentoo-2-81e8102e326745e1606d614d7e4fe9aa912946a9.tar.bz2
gentoo-2-81e8102e326745e1606d614d7e4fe9aa912946a9.zip
media-gfx/shotwell: Backport fir for format-security, #517622; Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/ChangeLog8
-rw-r--r--media-gfx/shotwell/files/shotwell-0.15.1-format-security.patch11
-rw-r--r--media-gfx/shotwell/shotwell-0.15.1.ebuild5
-rw-r--r--media-gfx/shotwell/shotwell-0.18.1.ebuild103
4 files changed, 124 insertions, 3 deletions
diff --git a/media-gfx/shotwell/ChangeLog b/media-gfx/shotwell/ChangeLog
index 481054b92480..2173d16fb247 100644
--- a/media-gfx/shotwell/ChangeLog
+++ b/media-gfx/shotwell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/shotwell
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.69 2014/04/24 12:37:09 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/ChangeLog,v 1.70 2014/07/21 06:33:54 jlec Exp $
+
+*shotwell-0.18.1 (21 Jul 2014)
+
+ 21 Jul 2014; Justin Lecher <jlec@gentoo.org> shotwell-0.15.1.ebuild,
+ +shotwell-0.18.1.ebuild, +files/shotwell-0.15.1-format-security.patch:
+ Backport fir for format-security, #517622; Version Bump
*shotwell-0.18.0 (24 Apr 2014)
diff --git a/media-gfx/shotwell/files/shotwell-0.15.1-format-security.patch b/media-gfx/shotwell/files/shotwell-0.15.1-format-security.patch
new file mode 100644
index 000000000000..a4ad89b7a31d
--- /dev/null
+++ b/media-gfx/shotwell/files/shotwell-0.15.1-format-security.patch
@@ -0,0 +1,11 @@
+--- src/Dialogs.vala
++++ src/Dialogs.vala
+@@ -31,7 +31,7 @@
+
+ public bool confirm_warn_developer_changed(int number) {
+ Gtk.MessageDialog dialog = new Gtk.MessageDialog.with_markup(AppWindow.get_instance(),
+- Gtk.DialogFlags.MODAL, Gtk.MessageType.WARNING, Gtk.ButtonsType.NONE,
++ Gtk.DialogFlags.MODAL, Gtk.MessageType.WARNING, Gtk.ButtonsType.NONE, "%s",
+ "<span weight=\"bold\" size=\"larger\">%s</span>".printf(ngettext("Switching developers will undo all changes you have made to this photo in Shotwell",
+ "Switching developers will undo all changes you have made to these photos in Shotwell", number)));
+
diff --git a/media-gfx/shotwell/shotwell-0.15.1.ebuild b/media-gfx/shotwell/shotwell-0.15.1.ebuild
index 1a835945425f..ce6d42804051 100644
--- a/media-gfx/shotwell/shotwell-0.15.1.ebuild
+++ b/media-gfx/shotwell/shotwell-0.15.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.15.1.ebuild,v 1.3 2014/02/20 20:40:10 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.15.1.ebuild,v 1.4 2014/07/21 06:33:54 jlec Exp $
EAPI=5
@@ -83,7 +83,8 @@ src_prepare() {
-e 's|CFLAGS :|CFLAGS +|g' \
-i plugins/Makefile.plugin.mk || die
epatch \
- "${FILESDIR}"/${PN}-0.13.1-ldflags.patch
+ "${FILESDIR}"/${PN}-0.13.1-ldflags.patch \
+ "${FILESDIR}"/${P}-format-security.patch
}
src_configure() {
diff --git a/media-gfx/shotwell/shotwell-0.18.1.ebuild b/media-gfx/shotwell/shotwell-0.18.1.ebuild
new file mode 100644
index 000000000000..e28e663c3680
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.18.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/shotwell/shotwell-0.18.1.ebuild,v 1.1 2014/07/21 06:33:54 jlec Exp $
+
+EAPI=5
+
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.20"
+VALA_MAX_API_VERSION="0.22"
+
+inherit eutils gnome2 multilib toolchain-funcs vala versionator
+
+MY_PV=$(get_version_component_range 1-2)
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="http://yorba.org/shotwell/"
+SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+CORE_SUPPORTED_LANGUAGES="
+ af ar as ast bg bn bn_IN ca cs da de el en_GB eo es et eu fi fr gl gu he hi
+ hr hu ia id it ja kk km kn ko ky lt lv mk ml mr nb nl nn or pa pl pt pt_BR
+ ro ru sk sl sr sv ta te th tr uk vi zh_CN zh_HK zh_TW"
+
+for x in ${CORE_SUPPORTED_LANGUAGES}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="
+ app-text/gnome-doc-utils
+ >=dev-db/sqlite-3.5.9:3
+ >=dev-libs/dbus-glib-0.80
+ >=dev-libs/glib-2.30.0:2
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libgee-0.8.5:0.8
+ >=dev-libs/libxml2-2.6.32:2
+ >=dev-util/desktop-file-utils-0.13
+ gnome-base/dconf
+ >=media-libs/gexiv2-0.4.90
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ media-libs/gstreamer:1.0
+ media-libs/lcms:2
+ >=media-libs/libexif-0.6.16:=
+ >=media-libs/libgphoto2-2.4.2:=
+ >=media-libs/libraw-0.13.2:=
+ >=net-libs/libsoup-2.26.0:2.4
+ >=net-libs/rest-0.7:0.7
+ >=net-libs/webkit-gtk-1.4:3
+ >=virtual/udev-145[gudev]
+ >=x11-libs/gtk+-3.6.0:3"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=sys-devel/m4-1.4.13"
+
+DOCS=( AUTHORS MAINTAINERS NEWS README THANKS )
+
+# This probably comes from libraries that
+# shotwell-video-thumbnailer links to.
+# Nothing we can do at the moment. #435048
+QA_FLAGS_IGNORED="/usr/libexec/${PN}/${PN}-video-thumbnailer"
+
+pkg_setup() {
+ tc-export CC
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-desktop-update
+ --disable-icon-update
+ --prefix=/usr
+ --lib=$(get_libdir)"
+}
+
+src_prepare() {
+ vala_src_prepare
+ sed \
+ -e 's|CFLAGS :|CFLAGS +|g' \
+ -i plugins/Makefile.plugin.mk || die
+ epatch \
+ "${FILESDIR}"/${PN}-0.13.1-ldflags.patch
+}
+
+src_configure() {
+ ./configure \
+ ${G2CONF} \
+ || die
+}
+
+src_compile() {
+ local valaver="$(vala_best_api_version)"
+ emake VALAC="$(type -p valac-${valaver})"
+}
+
+src_install() {
+ gnome2_src_install
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ find "${D}"/usr/share/locale/${x} -type f -exec rm {} \;
+ fi
+ done
+}