summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-10-10 08:04:27 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-10-10 08:04:27 +0000
commit7f16e3645c31c4028291544034224c12dd77fdf5 (patch)
tree4153fd0c0cdc03ddb981f391ea4f26c85cfc2e1e /media-gfx
parentNew synaptics driver really needs xorg-server-1.7 so mask it (diff)
downloadgentoo-2-7f16e3645c31c4028291544034224c12dd77fdf5.tar.gz
gentoo-2-7f16e3645c31c4028291544034224c12dd77fdf5.tar.bz2
gentoo-2-7f16e3645c31c4028291544034224c12dd77fdf5.zip
Version bump and fix parallel build (bug #278417).
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/pstoedit/ChangeLog9
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.50-parallel.patch47
-rw-r--r--media-gfx/pstoedit/files/pstoedit-3.50-plugin-close.patch14
-rw-r--r--media-gfx/pstoedit/pstoedit-3.50.ebuild53
4 files changed, 122 insertions, 1 deletions
diff --git a/media-gfx/pstoedit/ChangeLog b/media-gfx/pstoedit/ChangeLog
index 09940156033a..f8b391a01e6f 100644
--- a/media-gfx/pstoedit/ChangeLog
+++ b/media-gfx/pstoedit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/pstoedit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.58 2009/09/18 22:47:33 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/ChangeLog,v 1.59 2009/10/10 08:04:27 dirtyepic Exp $
+
+*pstoedit-3.50 (10 Oct 2009)
+
+ 10 Oct 2009; Ryan Hill <dirtyepic@gentoo.org> +pstoedit-3.50.ebuild,
+ +files/pstoedit-3.50-parallel.patch,
+ +files/pstoedit-3.50-plugin-close.patch:
+ Version bump and fix parallel build (bug #278417).
*pstoedit-3.45-r1 (18 Sep 2009)
diff --git a/media-gfx/pstoedit/files/pstoedit-3.50-parallel.patch b/media-gfx/pstoedit/files/pstoedit-3.50-parallel.patch
new file mode 100644
index 000000000000..4f1f73b04528
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.50-parallel.patch
@@ -0,0 +1,47 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index d6178df..66f377b 100755
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -86,6 +86,7 @@ libp2edrvstd_la_SOURCES= \
+ $(sample_drivers_src)
+ libp2edrvstd_la_LIBADD=-L. libpstoedit.la
+ libp2edrvstd_la_LDFLAGS=-no-undefined -module
++libp2edrvstd_la_DEPENDENCIES = libpstoedit.la
+
+ #libp2edrvplugins_la_SOURCES=drvmif.cpp drvcgm.cpp drvrtf.cpp drvwwmf.cpp
+ #libp2edrvplugins_la_LIBADD=
+@@ -95,15 +96,18 @@ libp2edrvstd_la_LDFLAGS=-no-undefined -module
+ libp2edrvlplot_la_SOURCES=drvlplot.cpp drvlplot.h initlibrary.cpp
+ libp2edrvlplot_la_LIBADD=$(LIBPLOTTER_LDFLAGS) -L. libpstoedit.la
+ libp2edrvlplot_la_LDFLAGS=-no-undefined -module
++libp2edrvlplot_la_DEPENDENCIES = libpstoedit.la
+
+ libp2edrvswf_la_SOURCES=drvswf.cpp drvswf.h initlibrary.cpp
+ libp2edrvswf_la_LIBADD=$(LIBMING_LDFLAGS) -L. libpstoedit.la
+ libp2edrvswf_la_LDFLAGS=-no-undefined -module
++libp2edrvswf_la_DEPENDENCIES = libpstoedit.la
+
+ # note the __ stand for ++ - automake treats all no alphanums chars as _
+ libp2edrvmagick___la_SOURCES=drvmagick++.cpp drvmagick++.h initlibrary.cpp
+ libp2edrvmagick___la_LIBADD=-L. libpstoedit.la
+ libp2edrvmagick___la_LDFLAGS=-no-undefined ${LIBMAGICK_LDFLAGS} -module
++libp2edrvmagick___la_DEPENDENCIES = libpstoedit.la
+ # moved to configure.ac because needed only for g++ libp2edrvmagick___la_CPPFLAGS=$(LIBMAGICK_CFLAGS) $(AM_CPPFLAGS) -Wno-long-long
+
+ if USE_EMFBYSOURCE
+@@ -113,6 +117,7 @@ else
+ libp2edrvwmf_la_SOURCES=drvwmf.cpp drvwmf.h initlibrary.cpp
+ libp2edrvwmf_la_LDFLAGS=-no-undefined $(LIBEMF_LDFLAGS) -L. libpstoedit.la -module
+ endif
++libp2edrvwmf_la_DEPENDENCIES = libpstoedit.la
+
+ libpstoedit_la_SOURCES = \
+ dynload.cpp dynload.h \
+@@ -135,6 +140,7 @@ libpstoedit_la_LDFLAGS = -no-undefined
+
+ pstoedit_SOURCES = cmdmain.cpp
+ pstoedit_LDFLAGS = -no-undefined -L. libpstoedit.la ${LIBLD_LDFLAGS}
++pstoedit_DEPENDENCIES = libpstoedit.la
+
+ pkginclude_HEADERS = \
+ pstoedit.h \
diff --git a/media-gfx/pstoedit/files/pstoedit-3.50-plugin-close.patch b/media-gfx/pstoedit/files/pstoedit-3.50-plugin-close.patch
new file mode 100644
index 000000000000..6787d6aefd4a
--- /dev/null
+++ b/media-gfx/pstoedit/files/pstoedit-3.50-plugin-close.patch
@@ -0,0 +1,14 @@
+http://bugzilla.redhat.com/507035
+
+diff --git a/src/dynload.cpp b/src/dynload.cpp
+index c0db355..7c073ef 100644
+--- a/src/dynload.cpp
++++ b/src/dynload.cpp
+@@ -147,7 +147,6 @@ void DynLoader::close()
+
+ DynLoader::~DynLoader()
+ {
+- close();
+ libname=0;
+ }
+
diff --git a/media-gfx/pstoedit/pstoedit-3.50.ebuild b/media-gfx/pstoedit/pstoedit-3.50.ebuild
new file mode 100644
index 000000000000..61012f69827d
--- /dev/null
+++ b/media-gfx/pstoedit/pstoedit-3.50.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pstoedit/pstoedit-3.50.ebuild,v 1.1 2009/10/10 08:04:27 dirtyepic Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Translate PostScript and PDF graphics into other vector formats"
+HOMEPAGE="http://www.pstoedit.net/pstoedit"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="emf imagemagick plotutils"
+
+RDEPEND="media-libs/libpng
+ media-libs/gd
+ virtual/ghostscript
+ emf? ( >=media-libs/libemf-1.0.3 )
+ imagemagick? ( media-gfx/imagemagick[-nocxx] )
+ plotutils? ( media-libs/plotutils )"
+# swf? ( >=media-libs/ming-0.3 )" bug 238803
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e 's:-pedantic ::' -e 's:CXXFLAGS="-g"::' "${S}"/configure.ac
+ epatch "${FILESDIR}"/${P}-parallel.patch
+ epatch "${FILESDIR}"/${P}-plugin-close.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with emf) \
+ $(use_with imagemagick magick) \
+ $(use_with plotutils libplot) \
+ --without-swf \
+ || die 'econf failed'
+# $(use_with swf) \ # bug 238803
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die 'make install failed'
+ cd doc
+ dodoc readme.txt || die
+ dohtml *.htm || die
+ doman pstoedit.1 || die
+}