summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-03-28 17:38:05 +0000
committerPacho Ramos <pacho@gentoo.org>2013-03-28 17:38:05 +0000
commit6ff674f9ebf568a148a239acbf5f353d28740d99 (patch)
tree82b8f0ecf70ad14113ad3d5ec700dfc37b20759c /media-gfx
parentVersion bump for Gnome 3.8 (diff)
downloadgentoo-2-6ff674f9ebf568a148a239acbf5f353d28740d99.tar.gz
gentoo-2-6ff674f9ebf568a148a239acbf5f353d28740d99.tar.bz2
gentoo-2-6ff674f9ebf568a148a239acbf5f353d28740d99.zip
Version bump for Gnome 3.8
(Portage version: 2.1.11.58/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gnome-screenshot/ChangeLog10
-rw-r--r--media-gfx/gnome-screenshot/gnome-screenshot-3.8.0.ebuild51
2 files changed, 58 insertions, 3 deletions
diff --git a/media-gfx/gnome-screenshot/ChangeLog b/media-gfx/gnome-screenshot/ChangeLog
index 5723b86c692a..5a0d894615dc 100644
--- a/media-gfx/gnome-screenshot/ChangeLog
+++ b/media-gfx/gnome-screenshot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gnome-screenshot
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnome-screenshot/ChangeLog,v 1.3 2012/12/23 23:03:36 eva Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnome-screenshot/ChangeLog,v 1.4 2013/03/28 17:38:05 pacho Exp $
+
+*gnome-screenshot-3.8.0 (28 Mar 2013)
+
+ 28 Mar 2013; Pacho Ramos <pacho@gentoo.org> +gnome-screenshot-3.8.0.ebuild:
+ Version bump for Gnome 3.8
*gnome-screenshot-3.6.1 (23 Dec 2012)
@@ -18,4 +23,3 @@
+gnome-screenshot-3.4.1.ebuild, +metadata.xml:
New separate gnome screenshot package, formerly part of
gnome-extra/gnome-utils.
-
diff --git a/media-gfx/gnome-screenshot/gnome-screenshot-3.8.0.ebuild b/media-gfx/gnome-screenshot/gnome-screenshot-3.8.0.ebuild
new file mode 100644
index 000000000000..a871e431f130
--- /dev/null
+++ b/media-gfx/gnome-screenshot/gnome-screenshot-3.8.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gnome-screenshot/gnome-screenshot-3.8.0.ebuild,v 1.1 2013/03/28 17:38:05 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 readme.gentoo
+
+DESCRIPTION="Screenshot utility for GNOME 3"
+HOMEPAGE="https://live.gnome.org/GnomeUtils"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+
+# libcanberra 0.26-r2 is needed for gtk+:3 fixes
+COMMON_DEPEND="
+ >=dev-libs/glib-2.35.1:2
+ >=media-libs/libcanberra-0.26-r2[gtk3]
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ >=x11-libs/gtk+-3.0.3:3
+ x11-libs/libX11
+ x11-libs/libXext
+"
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xextproto
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="${P} saves screenshots in ~/Pictures/ and defaults to
+ non-interactive mode when launched from a terminal. If you want to choose
+ where to save the screenshot, run 'gnome-screenshot --interactive'"
+
+src_install() {
+ gnome2_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}