summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2009-06-12 19:31:54 +0000
committerMarkus Meier <maekke@gentoo.org>2009-06-12 19:31:54 +0000
commit6e5b4bd453aef5b03829430ae2228320442ceee7 (patch)
tree6e355d894cc3964a9181a009ce01881c8b1791d4 /media-gfx
parentadd alsa as default USE flag, bug 273762 (diff)
downloadgentoo-2-6e5b4bd453aef5b03829430ae2228320442ceee7.tar.gz
gentoo-2-6e5b4bd453aef5b03829430ae2228320442ceee7.tar.bz2
gentoo-2-6e5b4bd453aef5b03829430ae2228320442ceee7.zip
do not use -Werror during build wrt bug #272301
use gnome eclass and add USE=doc wrt bug #272303 add USE=examples and update mirror wrt bug #272620 (Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gtkimageview/ChangeLog7
-rw-r--r--media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild33
2 files changed, 31 insertions, 9 deletions
diff --git a/media-gfx/gtkimageview/ChangeLog b/media-gfx/gtkimageview/ChangeLog
index 8855df0df516..9c53aeaab2aa 100644
--- a/media-gfx/gtkimageview/ChangeLog
+++ b/media-gfx/gtkimageview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/gtkimageview
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkimageview/ChangeLog,v 1.3 2009/06/07 18:08:03 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkimageview/ChangeLog,v 1.4 2009/06/12 19:31:54 maekke Exp $
+
+ 12 Jun 2009; Markus Meier <maekke@gentoo.org> gtkimageview-1.6.4.ebuild:
+ do not use -Werror during build wrt bug #272301
+ use gnome eclass and add USE=doc wrt bug #272303
+ add USE=examples and update mirror wrt bug #272620
07 Jun 2009; Tobias Klausmann <klausman@gentoo.org>
gtkimageview-1.6.4.ebuild:
diff --git a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
index 014b523fd534..0b806292d692 100644
--- a/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
+++ b/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild
@@ -1,24 +1,38 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild,v 1.4 2009/06/07 18:08:03 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gtkimageview/gtkimageview-1.6.4.ebuild,v 1.5 2009/06/12 19:31:54 maekke Exp $
EAPI="2"
+inherit autotools gnome2
+
DESCRIPTION="GtkImageView is a simple image viewer widget for GTK."
HOMEPAGE="http://trac.bjourne.webfactional.com/wiki"
-SRC_URI="http://trac.bjourne.webfactional.com/attachment/wiki/WikiStart/${P}.tar.gz?format=raw
--> ${P}.tar.gz"
+SRC_URI="http://trac.bjourne.webfactional.com/attachment/wiki/WikiStart/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~x86"
-IUSE=""
+IUSE="doc examples"
# tests do not work with userpriv
RESTRICT="userpriv"
-DEPEND="gnome-base/gnome-common
+RDEPEND="gnome-base/gnome-common
>=x11-libs/gtk+-2.6"
-RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+pkg_setup() {
+ DOCS="README"
+ # apparently docs are always built...
+ use doc || export GTKDOC_REBASE=/bin/true
+}
+
+src_prepare() {
+ sed -i -e '/CFLAGS/s/-Werror //g' configure.in || die
+ gnome2_src_prepare
+ eautoreconf
+}
src_test() {
# the tests are only built, but not run by default
@@ -34,6 +48,9 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README || die
+ gnome2_src_install
+ if use examples ; then
+ docinto examples
+ dodoc tests/ex-*.c || die
+ fi
}