summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-09-07 13:34:32 +0000
committerMarkus Meier <maekke@gentoo.org>2008-09-07 13:34:32 +0000
commit5659f39e99f6f0f7a80c67f0850c9af18e2769b2 (patch)
tree2bd83a22f3c112607dafd503b07ae6751eadf573 /media-gfx
parentEbuild requested in #236716 and based on Michele Beltrame's ebuild from the p... (diff)
downloadgentoo-2-5659f39e99f6f0f7a80c67f0850c9af18e2769b2.tar.gz
gentoo-2-5659f39e99f6f0f7a80c67f0850c9af18e2769b2.tar.bz2
gentoo-2-5659f39e99f6f0f7a80c67f0850c9af18e2769b2.zip
bump to 2.47, bug #235776
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/blender/ChangeLog9
-rw-r--r--media-gfx/blender/blender-2.47-r1.ebuild141
-rw-r--r--media-gfx/blender/blender-2.47.ebuild141
-rw-r--r--media-gfx/blender/metadata.xml9
4 files changed, 299 insertions, 1 deletions
diff --git a/media-gfx/blender/ChangeLog b/media-gfx/blender/ChangeLog
index 2b63465d34ae..27996b84bcc5 100644
--- a/media-gfx/blender/ChangeLog
+++ b/media-gfx/blender/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/blender
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.146 2008/08/22 21:24:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/ChangeLog,v 1.147 2008/09/07 13:34:32 maekke Exp $
+
+*blender-2.47-r1 (07 Sep 2008)
+*blender-2.47 (07 Sep 2008)
+
+ 07 Sep 2008; Markus Meier <maekke@gentoo.org> +blender-2.47.ebuild,
+ +blender-2.47-r1.ebuild:
+ bump to 2.47, bug #235776
22 Aug 2008; Markus Meier <maekke@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/media-gfx/blender/blender-2.47-r1.ebuild b/media-gfx/blender/blender-2.47-r1.ebuild
new file mode 100644
index 000000000000..f14b32e65c20
--- /dev/null
+++ b/media-gfx/blender/blender-2.47-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.47-r1.ebuild,v 1.1 2008/09/07 13:34:32 maekke Exp $
+
+inherit multilib flag-o-matic eutils python
+
+#IUSE="jpeg mozilla png sdl static truetype"
+IUSE="blender-game bullet ffmpeg jpeg nls openal openexr openmp
+ player png quicktime verse"
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BL )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+ jpeg? ( media-libs/jpeg )
+ media-libs/tiff
+ >=dev-lang/python-2.4
+ nls? ( >=media-libs/freetype-2.0
+ virtual/libintl
+ >=media-libs/ftgl-2.1 )
+ openal? ( media-libs/openal
+ media-libs/freealut )
+ openexr? ( media-libs/openexr )
+ png? ( media-libs/libpng )
+ quicktime? ( media-libs/libquicktime )
+ >=media-libs/libsdl-1.2
+ virtual/opengl"
+
+DEPEND=">=dev-util/scons-0.98
+ x11-libs/libXt
+ x11-proto/inputproto
+ ${RDEPEND}"
+
+blend_with() {
+ local UWORD="$2"
+ if [ -z "${UWORD}" ]; then
+ UWORD="$1"
+ fi
+ if useq $1; then
+ echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ else
+ echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/blender-2.37-dirs.patch
+ epatch "${FILESDIR}"/blender-2.44-scriptsdir.patch
+ epatch "${FILESDIR}"/blender-2.46-ffmpeg.patch
+ epatch "${FILESDIR}"/blender-2.46-cve-2008-1103-1.patch
+
+ if use ffmpeg ; then
+ cd "${S}"/extern
+# rm -rf ffmpeg libmp3lame x264
+ cat <<- EOF >> "${S}"/user-config.py
+ BF_FFMPEG="/usr"
+ BF_FFMPEG_LIB="avformat avcodec swscale avutil"
+ EOF
+ fi
+ # pass compiler flags to the scons build system
+ # and set python version to current version in use
+ python_version
+ cat <<- EOF >> "${S}"/user-config.py
+ CFLAGS += '${CFLAGS}'
+ BF_PYTHON_VERSION="${PYVER}"
+ BF_PYTHON_INC="/usr/include/python${PYVER}"
+ BF_PYTHON_BINARY="/usr/bin/python${PYVER}"
+ BF_PYTHON_LIB="python${PYVER}"
+ EOF
+
+}
+
+src_compile() {
+ for arg in \
+ 'blender-game gameengine' \
+ 'bullet' \
+ 'nls international' \
+ 'openal' \
+ 'openexr' \
+ 'openmp' \
+ 'player' \
+ 'verse' ; do
+ blend_with ${arg}
+ done
+
+ # scons uses -l differently -> remove it
+ scons ${MAKEOPTS/-l[0-9]} || die \
+ "!!! Please add ${S}/scons.config when filing bugs reports to bugs.gentoo.org"
+
+ cd "${WORKDIR}"/install/linux2/plugins
+ chmod 755 bmake
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe "${WORKDIR}"/install/linux2/blender
+
+ dodir /usr/share/${PN}
+
+ exeinto /usr/$(get_libdir)/${PN}/textures
+ doexe "${WORKDIR}"/install/linux2/plugins/texture/*.so
+ exeinto /usr/$(get_libdir)/${PN}/sequences
+ doexe "${WORKDIR}"/install/linux2/plugins/sequence/*.so
+ insinto /usr/include/${PN}
+ doins "${WORKDIR}"/install/linux2/plugins/include/*.h
+
+ if use nls ; then
+ mv "${WORKDIR}"/install/linux2/.blender/{.Blanguages,.bfont.ttf} \
+ "${D}"/usr/share/${PN}
+ mv "${WORKDIR}"/install/linux2/.blender/locale \
+ "${D}"/usr/share/locale
+ fi
+
+ mv "${WORKDIR}"/install/linux2/.blender/scripts "${D}"/usr/share/${PN}
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+
+ dodoc INSTALL README
+ dodoc "${WORKDIR}"/install/linux2/BlenderQuickStart.pdf
+}
+
+pkg_preinst(){
+ if [ -h "${ROOT}/usr/$(get_libdir)/blender/plugins/include" ];
+ then
+ rm -f "${ROOT}"/usr/$(get_libdir)/blender/plugins/include
+ fi
+}
diff --git a/media-gfx/blender/blender-2.47.ebuild b/media-gfx/blender/blender-2.47.ebuild
new file mode 100644
index 000000000000..4b053dae88be
--- /dev/null
+++ b/media-gfx/blender/blender-2.47.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.47.ebuild,v 1.1 2008/09/07 13:34:32 maekke Exp $
+
+inherit multilib flag-o-matic eutils python
+
+#IUSE="jpeg mozilla png sdl static truetype"
+IUSE="blender-game bullet ffmpeg jpeg nls openal openexr openmp
+ player png quicktime verse"
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 BL )"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/openssl-0.9.6
+ ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20070616-r1
+ media-libs/x264 )
+ jpeg? ( media-libs/jpeg )
+ media-libs/tiff
+ >=dev-lang/python-2.4
+ nls? ( >=media-libs/freetype-2.0
+ virtual/libintl
+ >=media-libs/ftgl-2.1 )
+ openal? ( media-libs/openal
+ media-libs/freealut )
+ openexr? ( media-libs/openexr )
+ png? ( media-libs/libpng )
+ quicktime? ( media-libs/libquicktime )
+ >=media-libs/libsdl-1.2
+ virtual/opengl"
+
+DEPEND=">=dev-util/scons-0.98
+ x11-libs/libXt
+ x11-proto/inputproto
+ ${RDEPEND}"
+
+blend_with() {
+ local UWORD="$2"
+ if [ -z "${UWORD}" ]; then
+ UWORD="$1"
+ fi
+ if useq $1; then
+ echo "WITH_BF_${UWORD}=1" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ else
+ echo "WITH_BF_${UWORD}=0" | tr '[:lower:]' '[:upper:]' \
+ >> "${S}"/user-config.py
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/blender-2.37-dirs.patch
+ epatch "${FILESDIR}"/blender-2.44-scriptsdir.patch
+ epatch "${FILESDIR}"/blender-2.46-cve-2008-1103-1.patch
+
+ if use ffmpeg ; then
+ cd "${S}"/extern
+# rm -rf ffmpeg libmp3lame x264
+ cat <<- EOF >> "${S}"/user-config.py
+ BF_FFMPEG="/usr"
+ BF_FFMPEG_LIB="avformat avcodec swscale avutil"
+ EOF
+ fi
+ # pass compiler flags to the scons build system
+ # and set python version to current version in use
+ python_version
+ cat <<- EOF >> "${S}"/user-config.py
+ CFLAGS += '${CFLAGS}'
+ BF_PYTHON_VERSION="${PYVER}"
+ BF_PYTHON_INC="/usr/include/python${PYVER}"
+ BF_PYTHON_BINARY="/usr/bin/python${PYVER}"
+ BF_PYTHON_LIB="python${PYVER}"
+ EOF
+
+}
+
+src_compile() {
+ for arg in \
+ 'blender-game gameengine' \
+ 'bullet' \
+ 'nls international' \
+ 'openal' \
+ 'openexr' \
+ 'openmp' \
+ 'player' \
+ 'verse' ; do
+ blend_with ${arg}
+ done
+
+ # scons uses -l differently -> remove it
+ scons ${MAKEOPTS/-l[0-9]} || die \
+ "!!! Please add ${S}/scons.config when filing bugs reports to bugs.gentoo.org"
+
+ cd "${WORKDIR}"/install/linux2/plugins
+ chmod 755 bmake
+ emake || die
+}
+
+src_install() {
+ exeinto /usr/bin/
+ doexe "${WORKDIR}"/install/linux2/blender
+
+ dodir /usr/share/${PN}
+
+ exeinto /usr/$(get_libdir)/${PN}/textures
+ doexe "${WORKDIR}"/install/linux2/plugins/texture/*.so
+ exeinto /usr/$(get_libdir)/${PN}/sequences
+ doexe "${WORKDIR}"/install/linux2/plugins/sequence/*.so
+ insinto /usr/include/${PN}
+ doins "${WORKDIR}"/install/linux2/plugins/include/*.h
+
+ if use nls ; then
+ mv "${WORKDIR}"/install/linux2/.blender/{.Blanguages,.bfont.ttf} \
+ "${D}"/usr/share/${PN}
+ mv "${WORKDIR}"/install/linux2/.blender/locale \
+ "${D}"/usr/share/locale
+ fi
+
+ mv "${WORKDIR}"/install/linux2/.blender/scripts "${D}"/usr/share/${PN}
+
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+
+ dodoc INSTALL README
+ dodoc "${WORKDIR}"/install/linux2/BlenderQuickStart.pdf
+}
+
+pkg_preinst(){
+ if [ -h "${ROOT}/usr/$(get_libdir)/blender/plugins/include" ];
+ then
+ rm -f "${ROOT}"/usr/$(get_libdir)/blender/plugins/include
+ fi
+}
diff --git a/media-gfx/blender/metadata.xml b/media-gfx/blender/metadata.xml
index b6ff62d34cb2..bf2fbe2e681b 100644
--- a/media-gfx/blender/metadata.xml
+++ b/media-gfx/blender/metadata.xml
@@ -16,6 +16,15 @@
<flag name='blender-game'>
Adds game engine support to blender
</flag>
+ <flag name='bullet'>
+ Enable Bullet (Physics Engine)
+ </flag>
+ <flag name='openmp'>
+ build support for the OpenMP (support parallel computing), requires sys-devel/gcc-4.3 built with USE="openmp"
+ </flag>
+ <flag name='player'>
+ Enable blender player
+ </flag>
<flag name='verse'>
Adds verse clustering features to blender
</flag>