summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2010-12-25 12:54:53 +0000
committerMarkus Meier <maekke@gentoo.org>2010-12-25 12:54:53 +0000
commit50b7f5ae5a00e7ff0e5404959e41319f22c761a4 (patch)
tree562cc6236609539c48d9d35c914c0fee3195ac8d /media-gfx
parentBump EAPI=3 for Prefix, add support for Darwin, marked ~x86-linux, ~amd64-lin... (diff)
downloadgentoo-2-50b7f5ae5a00e7ff0e5404959e41319f22c761a4.tar.gz
gentoo-2-50b7f5ae5a00e7ff0e5404959e41319f22c761a4.tar.bz2
gentoo-2-50b7f5ae5a00e7ff0e5404959e41319f22c761a4.zip
version bump
(Portage version: 2.1.9.26/cvs/Linux i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/ChangeLog7
-rw-r--r--media-gfx/hugin/hugin-2010.4.0_rc1.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index 071203cf6248..a3566f733636 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.104 2010/12/05 16:30:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.105 2010/12/25 12:54:53 maekke Exp $
+
+*hugin-2010.4.0_rc1 (25 Dec 2010)
+
+ 25 Dec 2010; Markus Meier <maekke@gentoo.org> +hugin-2010.4.0_rc1.ebuild:
+ version bump
05 Dec 2010; Markos Chandras <hwoarang@gentoo.org> hugin-2010.2.0.ebuild:
Stable on amd64 wrt bug #347633
diff --git a/media-gfx/hugin/hugin-2010.4.0_rc1.ebuild b/media-gfx/hugin/hugin-2010.4.0_rc1.ebuild
new file mode 100644
index 000000000000..4735348310c8
--- /dev/null
+++ b/media-gfx/hugin/hugin-2010.4.0_rc1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-2010.4.0_rc1.ebuild,v 1.1 2010/12/25 12:54:53 maekke Exp $
+
+EAPI=2
+WX_GTK_VER="2.8"
+
+inherit cmake-utils wxwidgets versionator
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+LANGS=" bg ca cs de en_GB es es_LA fi fr hu it ja ko nl pl pt_BR ru sk sl sv uk zh_CN zh_TW"
+IUSE="lapack sift $(echo ${LANGS//\ /\ linguas_})"
+
+CDEPEND="
+ !!dev-util/cocom
+ app-arch/zip
+ >=dev-libs/boost-1.35.0-r5
+ >=media-gfx/enblend-3.0_p20080807
+ media-gfx/exiv2
+ media-libs/freeglut
+ >=media-libs/libpano13-2.9.17
+ media-libs/libpng
+ media-libs/openexr
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/wxGTK:2.8[opengl,-odbc]
+ lapack? ( virtual/lapack )
+ sift? ( media-gfx/autopano-sift-C )"
+RDEPEND="${CDEPEND}
+ media-libs/exiftool"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+pkg_setup() {
+ DOCS="authors.txt README TODO"
+ mycmakeargs=( $(cmake-utils_use_enable lapack LAPACK) )
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ for lang in ${LANGS} ; do
+ case ${lang} in
+ ca) dir=ca_ES;;
+ cs) dir=cs_CZ;;
+ es_LA) dir=es_la;;
+ *) dir=${lang};;
+ esac
+ use linguas_${lang} || rm -r "${D}"/usr/share/locale/${dir}
+ done
+}
+
+pkg_postinst() {
+ elog "Please note that the sift USE-flag has been disabled by default"
+ elog "as hugin ships its own control point generator with 2010.4"
+}