summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2007-05-06 13:20:09 +0000
committerMichael Januszewski <spock@gentoo.org>2007-05-06 13:20:09 +0000
commit4bf4d16655bec56da454bfa62abc80e78ca972c8 (patch)
tree9ecc45d64d19ac9f8f75b223249eecad2c33bd3a /media-gfx
parentReplacing einfo with elog (diff)
downloadgentoo-2-4bf4d16655bec56da454bfa62abc80e78ca972c8.tar.gz
gentoo-2-4bf4d16655bec56da454bfa62abc80e78ca972c8.tar.bz2
gentoo-2-4bf4d16655bec56da454bfa62abc80e78ca972c8.zip
Version bump (bug #177055).
(Portage version: 2.1.2.6)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fbida/ChangeLog7
-rw-r--r--media-gfx/fbida/fbida-2.06.ebuild93
-rw-r--r--media-gfx/fbida/files/digest-fbida-2.063
3 files changed, 102 insertions, 1 deletions
diff --git a/media-gfx/fbida/ChangeLog b/media-gfx/fbida/ChangeLog
index 8b64f896f719..9a772304080e 100644
--- a/media-gfx/fbida/ChangeLog
+++ b/media-gfx/fbida/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/fbida
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbida/ChangeLog,v 1.30 2007/04/22 14:38:30 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbida/ChangeLog,v 1.31 2007/05/06 13:20:09 spock Exp $
+
+*fbida-2.06 (06 May 2007)
+
+ 06 May 2007; Michał Januszewski <spock@gentoo.org> +fbida-2.06.ebuild:
+ Version bump (bug #177055).
22 Apr 2007; Michał Januszewski <spock@gentoo.org> fbida-2.03-r4.ebuild,
fbida-2.05.ebuild:
diff --git a/media-gfx/fbida/fbida-2.06.ebuild b/media-gfx/fbida/fbida-2.06.ebuild
new file mode 100644
index 000000000000..dd691c5bcdbb
--- /dev/null
+++ b/media-gfx/fbida/fbida-2.06.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fbida/fbida-2.06.ebuild,v 1.1 2007/05/06 13:20:09 spock Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Image viewers for the framebuffer console (fbi) and X11 (ida)."
+HOMEPAGE="http://linux.bytesex.org/fbida/"
+SRC_URI="http://dl.bytesex.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="png jpeg gif tiff curl lirc X fbcon pdf"
+
+RDEPEND="jpeg? ( >=media-libs/jpeg-6b )
+ png? ( media-libs/libpng )
+ gif? ( media-libs/giflib )
+ pdf? ( virtual/ghostscript media-libs/tiff )
+ tiff? ( media-libs/tiff )
+ curl? ( net-misc/curl )
+ lirc? ( app-misc/lirc )
+ X? ( || ( ( x11-libs/libX11 x11-libs/libXt x11-libs/libXpm )
+ virtual/x11 )
+ virtual/motif )
+ !media-gfx/fbi
+ media-libs/libexif
+ >=media-libs/freetype-2.0
+ >=media-libs/fontconfig-2.2
+ media-fonts/ttf-bitstream-vera"
+
+DEPEND="${RDEPEND}
+ X? ( || ( ( x11-proto/xextproto x11-proto/xproto )
+ virtual/x11 ) )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e 's/DGifOpenFileName,ungif/DGifOpenFileName,gif/' \
+ -e 's/-lungif/-lgif/' -i ${S}/GNUmakefile
+
+ if [[ `gcc-major-version` -lt 4 ]]; then
+ sed -e 's/-Wno-pointer-sign//' -i ${S}/GNUmakefile
+ fi
+
+ # We don't want the binaries to be stripped automatically.
+ sed -i -e 's/$(INSTALL) -s/$(INSTALL)/' ${S}/mk/Variables.mk
+
+ epatch ${FILESDIR}/fbida-2.05-asmpage-fix.patch
+}
+
+src_compile() {
+ # Let autoconf do its job and then fix things to build fbida
+ # according to our specifications
+ emake Make.config || die
+
+ set_feat() {
+ local useflag=${1}
+ local config=${2}
+
+ local option="yes"
+ if ! use ${useflag}; then
+ option="no"
+ fi
+
+ sed -e "s/${config}.*/${config} := ${option}/" -i ${S}/Make.config
+ }
+
+ set_feat fbcon HAVE_LINUX_FB_H
+ set_feat X HAVE_MOTIF
+ set_feat tiff HAVE_LIBTIFF
+
+ # The 'pdf' flag forces the use of libtiff.
+ set_feat pdf HAVE_LIBTIFF
+ set_feat png HAVE_LIBPNG
+ set_feat gif HAVE_LIBUNGIF
+ set_feat lirc HAVE_LIBLIRC
+ set_feat curl HAVE_LIBCURL
+
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ prefix=/usr \
+ install || die
+ dodoc README
+
+ if ! use pdf; then
+ rm -f ${D}/usr/bin/fbgs ${D}/usr/share/man/man1/fbgs.1
+ fi
+}
diff --git a/media-gfx/fbida/files/digest-fbida-2.06 b/media-gfx/fbida/files/digest-fbida-2.06
new file mode 100644
index 000000000000..3040eb48753c
--- /dev/null
+++ b/media-gfx/fbida/files/digest-fbida-2.06
@@ -0,0 +1,3 @@
+MD5 1f78e9a83fb546660a024a4bc0580ace fbida-2.06.tar.gz 207707
+RMD160 71cee41934a15c7f1e633743ba5e7499610b8377 fbida-2.06.tar.gz 207707
+SHA256 6d0d2a553940fb36ab673332f4552ba6943852d795af9618138322178fe1aeac fbida-2.06.tar.gz 207707