summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-03-24 05:52:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-03-24 05:52:29 +0000
commit46a189aaf4b9645c8ea7166c3d3f708a183ba1a4 (patch)
tree60127816736af76a94fa498b158d32e79449ce60 /media-gfx
parentStable for HPPA (bug #307889). (diff)
downloadgentoo-2-46a189aaf4b9645c8ea7166c3d3f708a183ba1a4.tar.gz
gentoo-2-46a189aaf4b9645c8ea7166c3d3f708a183ba1a4.tar.bz2
gentoo-2-46a189aaf4b9645c8ea7166c3d3f708a183ba1a4.zip
Now install perl modules in vendor instead of site-dir, bug #310839
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/graphicsmagick/ChangeLog7
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.10.ebuild126
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild126
-rw-r--r--media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild3
4 files changed, 8 insertions, 254 deletions
diff --git a/media-gfx/graphicsmagick/ChangeLog b/media-gfx/graphicsmagick/ChangeLog
index f96466d39cb3..9227fcdaa785 100644
--- a/media-gfx/graphicsmagick/ChangeLog
+++ b/media-gfx/graphicsmagick/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/graphicsmagick
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.63 2010/03/21 10:34:32 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/ChangeLog,v 1.64 2010/03/24 05:52:29 bicatali Exp $
+
+ 24 Mar 2010; Sébastien Fabbro <bicatali@gentoo.org>
+ -graphicsmagick-1.3.10.ebuild, -graphicsmagick-1.3.11.ebuild,
+ graphicsmagick-1.3.12.ebuild:
+ Now install perl modules in vendor instead of site-dir, bug #310839
21 Mar 2010; Fabian Groffen <grobian@gentoo.org>
graphicsmagick-1.3.12.ebuild:
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.10.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.10.ebuild
deleted file mode 100644
index e5f6c5824822..000000000000
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.10.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.10.ebuild,v 1.2 2010/02/20 19:05:28 armin76 Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs flag-o-matic perl-module
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="bzip2 cxx debug doc fpx imagemagick jbig jpeg jpeg2k lcms openmp
- perl png q16 q32 svg threads tiff truetype X wmf zlib"
-
-RDEPEND="app-text/ghostscript-gpl
- bzip2? ( app-arch/bzip2 )
- fpx? ( media-libs/libfpx )
- jbig? ( media-libs/jbigkit )
- jpeg? ( media-libs/jpeg )
- jpeg2k? ( >=media-libs/jasper-1.701.0 )
- lcms? ( media-libs/lcms )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- svg? ( dev-libs/libxml2 )
- tiff? ( >=media-libs/tiff-3.8.2 )
- truetype? ( >=media-libs/freetype-2.0 )
- wmf? ( media-libs/libwmf )
- X? ( x11-libs/libXext x11-libs/libSM )
- imagemagick? ( !media-gfx/imagemagick )"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! built_with_use sys-devel/gcc openmp )
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- ewarn "If you want to build fftw with OpenMP, abort now,"
- ewarn "and switch CC to an OpenMP capable compiler"
- epause 5
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.7-perl-ldflags.patch"
- epatch "${FILESDIR}/${PN}-1.3.7-debian-fixed.patch"
-}
-
-src_configure() {
- local quantumDepth
- if use q16 ; then
- quantumDepth="16"
- elif use q32 ; then
- quantumDepth="32"
- else
- quantumDepth="8"
- fi
-
- use debug && filter-flags -fomit-frame-pointer
- econf \
- --docdir=/usr/share/doc/${PF} \
- --htmldir=/usr/share/doc/${PF}/html \
- --enable-shared \
- --enable-largefile \
- --without-included-ltdl \
- --without-frozenpaths \
- --without-gslib \
- --with-modules \
- --with-quantum-depth=${quantumDepth} \
- --with-fontpath="/usr/share/fonts" \
- --with-gs-font-dir="/usr/share/fonts/default/ghostscript" \
- --with-windows-font-dir="/usr/share/fonts/corefonts" \
- $(use_enable debug ccmalloc) \
- $(use_enable debug prof) \
- $(use_enable debug gcov) \
- $(use_enable imagemagick magick-compat) \
- $(use_enable openmp) \
- $(use_with bzip2 bzlib) \
- $(use_with cxx magick-plus-plus) \
- $(use_with fpx) \
- $(use_with jbig) \
- $(use_with jpeg) \
- $(use_with jpeg2k jp2) \
- $(use_with lcms) \
- $(use_with perl) \
- $(use_with png) \
- $(use_with svg xml) \
- $(use_with threads) \
- $(use_with tiff) \
- $(use_with truetype ttf) \
- $(use_with wmf) \
- $(use_with X x) \
- $(use_with zlib)
-}
-
-src_compile() {
- emake || die "emake failed"
- if use perl; then
- emake perl-build || die "emake perl failed"
- fi
-}
-
-src_test() {
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use perl; then
- perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
- emake -C PerlMagick DESTDIR="${D}" \
- install || die "emake perl install failed"
- fixlocalpod
- fi
- use doc || rm -rf "${D}"usr/share/doc/${PF}/html
-}
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild
deleted file mode 100644
index bc9d535b92be..000000000000
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.11.ebuild,v 1.3 2010/03/11 14:57:28 josejx Exp $
-
-EAPI="2"
-
-inherit eutils toolchain-funcs flag-o-matic perl-module
-
-MY_P=${P/graphicsm/GraphicsM}
-
-DESCRIPTION="Collection of tools and libraries for many image formats"
-HOMEPAGE="http://www.graphicsmagick.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="bzip2 cxx debug doc fpx imagemagick jbig jpeg jpeg2k lcms openmp
- perl png q16 q32 svg threads tiff truetype X wmf zlib"
-
-RDEPEND="app-text/ghostscript-gpl
- bzip2? ( app-arch/bzip2 )
- fpx? ( media-libs/libfpx )
- jbig? ( media-libs/jbigkit )
- jpeg? ( media-libs/jpeg )
- jpeg2k? ( >=media-libs/jasper-1.701.0 )
- lcms? ( media-libs/lcms )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- svg? ( dev-libs/libxml2 )
- tiff? ( >=media-libs/tiff-3.8.2 )
- truetype? ( >=media-libs/freetype-2.0 )
- wmf? ( media-libs/libwmf )
- X? ( x11-libs/libXext x11-libs/libSM )
- imagemagick? ( !media-gfx/imagemagick )"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! has_version sys-devel/gcc[openmp] )
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
- ewarn "If you want to build fftw with OpenMP, abort now,"
- ewarn "and switch CC to an OpenMP capable compiler"
- epause 5
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-1.3.7-perl-ldflags.patch"
- epatch "${FILESDIR}/${PN}-1.3.7-debian-fixed.patch"
-}
-
-src_configure() {
- local quantumDepth
- if use q16 ; then
- quantumDepth="16"
- elif use q32 ; then
- quantumDepth="32"
- else
- quantumDepth="8"
- fi
-
- use debug && filter-flags -fomit-frame-pointer
- econf \
- --docdir=/usr/share/doc/${PF} \
- --htmldir=/usr/share/doc/${PF}/html \
- --enable-shared \
- --enable-largefile \
- --without-included-ltdl \
- --without-frozenpaths \
- --without-gslib \
- --with-modules \
- --with-quantum-depth=${quantumDepth} \
- --with-fontpath="/usr/share/fonts" \
- --with-gs-font-dir="/usr/share/fonts/default/ghostscript" \
- --with-windows-font-dir="/usr/share/fonts/corefonts" \
- $(use_enable debug ccmalloc) \
- $(use_enable debug prof) \
- $(use_enable debug gcov) \
- $(use_enable imagemagick magick-compat) \
- $(use_enable openmp) \
- $(use_with bzip2 bzlib) \
- $(use_with cxx magick-plus-plus) \
- $(use_with fpx) \
- $(use_with jbig) \
- $(use_with jpeg) \
- $(use_with jpeg2k jp2) \
- $(use_with lcms) \
- $(use_with perl) \
- $(use_with png) \
- $(use_with svg xml) \
- $(use_with threads) \
- $(use_with tiff) \
- $(use_with truetype ttf) \
- $(use_with wmf) \
- $(use_with X x) \
- $(use_with zlib)
-}
-
-src_compile() {
- emake || die "emake failed"
- if use perl; then
- emake perl-build || die "emake perl failed"
- fi
-}
-
-src_test() {
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- if use perl; then
- perl -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
- emake -C PerlMagick DESTDIR="${D}" \
- install || die "emake perl install failed"
- fixlocalpod
- fi
- use doc || rm -rf "${D}"usr/share/doc/${PF}/html
-}
diff --git a/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild b/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild
index c811584f1cd1..23490d1053f2 100644
--- a/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild
+++ b/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild,v 1.4 2010/03/21 20:21:50 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphicsmagick/graphicsmagick-1.3.12.ebuild,v 1.5 2010/03/24 05:52:29 bicatali Exp $
EAPI="2"
@@ -83,6 +83,7 @@ src_configure() {
--with-fontpath="${EPREFIX}/usr/share/fonts" \
--with-gs-font-dir="${EPREFIX}/usr/share/fonts/default/ghostscript" \
--with-windows-font-dir="${EPREFIX}/usr/share/fonts/corefonts" \
+ --with-perl-options="INSTALLDIRS=vendor" \
$(use_enable debug ccmalloc) \
$(use_enable debug prof) \
$(use_enable debug gcov) \