summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-30 21:36:05 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2012-06-30 21:36:05 +0000
commit3f63d66ca9b0c5ff0fab3d73ec176aeebe86ac1a (patch)
treea98579d18a58ad3d446eff9eb82ee6c13c50d28d /media-gfx
parentVersion bump, remove old. (diff)
downloadgentoo-2-3f63d66ca9b0c5ff0fab3d73ec176aeebe86ac1a.tar.gz
gentoo-2-3f63d66ca9b0c5ff0fab3d73ec176aeebe86ac1a.tar.bz2
gentoo-2-3f63d66ca9b0c5ff0fab3d73ec176aeebe86ac1a.zip
Add simple build fixes for gcc-4.7 and boost-1.48+ from upstream. Unfortunately boost-1.48 has an ugly bug with gcc-4.7 itself (bug 424319) which means we need boost-1.49.
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/hugin/ChangeLog11
-rw-r--r--media-gfx/hugin/files/hugin-2011.4.0-boost148.patch42
-rw-r--r--media-gfx/hugin/files/hugin-2011.4.0-gcc47.patch42
-rw-r--r--media-gfx/hugin/hugin-2011.4.0-r1.ebuild70
4 files changed, 164 insertions, 1 deletions
diff --git a/media-gfx/hugin/ChangeLog b/media-gfx/hugin/ChangeLog
index 53066532cce1..f55752c4a08c 100644
--- a/media-gfx/hugin/ChangeLog
+++ b/media-gfx/hugin/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-gfx/hugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.121 2012/05/05 07:00:18 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/ChangeLog,v 1.122 2012/06/30 21:36:05 dilfridge Exp $
+
+*hugin-2011.4.0-r1 (30 Jun 2012)
+
+ 30 Jun 2012; Andreas K. Huettel <dilfridge@gentoo.org>
+ +hugin-2011.4.0-r1.ebuild, +files/hugin-2011.4.0-boost148.patch,
+ +files/hugin-2011.4.0-gcc47.patch:
+ Add simple build fixes for gcc-4.7 and boost-1.48+ from upstream.
+ Unfortunately boost-1.48 has an ugly bug with gcc-4.7 itself (bug 424319)
+ which means we need boost-1.49.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> hugin-2011.0.0.ebuild,
hugin-2011.2.0.ebuild, hugin-2011.4.0.ebuild:
diff --git a/media-gfx/hugin/files/hugin-2011.4.0-boost148.patch b/media-gfx/hugin/files/hugin-2011.4.0-boost148.patch
new file mode 100644
index 000000000000..3c19cc79c303
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-2011.4.0-boost148.patch
@@ -0,0 +1,42 @@
+
+# HG changeset patch
+# User tmodes
+# Date 1324625694 -3600
+# Node ID 7f0674a26bdb85fbcc73f64c8a38d1b353910af7
+# Parent b873e1da31f0fdc4cf19f9630450d1735a040fbe
+Add namespace to compile with Boost 1.48
+
+diff -r b873e1da31f0 -r 7f0674a26bdb src/hugin_base/algorithms/optimizer/ImageGraph.cpp
+--- a/src/hugin_base/algorithms/optimizer/ImageGraph.cpp Fri Dec 23 08:34:18 2011 +0100
++++ b/src/hugin_base/algorithms/optimizer/ImageGraph.cpp Fri Dec 23 08:34:54 2011 +0100
+@@ -55,7 +55,7 @@
+
+ CPGraphIndexMap index = get(boost::vertex_index, graph);
+ bool found=false;
+- for (tie(ai, ai_end) = adjacent_vertices(it->image1Nr, graph);
++ for (boost::tuples::tie(ai, ai_end) = adjacent_vertices(it->image1Nr, graph);
+ ai != ai_end; ++ai)
+ {
+ if (index[*ai] == it->image2Nr) found = true;
+@@ -83,7 +83,7 @@
+
+ CPGraphIndexMap index = get(boost::vertex_index, graph);
+ bool found=false;
+- for (tie(ai, ai_end) = adjacent_vertices(i, graph);
++ for (boost::tuples::tie(ai, ai_end) = adjacent_vertices(i, graph);
+ ai != ai_end; ++ai)
+ {
+ if (index[*ai] == j) found = true;
+diff -r b873e1da31f0 -r 7f0674a26bdb src/hugin_base/algorithms/optimizer/PTOptimizer.h
+--- a/src/hugin_base/algorithms/optimizer/PTOptimizer.h Fri Dec 23 08:34:18 2011 +0100
++++ b/src/hugin_base/algorithms/optimizer/PTOptimizer.h Fri Dec 23 08:34:54 2011 +0100
+@@ -233,7 +233,7 @@
+ // collect all optimized neighbours
+ typename boost::graph_traits<CPGraph>::adjacency_iterator ai;
+ typename boost::graph_traits<CPGraph>::adjacency_iterator ai_end;
+- for (tie(ai, ai_end) = adjacent_vertices(v, g);
++ for (boost::tuples::tie(ai, ai_end) = adjacent_vertices(v, g);
+ ai != ai_end; ++ai)
+ {
+ if (*ai != v) {
+
diff --git a/media-gfx/hugin/files/hugin-2011.4.0-gcc47.patch b/media-gfx/hugin/files/hugin-2011.4.0-gcc47.patch
new file mode 100644
index 000000000000..9615ae4b0647
--- /dev/null
+++ b/media-gfx/hugin/files/hugin-2011.4.0-gcc47.patch
@@ -0,0 +1,42 @@
+
+# HG changeset patch
+# User Bruno Postle <bruno@postle.net>
+# Date 1328910737 0
+# Node ID c7ecd541dbd78bfa95dd495c7c4317bba81f4c3b
+# Parent 658ded2153f2773a7e193f48d612d95104495080
+Fixes for gcc-4.7.0
+
+diff -r 658ded2153f2 -r c7ecd541dbd7 src/celeste/Utilities.h
+--- a/src/celeste/Utilities.h Sun Jan 01 13:23:39 2012 +0100
++++ b/src/celeste/Utilities.h Fri Feb 10 21:52:17 2012 +0000
+@@ -33,6 +33,8 @@
+ #include <stdio.h>
+ #ifdef _WINDOWS
+ #include "direct.h"
++#else
++#include <unistd.h>
+ #endif
+
+ using namespace std;
+diff -r 658ded2153f2 -r c7ecd541dbd7 src/foreign/zthread/include/zthread/Guard.h
+--- a/src/foreign/zthread/include/zthread/Guard.h Sun Jan 01 13:23:39 2012 +0100
++++ b/src/foreign/zthread/include/zthread/Guard.h Fri Feb 10 21:52:17 2012 +0000
+@@ -428,7 +428,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g) : LockHolder<LockType>(g) {
+
+- LockingPolicy::shareScope(*this, extract(g));
++ LockingPolicy::shareScope(*this, this->extract(g));
+
+ }
+
+@@ -458,7 +458,7 @@
+ template <class U, class V>
+ Guard(Guard<U, V>& g, LockType& lock) : LockHolder<LockType>(lock) {
+
+- LockingPolicy::transferScope(*this, extract(g));
++ LockingPolicy::transferScope(*this, this->extract(g));
+
+ }
+
+
diff --git a/media-gfx/hugin/hugin-2011.4.0-r1.ebuild b/media-gfx/hugin/hugin-2011.4.0-r1.ebuild
new file mode 100644
index 000000000000..4ba8629be12d
--- /dev/null
+++ b/media-gfx/hugin/hugin-2011.4.0-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/hugin/hugin-2011.4.0-r1.ebuild,v 1.1 2012/06/30 21:36:05 dilfridge Exp $
+
+EAPI=3
+WX_GTK_VER="2.8"
+PYTHON_DEPEND="python? 2:2.6 3"
+
+inherit base python wxwidgets versionator cmake-utils
+
+DESCRIPTION="GUI for the creation & processing of panoramic images"
+HOMEPAGE="http://hugin.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P/\.0_/}.tar.bz2"
+LICENSE="GPL-2 SIFT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+LANGS=" bg ca cs da de en_GB es fi fr hu it ja ko nl pl pt_BR ro ru sk sl sv uk zh_CN zh_TW"
+IUSE="lapack python sift $(echo ${LANGS//\ /\ linguas_})"
+
+CDEPEND="
+ !!dev-util/cocom
+ app-arch/zip
+ dev-cpp/tclap
+ >=dev-libs/boost-1.49.0-r1
+ dev-libs/zthread
+ >=media-gfx/enblend-4.0
+ media-gfx/exiv2
+ media-libs/freeglut
+ >=media-libs/libpano13-2.9.18
+ media-libs/libpng
+ media-libs/openexr
+ media-libs/tiff
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/wxGTK:2.8[X,opengl,-odbc]
+ lapack? ( virtual/lapack )
+ sift? ( media-gfx/autopano-sift-C )"
+RDEPEND="${CDEPEND}
+ media-libs/exiftool"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig
+ python? ( >=dev-lang/swig-2.0.4 )"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+PATCHES=(
+ "${FILESDIR}/${P}"-{boost148,gcc47}.patch
+)
+
+pkg_setup() {
+ DOCS="authors.txt README TODO"
+ mycmakeargs=(
+ $(cmake-utils_use_enable lapack LAPACK)
+ $(cmake-utils_use_build python HSI)
+ )
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ for lang in ${LANGS} ; do
+ case ${lang} in
+ ca) dir=ca_ES;;
+ cs) dir=cs_CZ;;
+ *) dir=${lang};;
+ esac
+ use linguas_${lang} || rm -r "${D}"/usr/share/locale/${dir}
+ done
+}