summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-04-29 08:33:27 +0000
committerTim Harder <radhermit@gentoo.org>2011-04-29 08:33:27 +0000
commit3d84d5f77c976eb154b6f364ef142611929f69f6 (patch)
tree6a2361fc15596810a96a0e823e104487c66ce8f9 /media-gfx
parentFix dependencies and linking error. (diff)
downloadgentoo-2-3d84d5f77c976eb154b6f364ef142611929f69f6.tar.gz
gentoo-2-3d84d5f77c976eb154b6f364ef142611929f69f6.tar.bz2
gentoo-2-3d84d5f77c976eb154b6f364ef142611929f69f6.zip
Add a dependency on zlib and explicitly link with it.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/apngasm/ChangeLog5
-rw-r--r--media-gfx/apngasm/apngasm-2.3.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/media-gfx/apngasm/ChangeLog b/media-gfx/apngasm/ChangeLog
index 73d1b3f1782e..54f69696eeed 100644
--- a/media-gfx/apngasm/ChangeLog
+++ b/media-gfx/apngasm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/apngasm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.1 2011/04/26 17:35:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.2 2011/04/29 08:33:27 radhermit Exp $
+
+ 29 Apr 2011; Tim Harder <radhermit@gentoo.org> apngasm-2.3.ebuild:
+ Add a dependency on zlib and explicitly link with it.
*apngasm-2.3 (26 Apr 2011)
diff --git a/media-gfx/apngasm/apngasm-2.3.ebuild b/media-gfx/apngasm/apngasm-2.3.ebuild
index c73daf279f89..b78563a1d18f 100644
--- a/media-gfx/apngasm/apngasm-2.3.ebuild
+++ b/media-gfx/apngasm/apngasm-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.3.ebuild,v 1.1 2011/04/26 17:35:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.3.ebuild,v 1.2 2011/04/29 08:33:27 radhermit Exp $
EAPI="3"
@@ -15,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="media-libs/libpng[apng]"
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
DEPEND="${RDEPEND}
dev-util/pkgconfig
app-arch/unzip"
@@ -23,7 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}
src_compile() {
- emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng)" ${PN} || die
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN} || die
}
src_install() {