summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-05-26 07:23:15 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-05-26 07:23:15 +0000
commit38525cb0d7534247a432357c9ef2410bd9f36547 (patch)
tree1afcf476eb93a0f5f91c068facb52ca883c396ea /media-gfx
parentfix another think-o in append-flags unification #271141 by Sebastian Lechte (diff)
downloadgentoo-2-38525cb0d7534247a432357c9ef2410bd9f36547.tar.gz
gentoo-2-38525cb0d7534247a432357c9ef2410bd9f36547.tar.bz2
gentoo-2-38525cb0d7534247a432357c9ef2410bd9f36547.zip
Initial import, bug 269377. Ebuild by Aleksandr Yakimov <yaleks@gentoo.ru> w/fixups by me.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/paint-mono/ChangeLog11
-rw-r--r--media-gfx/paint-mono/metadata.xml5
-rw-r--r--media-gfx/paint-mono/paint-mono-0.1.63.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/paint-mono/ChangeLog b/media-gfx/paint-mono/ChangeLog
new file mode 100644
index 000000000000..b9678f822dc5
--- /dev/null
+++ b/media-gfx/paint-mono/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/paint-mono
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/paint-mono/ChangeLog,v 1.1 2009/05/26 07:23:15 loki_val Exp $
+
+*paint-mono-0.1.63 (26 May 2009)
+
+ 26 May 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +paint-mono-0.1.63.ebuild, +metadata.xml:
+ Initial import, bug 269377. Ebuild by Aleksandr Yakimov <yaleks@gentoo.ru>
+ w/fixups by me.
+
diff --git a/media-gfx/paint-mono/metadata.xml b/media-gfx/paint-mono/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/media-gfx/paint-mono/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/media-gfx/paint-mono/paint-mono-0.1.63.ebuild b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
new file mode 100644
index 000000000000..335f527dc217
--- /dev/null
+++ b/media-gfx/paint-mono/paint-mono-0.1.63.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/paint-mono/paint-mono-0.1.63.ebuild,v 1.1 2009/05/26 07:23:15 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib
+
+DESCRIPTION="An unofficial effort to port Paint.NET 3.0 to Linux using Mono."
+HOMEPAGE="http://code.google.com/p/paint-mono/"
+SRC_URI="http://${PN}.googlecode.com/files/paintdotnet-${PV}.tar.gz"
+
+LICENSE="MIT CCPL-Attribution-NonCommercial-NoDerivs-2.5"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-2.4[-minimal]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/paintdotnet-${PV}"
+
+src_configure() {
+ ./configure --prefix=/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ mono_multilib_comply
+ sed -i -e 's:usr/local:usr:' "${D}"/usr/$(get_libdir)/pkgconfig/* "${D}"/usr/bin/*
+}