summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2003-01-28 07:45:40 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2003-01-28 07:45:40 +0000
commit373b88694928fb38c357bd6b45841518dc6f2741 (patch)
tree687a5d446f94e04986d5040261fa47c690fcccec /media-gfx
parentnew version bug #14659 (diff)
downloadgentoo-2-373b88694928fb38c357bd6b45841518dc6f2741.tar.gz
gentoo-2-373b88694928fb38c357bd6b45841518dc6f2741.tar.bz2
gentoo-2-373b88694928fb38c357bd6b45841518dc6f2741.zip
new version (bug #14660) (~arch)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp-print/ChangeLog6
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.2.51
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.5.ebuild83
3 files changed, 89 insertions, 1 deletions
diff --git a/media-gfx/gimp-print/ChangeLog b/media-gfx/gimp-print/ChangeLog
index c0de79f4a25e..e7fde1b9dcbb 100644
--- a/media-gfx/gimp-print/ChangeLog
+++ b/media-gfx/gimp-print/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gimp-print
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.8 2002/12/30 12:28:50 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.9 2003/01/28 07:45:40 lordvan Exp $
+
+*gimp-print-4.2.5 (28 Jan 2003)
+ 28 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org> gimp-print-4.2.5.ebuild:
+ new version (bug #14660)
*gimp-print-4.2.4 (30 Sept 2002)
27 Dec 2002; Thomas Raschbacher <lordvan@gentoo.org gimp-print-4.2.4.ebuild:
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.2.5 b/media-gfx/gimp-print/files/digest-gimp-print-4.2.5
new file mode 100644
index 000000000000..0c10e01131a6
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.2.5
@@ -0,0 +1 @@
+MD5 82a75fa7c97423b1a787df41552da3cc gimp-print-4.2.5.tar.gz 4992416
diff --git a/media-gfx/gimp-print/gimp-print-4.2.5.ebuild b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
new file mode 100644
index 000000000000..759fc8ecc7f6
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.2.5.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.5.ebuild,v 1.1 2003/01/28 07:45:40 lordvan Exp $
+
+IUSE="cups doc nls"
+
+inherit libtool
+
+MY_P=${P}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =media-gfx/gimp-1.2*
+ app-text/ghostscript
+ net-print/foomatic
+ doc? ( app-text/texi2html )
+ cups? ( >=net-print/cups-1.1.16 )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ local myconf
+
+ use cups && myconf="${myconf} --with-cups" \
+ || myconf="${myconf} --without-cups"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ econf \
+ --with-ghost \
+ --sysconfdir=/etc/gimp/1.2/ \
+ --with-gimp-exec-prefix=/usr \
+ --with-testpattern \
+ ${myconf} || die
+
+ cp src/gimp/Makefile src/gimp/Makefile.orig
+ sed -e 's:--install-admin-bin:--install-bin:g' \
+ src/gimp/Makefile.orig >src/gimp/Makefile
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins/print
+
+ make \
+ DESTDIR=${D} \
+ HOME=/usr/lib/gimp/1.2 \
+ install || die "make install failed"
+
+ # NOTE: this build uses gimptool to install the plugin, so
+ # if we dont do it this way, it will install to / no
+ # matter what.
+ #
+ # NOTE to whoever commented this: Please DO NOT!
+ mv ${D}/usr/lib/gimp/1.2/.gimp-1.2/plug-ins/ \
+ ${D}/usr/lib/gimp/1.2/
+ rm -rf ${D}/usr/lib/gimp/1.2/.gimp-1.2/
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+ dohtml -r doc
+
+}