summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-06-21 17:09:14 +0000
committerMamoru Komachi <usata@gentoo.org>2004-06-21 17:09:14 +0000
commit35746c920e9ec5e57e94e9edf95506c74065a99a (patch)
treeb55bffd11360bf3247eac9d1312da4cb4dbfbfd7 /media-gfx
parentVersion bump (Manifest recommit) (diff)
downloadgentoo-2-35746c920e9ec5e57e94e9edf95506c74065a99a.tar.gz
gentoo-2-35746c920e9ec5e57e94e9edf95506c74065a99a.tar.bz2
gentoo-2-35746c920e9ec5e57e94e9edf95506c74065a99a.zip
Version bumped. Marked 20040509 stable.
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/fontforge/ChangeLog9
-rw-r--r--media-gfx/fontforge/Manifest2
-rw-r--r--media-gfx/fontforge/files/digest-fontforge-200406181
-rw-r--r--media-gfx/fontforge/files/fontforge-20040618.patch85
-rw-r--r--media-gfx/fontforge/fontforge-20040509.ebuild4
-rw-r--r--media-gfx/fontforge/fontforge-20040618.ebuild47
6 files changed, 145 insertions, 3 deletions
diff --git a/media-gfx/fontforge/ChangeLog b/media-gfx/fontforge/ChangeLog
index 62c6006998fc..504b589e82a5 100644
--- a/media-gfx/fontforge/ChangeLog
+++ b/media-gfx/fontforge/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-gfx/fontforge
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontforge/ChangeLog,v 1.1 2004/05/17 17:31:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontforge/ChangeLog,v 1.2 2004/06/21 17:09:14 usata Exp $
+
+*fontforge-20040618 (22 Jun 2004)
+
+ 22 Jun 2004; Mamoru KOMACHI <usata@gentoo.org>
+ +files/fontforge-20040618.patch, fontforge-20040509.ebuild,
+ +fontforge-20040618.ebuild:
+ Version bumped. Marked 20040509 stable.
*fontforge-20040509 (18 May 2004)
diff --git a/media-gfx/fontforge/Manifest b/media-gfx/fontforge/Manifest
index db4487b6b095..dceb65e0b707 100644
--- a/media-gfx/fontforge/Manifest
+++ b/media-gfx/fontforge/Manifest
@@ -1,4 +1,6 @@
MD5 295674d4bed87f5a7c2796e032ed561e metadata.xml 158
MD5 aa528fd065776c782202b04182313cb7 fontforge-20040509.ebuild 1161
MD5 b9f44fb17b4d96912ae3f4b3fddeb05d ChangeLog 537
+MD5 aa528fd065776c782202b04182313cb7 fontforge-20040618.ebuild 1161
MD5 4a1317ec3e31d8218ec38fd58ee47178 files/digest-fontforge-20040509 73
+MD5 c8f9ca2044c72ddc3df79207a84c52c7 files/digest-fontforge-20040618 73
diff --git a/media-gfx/fontforge/files/digest-fontforge-20040618 b/media-gfx/fontforge/files/digest-fontforge-20040618
new file mode 100644
index 000000000000..e09a858c88ae
--- /dev/null
+++ b/media-gfx/fontforge/files/digest-fontforge-20040618
@@ -0,0 +1 @@
+MD5 0640913f05ec2bae63c2e63ffd4a2c29 fontforge_full-20040618.tgz 4116845
diff --git a/media-gfx/fontforge/files/fontforge-20040618.patch b/media-gfx/fontforge/files/fontforge-20040618.patch
new file mode 100644
index 000000000000..e79ce79e1906
--- /dev/null
+++ b/media-gfx/fontforge/files/fontforge-20040618.patch
@@ -0,0 +1,85 @@
+--- fontforge/tottf.c.orig Mon Jun 7 19:18:27 2004
++++ fontforge/tottf.c Wed Jun 16 13:37:06 2004
+@@ -3038,6 +3038,8 @@
+ int i,j,cnt1,cnt2,first,last,avg1,avg2,k;
+ SplineFont *sf = _sf;
+ char *pt;
++ static int const weightFactors[26] = { 64, 14, 27, 35, 100, 20, 14, 42, 63,
++ 3, 6, 35, 20, 56, 56, 17, 4, 49, 56, 71, 31, 10, 18, 3, 18, 2 };
+
+ os2->version = 1;
+ os2->weightClass = sf->pfminfo.weight;
+@@ -3102,9 +3104,10 @@
+ if ( sf->chars[i]->width!=0 ) {
+ avg2 += sf->chars[i]->width; ++cnt2;
+ }
+- if ( sf->chars[i]->unicodeenc==' ' ||
+- (sf->chars[i]->unicodeenc>='a' && sf->chars[i]->unicodeenc<='z')) {
+- avg1 += sf->chars[i]->width; ++cnt1;
++ if ( sf->chars[i]->unicodeenc==' ') {
++ avg1 += sf->chars[i]->width * 166; ++cnt1;
++ } else if (sf->chars[i]->unicodeenc>='a' && sf->chars[i]->unicodeenc<='z') {
++ avg1 += sf->chars[i]->width * weightFactors[sf->chars[i]->unicodeenc-'a']; ++cnt1;
+ }
+ }
+ }
+@@ -3122,9 +3125,9 @@
+ while ( pt<os2->achVendID ) *pt++ = ' '; /* Pad with spaces not NUL */
+
+ os2->avgCharWid = 500;
+- /*if ( cnt1==27 )
+- os2->avgCharWid = avg1/cnt1;
+- else*/ if ( cnt2!=0 )
++ if ( cnt1==27 )
++ os2->avgCharWid = avg1/1000;
++ else if ( cnt2!=0 )
+ os2->avgCharWid = avg2/cnt2;
+ memcpy(os2->panose,sf->pfminfo.panose,sizeof(os2->panose));
+ if ( format==ff_ttfsym ) {
+@@ -3349,11 +3352,34 @@
+ putshort(at->os2f,0);
+ }
+
+-static void dumpgasp(struct alltabs *at) {
++static void dumpgasp(struct alltabs *at, SplineFont *sf) {
++ BDFFont *bdf;
++ uint32 bitmaps = 0;
++ int i, rangecnt = 1;
++
++ for ( bdf=sf->bitmaps; bdf!=NULL; bdf=bdf->next) {
++ if ( BDFDepth(bdf)==1 && bdf->pixelsize<=32 )
++ bitmaps |= 1<<(bdf->pixelsize-1);
++ }
++ for ( i=1; i<32; i++ ) {
++ if ( (bitmaps&(1<<i))!=((bitmaps&(1<<(i-1)))<<1) )
++ rangecnt++;
++ }
++ if (bitmaps&(1<<31)) rangecnt++;
+
+ at->gaspf = tmpfile();
+ putshort(at->gaspf,0); /* Version number */
+- putshort(at->gaspf,1); /* One range */
++ putshort(at->gaspf,rangecnt); /* One range */
++ for ( i=0; i<31; i++ ) {
++ if ( (bitmaps&(1<<i))<<1 != (bitmaps&(1<<(i+1))) ) {
++ putshort(at->gaspf, i+1);
++ putshort(at->gaspf, bitmaps&(1<<i) ? 0x0 : 0x2);
++ }
++ }
++ if ( bitmaps&(1<<31) ) {
++ putshort(at->gaspf,32);
++ putshort(at->gaspf,0x0);
++ }
+ putshort(at->gaspf,0xffff); /* Upper bound on pixels/em for this range */
+ putshort(at->gaspf,0x2); /* Grey scale, no gridfitting */
+ /* No hints, so no grids to fit */
+@@ -4730,7 +4756,7 @@
+ redoos2(at);
+ if ( format!=ff_otf && format!=ff_otfcid && format!=ff_none ) {
+ if ( !SFHasInstructions(sf))
+- dumpgasp(at);
++ dumpgasp(at, sf);
+ at->fpgmf = dumpstoredtable(sf,CHR('f','p','g','m'),&at->fpgmlen);
+ at->prepf = dumpstoredtable(sf,CHR('p','r','e','p'),&at->preplen);
+ at->cvtf = dumpstoredtable(sf,CHR('c','v','t',' '),&at->cvtlen);
+
diff --git a/media-gfx/fontforge/fontforge-20040509.ebuild b/media-gfx/fontforge/fontforge-20040509.ebuild
index 6d7b0ab6b3c8..beb87ee73f7a 100644
--- a/media-gfx/fontforge/fontforge-20040509.ebuild
+++ b/media-gfx/fontforge/fontforge-20040509.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontforge/fontforge-20040509.ebuild,v 1.1 2004/05/17 17:31:42 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontforge/fontforge-20040509.ebuild,v 1.2 2004/06/21 17:09:14 usata Exp $
inherit flag-o-matic
@@ -10,7 +10,7 @@ SRC_URI="http://fontforge.sourceforge.net/${PN}_full-${PV}.tgz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="png gif jpeg tiff truetype svg unicode X"
DEPEND="png? ( >=media-libs/libpng-1.2.4 )
diff --git a/media-gfx/fontforge/fontforge-20040618.ebuild b/media-gfx/fontforge/fontforge-20040618.ebuild
new file mode 100644
index 000000000000..09780ef6ee71
--- /dev/null
+++ b/media-gfx/fontforge/fontforge-20040618.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/fontforge/fontforge-20040618.ebuild,v 1.1 2004/06/21 17:09:14 usata Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="postscript font editor and converter"
+HOMEPAGE="http://fontforge.sourceforge.net/"
+SRC_URI="http://fontforge.sourceforge.net/${PN}_full-${PV}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="png gif jpeg tiff truetype svg unicode X"
+
+DEPEND="png? ( >=media-libs/libpng-1.2.4 )
+ gif? ( >=media-libs/libungif-4.1.0-r1 )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7-r1 )
+ truetype? ( >=media-libs/freetype-2.1.4 )
+ svg? ( >=dev-libs/libxml2-2.6.7 )
+ >=media-gfx/autotrace-0.31.1
+ unicode? ( >=media-libs/libuninameslist-030713 )
+ !media-gfx/pfaedit"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ local myconf="--with-multilayer"
+ use X || myconf="--without-x"
+
+ filter-mfpmath "sse" "387"
+
+ econf ${myconf} --without-freetype-src || die "econf failed"
+ make || die
+}
+
+src_install() {
+ # make install fails if this directory doesn't exist
+ dodir /usr/lib
+ einstall || die
+ dodoc AUTHORS README*
+}