summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-23 05:42:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-23 05:42:01 +0000
commit2eb7d65198c7965f787c0d0b9df67546a9716375 (patch)
treee8885c80f1bb1b88d81ea77ac52ee7b75888b579 /media-gfx
parentOnly build documentation when USE=doc. Fixes #337670. (diff)
downloadgentoo-2-2eb7d65198c7965f787c0d0b9df67546a9716375.tar.gz
gentoo-2-2eb7d65198c7965f787c0d0b9df67546a9716375.tar.bz2
gentoo-2-2eb7d65198c7965f787c0d0b9df67546a9716375.zip
Version bump (also fixing overflow bug #338147)
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/dawn/ChangeLog8
-rw-r--r--media-gfx/dawn/dawn-3.90b.ebuild58
-rw-r--r--media-gfx/dawn/files/dawn-3.90b-no-interactive.patch158
3 files changed, 223 insertions, 1 deletions
diff --git a/media-gfx/dawn/ChangeLog b/media-gfx/dawn/ChangeLog
index d9aae42e2a31..5abbdb952e4a 100644
--- a/media-gfx/dawn/ChangeLog
+++ b/media-gfx/dawn/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/dawn
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/ChangeLog,v 1.9 2010/08/09 16:58:12 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/ChangeLog,v 1.10 2010/09/23 05:42:01 bicatali Exp $
+
+*dawn-3.90b (23 Sep 2010)
+
+ 23 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> +dawn-3.90b.ebuild,
+ +files/dawn-3.90b-no-interactive.patch:
+ Version bump (also fixing overflow bug #338147)
09 Aug 2010; Kacper Kowalik <xarthisius@gentoo.org> dawn-3.88a.ebuild:
Respect CXX and LDFLAGS. Fixes bug 331857. Thanks to Diego for report.
diff --git a/media-gfx/dawn/dawn-3.90b.ebuild b/media-gfx/dawn/dawn-3.90b.ebuild
new file mode 100644
index 000000000000..23084dbf8b6d
--- /dev/null
+++ b/media-gfx/dawn/dawn-3.90b.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dawn/dawn-3.90b.ebuild,v 1.1 2010/09/23 05:42:01 bicatali Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs versionator
+
+MYP=${PN}_$(replace_version_separator 1 _)
+
+DESCRIPTION="3D geometrical postscript renderer"
+HOMEPAGE="http://geant4.kek.jp/~tanaka/DAWN/About_DAWN.html"
+SRC_URI="http://geant4.kek.jp/~tanaka/src/${MYP}.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc opengl X"
+
+RDEPEND="dev-lang/tk
+ X? ( x11-libs/libX11 )
+ opengl? ( virtual/opengl )"
+DEPEND="${RDEPEND}
+ app-shells/tcsh
+ doc? ( virtual/latex-base )"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-interactive.patch
+ sed -i -e "s/\$(LIB_DIR)/\$(LDFLAGS) &/" \
+ -e '/strip/d' Makefile*in || die
+}
+
+src_compile() {
+ tc-export CXX
+ emake clean
+ emake guiclean
+ if use X; then
+ ./configure_xwin || die
+ else
+ ./configure || die
+ fi
+ einfo "Compiling"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ emake DESTDIR="${D}" install || die
+ dodoc README.txt
+ if use doc; then
+ pdflatex DOC/G4PRIM_FORMAT_24.tex || die "pdf generation failed"
+ insinto /usr/share/doc/${PF}
+ doins DOC/G4PRIM_FORMAT_24.pdf
+ dohtml DOC/*.html
+ fi
+}
diff --git a/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch b/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch
new file mode 100644
index 000000000000..244948ec5262
--- /dev/null
+++ b/media-gfx/dawn/files/dawn-3.90b-no-interactive.patch
@@ -0,0 +1,158 @@
+--- configure_xwin.orig 2008-04-02 22:58:44.973465484 +0100
++++ configure_xwin 2008-04-03 00:02:15.950190359 +0100
+@@ -16,17 +16,17 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+
+ #-----
+@@ -34,7 +34,7 @@
+ echo " (e.g. -I/usr/X11R6/include) "
+ echo " Hit return key if path is already set properly. )"
+ echo -n " : "
+-set xlib_inc=$<
++set xlib_inc=
+ echo ""
+
+
+@@ -43,17 +43,17 @@
+ echo " (e.g. -L/usr/X11R6/lib) "
+ echo " Hit return key if path is already set properly.)"
+ echo -n " : "
+-set xlib_lib=$<
++set xlib_lib=
+ echo ""
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+ #----- Input system name
+ echo -n "Select a system (0: Defalut, 1: AIX, 2: IRIX, 3: Solaris, 4: RedHat/FedoraCore): "
+-set sysid=$<
++set sysid=0
+ switch ($sysid)
+ case "0":
+ set sysname = "Default"
+@@ -80,7 +80,7 @@
+ echo "Do you use remote-visualization function? (y/n, no default)"
+ echo " (Select n if your compilation fails for FRClientServer.cc)"
+ echo -n " : "
+-set ynflag_socket=$<
++set ynflag_socket=n
+ switch ($ynflag_socket)
+ case "y":
+ set macro_socket = '#define USE_SOCKET'
+@@ -123,14 +123,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -152,7 +152,7 @@
+ echo "" >> Makefile
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Socket libraries to be linked " >> Makefile
+--- FRSocketMacro.h.orig 2008-04-02 23:58:51.126518123 +0100
++++ FRSocketMacro.h 2008-04-02 23:59:03.443220012 +0100
+@@ -14,8 +14,8 @@
+ #elif defined SOCKET_REDHAT61
+ #define CLIENT_ADDR_LENGTH socklen_t
+ #else
+- #define CLIENT_ADDR_LENGTH int
+-// #define CLIENT_ADDR_LENGTH size_t
++// #define CLIENT_ADDR_LENGTH int
++ #define CLIENT_ADDR_LENGTH size_t
+ #endif
+
+ //----- gethostname
+--- configure.orig 2010-08-21 14:22:18.000000000 +0100
++++ configure 2010-09-23 05:57:02.000000000 +0100
+@@ -13,22 +13,22 @@
+ #----- C++ compiler name
+ echo "Input C++ compiler name (e.g. g++, no default)."
+ echo -n " :"
+-set cpp_compiler=$<
++set cpp_compiler=
+
+ #----- Optimization option of the C++ compiler
+ echo "Input optimization option (e.g. -O2, no default)"
+ echo -n " :"
+-set optimize=$<
++set optimize=
+
+ #----- Input Tcl/Tk window shell name
+ echo "Input Tcl/Tk window shell name"
+ echo -n " (e.g. wish, no default): "
+-set wish=$<
++set wish=wish
+
+ #----- Input directory name to install dawn and DAWN_GUI
+ echo "Input directory to install executable files"
+ echo -n " (e.g. /usr/local/bin, no default ): "
+-set install_dir=$<
++set install_dir=
+
+
+ ##### DELETE #####
+@@ -57,14 +57,14 @@
+
+ echo "### C++ compiler" >> Makefile
+ #echo "ifndef CXX" >> Makefile
+-echo "CC = $cpp_compiler" >> Makefile
++#echo "CC = $cpp_compiler" >> Makefile
+ #echo "else" >> Makefile
+-#echo 'CC = $(CXX)' >> Makefile
++echo 'CC = $(CXX)' >> Makefile
+ #echo "endif" >> Makefile
+ echo "" >> Makefile
+
+ echo "### Optimization" >> Makefile
+-echo "OPTIMIZE = $optimize" >> Makefile
++echo 'OPTIMIZE = $(CXXFLAGS)' >> Makefile
+ echo "" >> Makefile
+
+ echo "### Waring level" >> Makefile
+@@ -78,7 +78,7 @@
+
+
+ echo "### Directory where to install executable files" >> Makefile
+-echo "INSTALL_DIR = $install_dir" >> Makefile
++echo 'INSTALL_DIR = $(DESTDIR)/usr/bin' >> Makefile
+ echo "" >> Makefile
+
+ echo "" >> Makefile