summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-07-01 10:40:27 +0000
committerJustin Lecher <jlec@gentoo.org>2012-07-01 10:40:27 +0000
commit274760a844a2a4e18bb65f3a18065783822d6051 (patch)
tree491b6e92a504c202a48734b9a008d05a4e08ed4f /media-gfx
parentdev-libs/libtrain: Fix some implicit declarations, respect LDFLAGS #337649; b... (diff)
downloadgentoo-2-274760a844a2a4e18bb65f3a18065783822d6051.tar.gz
gentoo-2-274760a844a2a4e18bb65f3a18065783822d6051.tar.bz2
gentoo-2-274760a844a2a4e18bb65f3a18065783822d6051.zip
media-gfx/crwinfo: Respect LDFLAGS, #337406; bumped to EAPI=4
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/crwinfo/ChangeLog7
-rw-r--r--media-gfx/crwinfo/crwinfo-0.2.ebuild25
2 files changed, 18 insertions, 14 deletions
diff --git a/media-gfx/crwinfo/ChangeLog b/media-gfx/crwinfo/ChangeLog
index d62dc099d47e..6abc3fa6a431 100644
--- a/media-gfx/crwinfo/ChangeLog
+++ b/media-gfx/crwinfo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/crwinfo
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/crwinfo/ChangeLog,v 1.4 2008/04/21 17:30:22 phreak Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/crwinfo/ChangeLog,v 1.5 2012/07/01 10:40:27 jlec Exp $
+
+ 01 Jul 2012; Justin Lecher <jlec@gentoo.org> crwinfo-0.2.ebuild:
+ Respect LDFLAGS, #337406; bumped to EAPI=4
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/media-gfx/crwinfo/crwinfo-0.2.ebuild b/media-gfx/crwinfo/crwinfo-0.2.ebuild
index 7639c303aade..f078ae08048f 100644
--- a/media-gfx/crwinfo/crwinfo-0.2.ebuild
+++ b/media-gfx/crwinfo/crwinfo-0.2.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/crwinfo/crwinfo-0.2.ebuild,v 1.2 2009/09/23 15:10:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/crwinfo/crwinfo-0.2.ebuild,v 1.3 2012/07/01 10:40:27 jlec Exp $
-inherit eutils
+EAPI=4
+
+inherit eutils toolchain-funcs
DESCRIPTION="Canon raw image (CRW) information and thumbnail extractor"
HOMEPAGE="http://freshmeat.net/projects/crwinfo/"
SRC_URI="http://neuemuenze.heim1.tu-clausthal.de/~sven/crwinfo/CRWInfo-${PV}.tar.gz"
-S="${WORKDIR}/CRWInfo-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64 alpha ia64 hppa ppc64"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}.patch
-}
+S="${WORKDIR}/CRWInfo-${PV}"
-src_compile() {
- emake || die
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+ sed \
+ -e '/gcc/s:^.*$:\t$(CC) $(CFLAGS) -Wall -c crwinfo.c\n\t$(CC) $(LDFLAGS) -o crwinfo crwinfo.o:g' \
+ -i Makefile || die
+ tc-export CC
}
src_install() {
- dobin crwinfo || die
+ dobin crwinfo
dodoc README spec
}