summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-11-11 15:31:09 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-11-11 15:31:09 +0000
commit0e9cae8118ab59ba348faae95192b27dfdfe4bd6 (patch)
tree127c469cb2e192b93a96aaf96b39c9da22a8001a /media-gfx
parentMarked ~amd64 for bug #246375 (diff)
downloadgentoo-2-0e9cae8118ab59ba348faae95192b27dfdfe4bd6.tar.gz
gentoo-2-0e9cae8118ab59ba348faae95192b27dfdfe4bd6.tar.bz2
gentoo-2-0e9cae8118ab59ba348faae95192b27dfdfe4bd6.zip
Version bump
(Portage version: 2.2_rc13/cvs/Linux 2.6.27.5 i686)
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/optipng/ChangeLog7
-rw-r--r--media-gfx/optipng/optipng-0.6.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/media-gfx/optipng/ChangeLog b/media-gfx/optipng/ChangeLog
index 67c414646613..b4080950dd86 100644
--- a/media-gfx/optipng/ChangeLog
+++ b/media-gfx/optipng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/optipng
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/ChangeLog,v 1.40 2008/08/24 14:03:32 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/ChangeLog,v 1.41 2008/11/11 15:31:09 nyhm Exp $
+
+*optipng-0.6.2 (11 Nov 2008)
+
+ 11 Nov 2008; Tristan Heaven <nyhm@gentoo.org> +optipng-0.6.2.ebuild:
+ Version bump
*optipng-0.6.1 (24 Aug 2008)
diff --git a/media-gfx/optipng/optipng-0.6.2.ebuild b/media-gfx/optipng/optipng-0.6.2.ebuild
new file mode 100644
index 000000000000..c5c8be53dc21
--- /dev/null
+++ b/media-gfx/optipng/optipng-0.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.6.2.ebuild,v 1.1 2008/11/11 15:31:09 nyhm Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compress PNG files without affecting image quality"
+HOMEPAGE="http://optipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^C/s: -O2.*: ${CFLAGS} -Wall:" \
+ -e "/^LD/s: -s$: ${LDFLAGS}:" \
+ src/scripts/gcc.mak \
+ lib/libpng/scripts/makefile.gcc \
+ lib/pngxtern/scripts/gcc.mak \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" -C src -f scripts/gcc.mak || die "emake failed"
+}
+
+src_install() {
+ dobin src/optipng || die "dobin failed"
+ dodoc README.txt doc/*.txt
+ dohtml doc/*.html
+ doman man/optipng.1
+}