summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-07-20 18:21:40 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-07-20 18:21:40 +0000
commit61f30fb9f605f9c516d41c187021d70d4de103d0 (patch)
tree2ec381dd7ccc250fae79e587755fc42c24ca0e88 /media-gfx/zphoto
parents/tester/maintainer-needed/ to not bother tester anymore with bugspam. (diff)
downloadgentoo-2-61f30fb9f605f9c516d41c187021d70d4de103d0.tar.gz
gentoo-2-61f30fb9f605f9c516d41c187021d70d4de103d0.tar.bz2
gentoo-2-61f30fb9f605f9c516d41c187021d70d4de103d0.zip
Adding patch to build with glibc-2.10, closes bug #273831 ; Adding built with use dependency =x11-libs/wxGTK-2.6*[X]
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx/zphoto')
-rw-r--r--media-gfx/zphoto/ChangeLog9
-rw-r--r--media-gfx/zphoto/files/zphoto-1.2-glibc210.patch18
-rw-r--r--media-gfx/zphoto/zphoto-1.2-r2.ebuild20
3 files changed, 39 insertions, 8 deletions
diff --git a/media-gfx/zphoto/ChangeLog b/media-gfx/zphoto/ChangeLog
index c07db2da877c..8d2b5f7a469a 100644
--- a/media-gfx/zphoto/ChangeLog
+++ b/media-gfx/zphoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/zphoto
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/ChangeLog,v 1.19 2007/12/25 17:11:56 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/ChangeLog,v 1.20 2009/07/20 18:21:39 vostorga Exp $
+
+ 20 Jul 2009; Víctor Ostorga <vostorga@gentoo.org> zphoto-1.2-r2.ebuild,
+ +files/zphoto-1.2-glibc210.patch:
+ Adding patch to build with glibc-2.10, closes bug #273831
+ Adding built with use dependency : =x11-libs/wxGTK-2.6*[X]
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931. Assigning to maintainer-needed.
diff --git a/media-gfx/zphoto/files/zphoto-1.2-glibc210.patch b/media-gfx/zphoto/files/zphoto-1.2-glibc210.patch
new file mode 100644
index 000000000000..20f72c595675
--- /dev/null
+++ b/media-gfx/zphoto/files/zphoto-1.2-glibc210.patch
@@ -0,0 +1,18 @@
+diff -NrU5 zphoto-1.2.original/image.cpp zphoto-1.2/image.cpp
+--- zphoto-1.2.original/image.cpp 2009-07-20 17:13:30.000000000 +0000
++++ zphoto-1.2/image.cpp 2009-07-20 17:18:38.000000000 +0000
+@@ -552,12 +552,12 @@
+ }
+
+ static int
+ convert_needed_p (const char *src, const char *dest)
+ {
+- char *suffix1 = strrchr(src, '.');
+- char *suffix2 = strrchr(dest, '.');
++ char *suffix1 = const_cast<char*>(strrchr(src, '.'));
++ char *suffix2 = const_cast<char*>(strrchr(dest, '.'));
+
+ return strcmp(suffix1, suffix2) != 0;
+ }
+
+ extern "C" void
diff --git a/media-gfx/zphoto/zphoto-1.2-r2.ebuild b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
index 0f1dfdfaecb8..15a6a499985a 100644
--- a/media-gfx/zphoto/zphoto-1.2-r2.ebuild
+++ b/media-gfx/zphoto/zphoto-1.2-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r2.ebuild,v 1.4 2007/04/23 02:03:49 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r2.ebuild,v 1.5 2009/07/20 18:21:39 vostorga Exp $
-inherit wxwidgets
+EAPI=2
+
+inherit wxwidgets eutils
IUSE="wxwindows"
@@ -18,11 +20,17 @@ DEPEND=">=media-libs/ming-0.2a
|| ( >=media-libs/imlib2-1.1.0 >=media-gfx/imagemagick-5.5.7 )
app-arch/zip
>=dev-libs/popt-1.6.3
- wxwindows? ( =x11-libs/wxGTK-2.6* )"
+ wxwindows? ( =x11-libs/wxGTK-2.6*[X] )"
+RDEPEND=""
+
+src_prepare(){
+ #bug 273831
+ epatch "${FILESDIR}"/"${P}"-glibc210.patch
+}
src_compile() {
- local myconf="--disable-avifile"
+ local myconf="${myconf} --disable-avifile"
if use wxwindows ; then
WX_GTK_VER="2.6"
@@ -33,7 +41,7 @@ src_compile() {
myconf="--disable-wx"
fi
- econf ${myconf} || die
+ econf ${myconf}
emake || die
}