summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-29 15:00:20 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-29 15:00:20 +0000
commitb10e2e322eb2251644aca9eeeb15e281a545216d (patch)
tree29a9b430062de8dec396205fae9a2aa65d2a9758 /media-gfx/yafray
parentVersion bump. Separated patches for fit plugins and qtiplot.pro for better re... (diff)
downloadgentoo-2-b10e2e322eb2251644aca9eeeb15e281a545216d.tar.gz
gentoo-2-b10e2e322eb2251644aca9eeeb15e281a545216d.tar.bz2
gentoo-2-b10e2e322eb2251644aca9eeeb15e281a545216d.zip
Fix building with GCC 4.3 wrt #219648, thanks to Peter Alfredsen.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'media-gfx/yafray')
-rw-r--r--media-gfx/yafray/ChangeLog6
-rw-r--r--media-gfx/yafray/files/yafray-0.0.9-gcc43.patch97
-rw-r--r--media-gfx/yafray/yafray-0.0.9-r1.ebuild27
3 files changed, 115 insertions, 15 deletions
diff --git a/media-gfx/yafray/ChangeLog b/media-gfx/yafray/ChangeLog
index f63b2c0bdac5..0a89d07917db 100644
--- a/media-gfx/yafray/ChangeLog
+++ b/media-gfx/yafray/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/yafray
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/ChangeLog,v 1.49 2008/04/12 13:58:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/ChangeLog,v 1.50 2008/04/29 15:00:19 drac Exp $
+
+ 29 Apr 2008; Samuli Suominen <drac@gentoo.org>
+ +files/yafray-0.0.9-gcc43.patch, yafray-0.0.9-r1.ebuild:
+ Fix building with GCC 4.3 wrt #219648, thanks to Peter Alfredsen.
12 Apr 2008; Markus Meier <maekke@gentoo.org> -yafray-0.0.9.ebuild:
old
diff --git a/media-gfx/yafray/files/yafray-0.0.9-gcc43.patch b/media-gfx/yafray/files/yafray-0.0.9-gcc43.patch
new file mode 100644
index 000000000000..200930af8b69
--- /dev/null
+++ b/media-gfx/yafray/files/yafray-0.0.9-gcc43.patch
@@ -0,0 +1,97 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 30_gcc4.3_missing_includes.dpatch by Cyril Brulebois <cyril.brulebois@enst-bretagne.fr>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Add missing includes to fix FTBFS with gcc 4.3
+
+@DPATCH@
+
+--- a/src/yafraycore/HDR_io.cc 2007-12-21 02:04:16.000000000 +0100
++++ b/src/yafraycore/HDR_io.cc 2007-12-21 02:04:23.000000000 +0100
+@@ -9,6 +9,8 @@
+ #include<config.h>
+ #endif
+
++#include <cstring>
++
+ __BEGIN_YAFRAY
+
+ //---------------------------------------------------------------------------
+--- a/src/yafraycore/buffer.h 2007-12-21 02:03:39.000000000 +0100
++++ b/src/yafraycore/buffer.h 2007-12-21 02:03:48.000000000 +0100
+@@ -29,6 +29,7 @@
+
+ #include <cstdio>
+ #include <iostream>
++#include <cstdlib>
+ #include "color.h"
+
+ __BEGIN_YAFRAY
+--- a/src/yafraycore/ccthreads.cc 2007-12-21 02:05:02.000000000 +0100
++++ b/src/yafraycore/ccthreads.cc 2007-12-21 02:05:12.000000000 +0100
+@@ -1,5 +1,6 @@
+ #include"ccthreads.h"
+ #include<iostream>
++#include<cstdlib>
+
+ using namespace std;
+
+--- a/src/yafraycore/geometree.h 2007-12-21 02:09:40.000000000 +0100
++++ b/src/yafraycore/geometree.h 2007-12-21 02:09:46.000000000 +0100
+@@ -2,6 +2,7 @@
+ #define __GEOMETREE_H
+
+ #include"bound.h"
++#include <limits>
+
+ __BEGIN_YAFRAY
+
+--- a/src/yafraycore/kdtree.cc 2007-12-21 02:05:55.000000000 +0100
++++ b/src/yafraycore/kdtree.cc 2007-12-21 02:06:03.000000000 +0100
+@@ -4,6 +4,7 @@
+ #include <math.h>
+ #include <limits>
+ #include <time.h>
++#include <cstring>
+
+ __BEGIN_YAFRAY
+
+--- a/src/yafraycore/renderblock.cc 2007-12-21 02:07:41.000000000 +0100
++++ b/src/yafraycore/renderblock.cc 2007-12-21 02:07:49.000000000 +0100
+@@ -1,5 +1,6 @@
+
+ #include "renderblock.h"
++#include <cstdlib>
+
+ using namespace std;
+
+--- a/src/loader/mlex.cc 2007-12-21 02:13:25.000000000 +0100
++++ b/src/loader/mlex.cc 2007-12-21 02:13:35.000000000 +0100
+@@ -22,6 +22,7 @@
+
+ #include<stdio.h>
+ #include<iostream>
++#include<cstring>
+ #include "mlex.h"
+ using namespace std;
+ #include<string>
+--- a/src/shaders/basictex.cc 2007-12-21 02:14:43.000000000 +0100
++++ b/src/shaders/basictex.cc 2007-12-21 02:14:52.000000000 +0100
+@@ -23,6 +23,7 @@
+ #include "basictex.h"
+ #include "object3d.h"
+ #include <iostream>
++#include <cstring>
+
+ #include "targaIO.h"
+ #include "HDR_io.h"
+--- a/src/yafraycore/targaIO.cc 2007-12-21 02:10:53.000000000 +0100
++++ b/src/yafraycore/targaIO.cc 2007-12-21 02:11:00.000000000 +0100
+@@ -3,6 +3,7 @@
+ //--------------------------------------------------------------------------------
+ #include "targaIO.h"
+ #include "vector3d.h"
++#include <cstring>
+
+ //--------------------------------------------------------------------------------
+ // Save uncompressed 24 bit targa
diff --git a/media-gfx/yafray/yafray-0.0.9-r1.ebuild b/media-gfx/yafray/yafray-0.0.9-r1.ebuild
index 7bcb135345f4..e074d808d255 100644
--- a/media-gfx/yafray/yafray-0.0.9-r1.ebuild
+++ b/media-gfx/yafray/yafray-0.0.9-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/yafray-0.0.9-r1.ebuild,v 1.5 2008/04/12 12:25:05 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/yafray-0.0.9-r1.ebuild,v 1.6 2008/04/29 15:00:19 drac Exp $
-inherit eutils python multilib
+inherit eutils multilib python
DESCRIPTION="Yet Another Free Raytracer"
-HOMEPAGE="http://www.yafray.org/"
+HOMEPAGE="http://www.yafray.org"
SRC_URI="http://www.yafray.org/sec/2/downloads/${P}.tar.gz"
LICENSE="LGPL-2.1"
@@ -17,21 +17,19 @@ RDEPEND="media-libs/jpeg
sys-libs/zlib
openexr? ( media-libs/openexr )"
DEPEND="${RDEPEND}
- >=sys-devel/gcc-3.3
- >=sys-apps/sed-4
dev-util/scons"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-scons.patch
- epatch "${FILESDIR}"/${P}-libdir.patch
- epatch "${FILESDIR}"/${P}-etc.patch
+ epatch "${FILESDIR}"/${P}-scons.patch \
+ "${FILESDIR}"/${P}-libdir.patch \
+ "${FILESDIR}"/${P}-etc.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
- # Dirty hack for a dirty buildsystem.
- sed -i -e "s:-O3:${CXXFLAGS} -fsigned-char:g" *-settings.py || die
+ sed -i -e "s:-O3:${CXXFLAGS} -fsigned-char:g" *-settings.py || die "sed failed."
}
src_compile() {
@@ -44,9 +42,10 @@ src_compile() {
}
src_install() {
- scons prefix="/usr" destdir="${D}" libdir="/$(get_libdir)" install || die
+ scons prefix="/usr" destdir="${D}" libdir="/$(get_libdir)" install \
+ || die "scons install failed."
find "${D}" -name .sconsign -exec rm \{\} \;
- dodoc AUTHORS || die
- dohtml doc/doc.html || die
+ dodoc AUTHORS
+ dohtml doc/doc.html
}