summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Stelling <blubb@gentoo.org>2005-09-04 14:02:42 +0000
committerSimon Stelling <blubb@gentoo.org>2005-09-04 14:02:42 +0000
commit4342b2daaf2082b6e7e57a0e6b81f81beb41b663 (patch)
tree5e6d0588633b065c6e32751f51d6d27561c8fc3e /media-gfx/yafray
parentx86 stable on 1.1. 1.0 fails on newer gcc - to be removed soon (diff)
downloadgentoo-2-4342b2daaf2082b6e7e57a0e6b81f81beb41b663.tar.gz
gentoo-2-4342b2daaf2082b6e7e57a0e6b81f81beb41b663.tar.bz2
gentoo-2-4342b2daaf2082b6e7e57a0e6b81f81beb41b663.zip
fixed evil ptr->int cast and made it multilib-strict aware
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-gfx/yafray')
-rw-r--r--media-gfx/yafray/ChangeLog7
-rw-r--r--media-gfx/yafray/files/yafray-0.0.8-64bit.patch16
-rw-r--r--media-gfx/yafray/files/yafray-0.0.8-multilib.patch22
-rw-r--r--media-gfx/yafray/yafray-0.0.8.ebuild8
4 files changed, 50 insertions, 3 deletions
diff --git a/media-gfx/yafray/ChangeLog b/media-gfx/yafray/ChangeLog
index 130f5e4671be..a990d47e7df5 100644
--- a/media-gfx/yafray/ChangeLog
+++ b/media-gfx/yafray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/yafray
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/ChangeLog,v 1.20 2005/08/20 09:45:31 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/ChangeLog,v 1.21 2005/09/04 14:02:42 blubb Exp $
+
+ 04 Sep 2005; Simon Stelling <blubb@gentoo.org>
+ +files/yafray-0.0.8-64bit.patch, +files/yafray-0.0.8-multilib.patch,
+ yafray-0.0.8.ebuild:
+ fixed evil ptr->int cast and made it multilib-strict aware
15 Aug 2005; Luca Barbato <lu_zero@gentoo.org> ChangeLog:
New version, thanks to Joshua Leach <leachj@cae.wisc.edu> for the ebuild
diff --git a/media-gfx/yafray/files/yafray-0.0.8-64bit.patch b/media-gfx/yafray/files/yafray-0.0.8-64bit.patch
new file mode 100644
index 000000000000..87589ccb9fac
--- /dev/null
+++ b/media-gfx/yafray/files/yafray-0.0.8-64bit.patch
@@ -0,0 +1,16 @@
+--- src/loader/render.cc.old 2005-09-04 15:32:46.000000000 +0200
++++ src/loader/render.cc 2005-09-04 15:33:01.000000000 +0200
+@@ -721,11 +721,11 @@
+ }
+ for(vector<triangle_t>::iterator i=faces.begin();i!=faces.end();++i)
+ {
+- long int n=(int)((*i).a);
++ long int n=(long int)((*i).a);
+ if((n>=(long int)mesh->points->points.size()) || (n<0))
+ { WARNING<<"Point "<<n<<" out of bounds in object\n"; n=0; }
+ (*i).a=&(mesh->points->points)[n];
+- n=(int)((*i).b);
++ n=(long int)((*i).b);
+ if((n>=(long int)mesh->points->points.size()) || (n<0))
+ { WARNING<<"Point "<<n<<" out of bounds in object\n"; n=0; }
+ (*i).b=&(mesh->points->points)[n];
diff --git a/media-gfx/yafray/files/yafray-0.0.8-multilib.patch b/media-gfx/yafray/files/yafray-0.0.8-multilib.patch
new file mode 100644
index 000000000000..1b68c2e6fc4b
--- /dev/null
+++ b/media-gfx/yafray/files/yafray-0.0.8-multilib.patch
@@ -0,0 +1,22 @@
+--- linux-settings.py.old 2005-09-04 15:51:15.000000000 +0200
++++ linux-settings.py 2005-09-04 15:52:29.000000000 +0200
+@@ -10,8 +10,8 @@
+ global prefix
+ prefix = args.get('prefix','/usr/local')
+
+-def get_libpath(args): return prefix+"/lib"
+-def get_pluginpath(args): return prefix+"/lib/yafray"
++def get_libpath(args): return prefix+"/lib64"
++def get_pluginpath(args): return prefix+"/lib64/yafray"
+ def get_binpath(args): return prefix+"/bin"
+ def get_confpath(args): return prefix+"/etc"
+ def get_cxxflags(args):
+@@ -34,7 +34,7 @@
+ return False
+
+ def get_include(args): return [ exr.PATH + "/include/OpenEXR" ]
+- def get_libpath(args): return [ exr.PATH + "/lib" ]
++ def get_libpath(args): return [ exr.PATH + "/lib64" ]
+ def get_libs(args): return ['IlmImf', 'Imath', 'Iex', 'Half']
+
+ class jpeg(globalinfo.library):
diff --git a/media-gfx/yafray/yafray-0.0.8.ebuild b/media-gfx/yafray/yafray-0.0.8.ebuild
index 9ace4f8ced23..3600dad82f31 100644
--- a/media-gfx/yafray/yafray-0.0.8.ebuild
+++ b/media-gfx/yafray/yafray-0.0.8.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/yafray-0.0.8.ebuild,v 1.1 2005/08/20 09:45:31 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/yafray/yafray-0.0.8.ebuild,v 1.2 2005/09/04 14:02:42 blubb Exp $
-inherit eutils python
+inherit eutils python multilib
DESCRIPTION="Yet Another Free Raytracer"
HOMEPAGE="http://www.yafray.org/"
@@ -27,6 +27,10 @@ src_unpack() {
cd ${S}
libtoolize --copy --force
epatch ${FILESDIR}/${P}-scons.patch
+ epatch ${FILESDIR}/${P}-64bit.patch
+ if [[ $(get_libdir) == "lib64" ]] ; then
+ epatch ${FILESDIR}/${P}-multilib.patch
+ fi
# Dirty hack for a dirty buildsystem.
sed -i -e "s:-O3:${CXXFLAGS} -fsigned-char:g" *-settings.py
}