summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-04 12:40:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-04 12:40:30 +0000
commit830de191cf38d6ea0f97fe49ee6e3e5d80af1d7e (patch)
tree10291b79f2b5e233b9f8f0d2a8d824555fc7f1d7 /media-gfx/xloadimage
parentAdd hungarian template pack, bug #272159 (diff)
downloadgentoo-2-830de191cf38d6ea0f97fe49ee6e3e5d80af1d7e.tar.gz
gentoo-2-830de191cf38d6ea0f97fe49ee6e3e5d80af1d7e.tar.bz2
gentoo-2-830de191cf38d6ea0f97fe49ee6e3e5d80af1d7e.zip
Include stdlib.h for exit(3) and respect LDFLAGS when building uufilter binary.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/xloadimage')
-rw-r--r--media-gfx/xloadimage/ChangeLog7
-rw-r--r--media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch23
-rw-r--r--media-gfx/xloadimage/xloadimage-4.1-r10.ebuild3
3 files changed, 31 insertions, 2 deletions
diff --git a/media-gfx/xloadimage/ChangeLog b/media-gfx/xloadimage/ChangeLog
index 82112081b1f5..5933f41fc741 100644
--- a/media-gfx/xloadimage/ChangeLog
+++ b/media-gfx/xloadimage/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/xloadimage
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.43 2009/09/04 11:14:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/ChangeLog,v 1.44 2009/09/04 12:40:30 ssuominen Exp $
+
+ 04 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xloadimage-4.1-r10.ebuild, +files/xloadimage-4.1-ldflags_and_exit.patch:
+ Include stdlib.h for exit(3) and respect LDFLAGS when building uufilter
+ binary.
*xloadimage-4.1-r10 (04 Sep 2009)
diff --git a/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
new file mode 100644
index 000000000000..afdea768aa47
--- /dev/null
+++ b/media-gfx/xloadimage/files/xloadimage-4.1-ldflags_and_exit.patch
@@ -0,0 +1,23 @@
+diff -ur xloadimage.4.1.orig/Makefile.in xloadimage.4.1/Makefile.in
+--- xloadimage.4.1.orig/Makefile.in 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/Makefile.in 2009-09-04 15:38:50.000000000 +0300
+@@ -27,7 +27,7 @@
+ $(CC) -o $@ $(OBJS) build.o $(LDFLAGS) $(XLIB) $(LIBS)
+
+ uufilter: uufilter.c
+- $(CC) $(CFLAGS) $(DEFS) uufilter.c -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $(DEFS) uufilter.c -o $@
+
+ .c.o: config.h image.h
+ $(CC) $(CFLAGS) -c $(DEFS) $<
+diff -ur xloadimage.4.1.orig/uufilter.c xloadimage.4.1/uufilter.c
+--- xloadimage.4.1.orig/uufilter.c 2009-09-04 15:37:09.000000000 +0300
++++ xloadimage.4.1/uufilter.c 2009-09-04 15:37:59.000000000 +0300
+@@ -11,6 +11,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ int main(argc, argv)
diff --git a/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild b/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
index d630faf68870..667b114d57d7 100644
--- a/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
+++ b/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild,v 1.2 2009/09/04 11:36:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xloadimage/xloadimage-4.1-r10.ebuild,v 1.3 2009/09/04 12:40:30 ssuominen Exp $
EAPI=2
inherit eutils toolchain-funcs
@@ -45,6 +45,7 @@ src_prepare() {
sed -i -e 's,<malloc.h>,<stdlib.h>,' vicar.c || die
epatch "${FILESDIR}"/${P}-unaligned-access.patch
+ epatch "${FILESDIR}"/${P}-ldflags_and_exit.patch
chmod +x configure
}