summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-12-08 20:40:46 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-12-08 20:40:46 +0000
commit162693f82e65a275fbf07b737132f5168a64fe77 (patch)
tree55048e99374f011099de567c88d869ef56a91dfc /media-gfx/xfig
parentDon't provide virtual/jre. (diff)
downloadgentoo-2-162693f82e65a275fbf07b737132f5168a64fe77.tar.gz
gentoo-2-162693f82e65a275fbf07b737132f5168a64fe77.tar.bz2
gentoo-2-162693f82e65a275fbf07b737132f5168a64fe77.zip
Added GCC 4 patch, thanks to Thomas Weidner <3.14159@gmx.net>, bug 114349.
(Portage version: 2.0.53)
Diffstat (limited to 'media-gfx/xfig')
-rw-r--r--media-gfx/xfig/ChangeLog6
-rw-r--r--media-gfx/xfig/files/xfig-3.2.4-gcc4.patch28
-rw-r--r--media-gfx/xfig/xfig-3.2.4-r2.ebuild3
3 files changed, 35 insertions, 2 deletions
diff --git a/media-gfx/xfig/ChangeLog b/media-gfx/xfig/ChangeLog
index 6d0a9a444078..52d836bcbbaa 100644
--- a/media-gfx/xfig/ChangeLog
+++ b/media-gfx/xfig/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/xfig
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xfig/ChangeLog,v 1.19 2005/09/24 21:31:55 vanquirius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xfig/ChangeLog,v 1.20 2005/12/08 20:40:46 cryos Exp $
+
+ 08 Dec 2005; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/xfig-3.2.4-gcc4.patch, xfig-3.2.4-r2.ebuild:
+ Added GCC 4 patch, thanks to Thomas Weidner <3.14159@gmx.net>, bug 114349.
*xfig-3.2.5_alpha5 (24 Sep 2005)
diff --git a/media-gfx/xfig/files/xfig-3.2.4-gcc4.patch b/media-gfx/xfig/files/xfig-3.2.4-gcc4.patch
new file mode 100644
index 000000000000..b5ab193bda94
--- /dev/null
+++ b/media-gfx/xfig/files/xfig-3.2.4-gcc4.patch
@@ -0,0 +1,28 @@
+diff -ru xfig.3.2.4/u_fonts.h xfig.3.2.4.new/u_fonts.h
+--- xfig.3.2.4/u_fonts.h 2002-03-27 01:18:23.000000000 +0100
++++ xfig.3.2.4.new/u_fonts.h 2005-12-03 15:21:02.054250392 +0100
+@@ -30,12 +30,6 @@
+ /* font number for the "nil" font (when user wants tiny text) */
+ #define NILL_FONT NUM_FONTS
+
+-extern int psfontnum();
+-extern int latexfontnum();
+-extern struct _xfstruct x_fontinfo[], x_backup_fontinfo[];
+-extern struct _fstruct ps_fontinfo[];
+-extern struct _fstruct latex_fontinfo[];
+-
+ /* element of linked list for each font
+ The head of list is for the different font NAMES,
+ and the elements of this list are for each different
+@@ -61,5 +55,11 @@
+ * sizes */
+ };
+
++extern int psfontnum();
++extern int latexfontnum();
++extern struct _xfstruct x_fontinfo[], x_backup_fontinfo[];
++extern struct _fstruct ps_fontinfo[];
++extern struct _fstruct latex_fontinfo[];
++
+ int x_fontnum();
+ #endif /* U_FONTS_H */
diff --git a/media-gfx/xfig/xfig-3.2.4-r2.ebuild b/media-gfx/xfig/xfig-3.2.4-r2.ebuild
index f03e354ddc4a..90cda631a936 100644
--- a/media-gfx/xfig/xfig-3.2.4-r2.ebuild
+++ b/media-gfx/xfig/xfig-3.2.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/xfig/xfig-3.2.4-r2.ebuild,v 1.4 2005/09/13 17:36:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/xfig/xfig-3.2.4-r2.ebuild,v 1.5 2005/12/08 20:40:46 cryos Exp $
inherit eutils
@@ -33,6 +33,7 @@ src_unpack() {
epatch ${WORKDIR}/${P}-gentoo.diff
epatch ${FILESDIR}/${P}-xaw3d.diff
epatch ../${SHAPE_P}/${PN}.${SHAPE_P#*.}.patch # bug #20877
+ epatch ${FILESDIR}/${P}-gcc4.patch
}
src_compile() {