summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-10 22:09:40 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-10 22:09:40 +0000
commitbb350f6da7e195bbef88c3b5ba2f0aa5560cbde1 (patch)
tree95fb06ea7fd204a223936b4c67c6fa251bdbfa33 /media-gfx/truevision
parentdie if a call to cvs fails. close bug #20871. (diff)
downloadgentoo-2-bb350f6da7e195bbef88c3b5ba2f0aa5560cbde1.tar.gz
gentoo-2-bb350f6da7e195bbef88c3b5ba2f0aa5560cbde1.tar.bz2
gentoo-2-bb350f6da7e195bbef88c3b5ba2f0aa5560cbde1.zip
deuglification. added gtkglarea deps and other fixes
Diffstat (limited to 'media-gfx/truevision')
-rw-r--r--media-gfx/truevision/ChangeLog12
-rw-r--r--media-gfx/truevision/Manifest6
-rw-r--r--media-gfx/truevision/files/truevision-0.3.10-gentoo2.patch186
-rw-r--r--media-gfx/truevision/files/truevision-0.3.10-gentoo3.patch18
-rw-r--r--media-gfx/truevision/truevision-0.3.10.ebuild34
5 files changed, 241 insertions, 15 deletions
diff --git a/media-gfx/truevision/ChangeLog b/media-gfx/truevision/ChangeLog
index 734579a54fc0..50b54b891fcc 100644
--- a/media-gfx/truevision/ChangeLog
+++ b/media-gfx/truevision/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for media-gfx/truevision
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/ChangeLog,v 1.1 2003/03/16 22:09:16 malverian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/ChangeLog,v 1.2 2003/06/10 22:09:30 liquidx Exp $
-*truevision-0.4.10 (16 Mar 2003)
+*truevision-0.3.10 (10 Jun 2003)
- 16 Mar 2003; Philip Walls <malverian@gentoo.org
+ 10 Jun 2003; Alastair Tse <liquidx@gentoo.org> truevision-0.3.10.ebuild,
+ files/truevision-0.3.10-gentoo2.patch,
+ files/truevision-0.3.10-gentoo3.patch:
+ added gtkglarea dep, deuglified build process, added more sensible patch,
+ added docs and examples
+
+ 16 Mar 2003; Philip Walls <malverian@gentoo.org>
Initial import.
diff --git a/media-gfx/truevision/Manifest b/media-gfx/truevision/Manifest
index 76bb8764f89b..59ed63c46c69 100644
--- a/media-gfx/truevision/Manifest
+++ b/media-gfx/truevision/Manifest
@@ -1,4 +1,6 @@
-MD5 6cf13cf9df4a0c48cd52b7fd6731dacb ChangeLog 327
-MD5 bdf4e4f4a2dd25ca22baaabb0b09b073 truevision-0.3.10.ebuild 1064
+MD5 6c2913d8b3b04595846710d2b200b6bf ChangeLog 586
+MD5 878bb8fca2c9b9948923ac32b38a696a truevision-0.3.10.ebuild 1167
MD5 0c66c4f3bc3edf17a100befe56959457 files/digest-truevision-0.3.10 149
MD5 9085c40eee347c530e117a0f6a8ae551 files/truevision-0.3.10-gentoo1.patch 8565
+MD5 39d2d26f905c503453e3629b2989b845 files/truevision-0.3.10-gentoo2.patch 8055
+MD5 63ac8e8758dc811648edcf1e98fbb5b4 files/truevision-0.3.10-gentoo3.patch 667
diff --git a/media-gfx/truevision/files/truevision-0.3.10-gentoo2.patch b/media-gfx/truevision/files/truevision-0.3.10-gentoo2.patch
new file mode 100644
index 000000000000..da3e6da24ddc
--- /dev/null
+++ b/media-gfx/truevision/files/truevision-0.3.10-gentoo2.patch
@@ -0,0 +1,186 @@
+diff -U3 -r truevision-0.3.10/src/density.cc truevision-0.3.10-patched/src/density.cc
+--- truevision-0.3.10/src/density.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/density.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -49,7 +49,7 @@
+ //**************************************
+ // Constructeur
+ //**************************************
+-PovTexDensity::PovTexDensity( app_objs *appref, void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top=true ) : MaterialItem( app_ref )
++PovTexDensity::PovTexDensity( app_objs *appref, void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top ) : MaterialItem( app_ref )
+ {
+ num = ++count;
+ char text[25];
+@@ -74,7 +74,7 @@
+ warp = new TvWidget_warp_rb( N_("Warp"), "WARP", NULL, app_ref );
+ }
+
+-void PovTexDensity::set_params( void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top=true )
++void PovTexDensity::set_params( void (*asuicidal_func)(gpointer, gpointer), gpointer amother, bool is_top )
+ {
+ suicidal_func = asuicidal_func;
+ mother = amother;
+@@ -337,7 +337,7 @@
+ if ( map_editor != NULL ) map_editor->flush();
+ }
+
+-void PovTexDensity::output_to_povray( ofstream & file, bool inmap = false )
++void PovTexDensity::output_to_povray( ofstream & file, bool inmap )
+ {
+ if ( !inmap ) file << "\n\t\t\tdensity {\n\t\t\t\t";
+
+diff -U3 -r truevision-0.3.10/src/dlgutils.cc truevision-0.3.10-patched/src/dlgutils.cc
+--- truevision-0.3.10/src/dlgutils.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/dlgutils.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -41,7 +41,7 @@
+ }
+
+ // Double box
+-GtkWidget *dlg_double_box( GtkWidget *parent, GtkWidget* &vbox1, GtkWidget* &vbox2, bool packed = false )
++GtkWidget *dlg_double_box( GtkWidget *parent, GtkWidget* &vbox1, GtkWidget* &vbox2, bool packed )
+ {
+ GtkWidget *hbox = gtk_hbox_new( TRUE, 5 );
+ if ( packed ) gtk_box_pack_start( GTK_BOX(parent), hbox, TRUE, TRUE, 1 );
+diff -U3 -r truevision-0.3.10/src/mapedit.cc truevision-0.3.10-patched/src/mapedit.cc
+--- truevision-0.3.10/src/mapedit.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/mapedit.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -28,7 +28,7 @@
+ //********************************************
+ // MAP ITEM
+ //********************************************
+-MapItem::MapItem( char *nom, float val = -1 )
++MapItem::MapItem( char *nom, float val)
+ {
+ name = nom;
+ value = val;
+diff -U3 -r truevision-0.3.10/src/material.cc truevision-0.3.10-patched/src/material.cc
+--- truevision-0.3.10/src/material.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/material.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -66,7 +66,7 @@
+ //**************************************
+ // Add to list
+ //**************************************
+-void Material::add_to_list( GtkWidget *list, int position = -1 )
++void Material::add_to_list( GtkWidget *list, int position)
+ {
+ clist = GTK_CLIST( list );
+ gchar *titre[] = { name->value() };
+@@ -182,7 +182,7 @@
+ item_type = ref.item_type;
+ }
+
+-void MaterialItem::add_to_tree( GtkCTree *tree, GtkCTreeNode *node , GtkCTreeNode *sibling = NULL )
++void MaterialItem::add_to_tree( GtkCTree *tree, GtkCTreeNode *node , GtkCTreeNode *sibling)
+ {
+ ctree = tree;
+ parent_node = node;
+diff -U3 -r truevision-0.3.10/src/matpov.cc truevision-0.3.10-patched/src/matpov.cc
+--- truevision-0.3.10/src/matpov.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/matpov.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -600,7 +600,7 @@
+ }
+
+
+-void PovTexture::output_to_povray( ofstream & file, bool inmap = false )
++void PovTexture::output_to_povray( ofstream & file, bool inmap )
+ {
+ //if ( !is_used() ) return;
+
+diff -U3 -r truevision-0.3.10/src/texnormal.cc truevision-0.3.10-patched/src/texnormal.cc
+--- truevision-0.3.10/src/texnormal.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/texnormal.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -44,7 +44,7 @@
+ //**************************************
+ // Constructeurs & Destructeurs
+ //**************************************
+-PovTexNormal::PovTexNormal( app_objs *appref, bool mother = true ) : MaterialItem( app_ref )
++PovTexNormal::PovTexNormal( app_objs *appref, bool mother ) : MaterialItem( app_ref )
+ {
+ set_name( _("Normal") );
+ item_type = TV_MITEM_NORMAL;
+diff -U3 -r truevision-0.3.10/src/texpigment.cc truevision-0.3.10-patched/src/texpigment.cc
+--- truevision-0.3.10/src/texpigment.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/texpigment.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -48,7 +48,7 @@
+ //**************************************
+ // Constructeur
+ //**************************************
+-PovTexPigment::PovTexPigment( app_objs *appref, bool mother = true ) : MaterialItem( appref )
++PovTexPigment::PovTexPigment( app_objs *appref, bool mother ) : MaterialItem( appref )
+ {
+ set_name( _("Pigment") );
+ item_type = TV_MITEM_PIGMENT;
+@@ -373,7 +373,7 @@
+ }
+
+
+-void PovTexPigment::output_to_povray( ofstream & file, bool in_map=false )
++void PovTexPigment::output_to_povray( ofstream & file, bool in_map )
+ {
+ if ( !used->value() ) return;
+ if ( !in_map ) file << "\n\t\tpigment {\n\t\t\t";
+diff -U3 -r truevision-0.3.10/src/tvwidgets.cc truevision-0.3.10-patched/src/tvwidgets.cc
+--- truevision-0.3.10/src/tvwidgets.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/tvwidgets.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -56,7 +56,7 @@
+ in_update = false;
+ }
+
+-void TvWidget::pack_widget( GtkWidget *box, bool tt, GtkWidget *target=NULL )
++void TvWidget::pack_widget( GtkWidget *box, bool tt, GtkWidget *target )
+ {
+ if ( tt && tooltip != NULL )
+ {
+diff -U3 -r truevision-0.3.10/src/tvwidgets2.cc truevision-0.3.10-patched/src/tvwidgets2.cc
+--- truevision-0.3.10/src/tvwidgets2.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/tvwidgets2.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -887,7 +887,7 @@
+ const char *bfiletype_ext[bfiletype_num] = { "df3" };
+ const char *bfiletype_def[bfiletype_num] = { " df3 " };
+
+-TvWidget_blendmap::TvWidget_blendmap( const char *name, const char *sname, const char *tooltip, app_objs *appref, bool is_colmap = false )
++TvWidget_blendmap::TvWidget_blendmap( const char *name, const char *sname, const char *tooltip, app_objs *appref, bool is_colmap )
+ : TvWidget( name, sname, tooltip, appref )
+ {
+ option_box = NULL;
+diff -U3 -r truevision-0.3.10/src/undo.cc truevision-0.3.10-patched/src/undo.cc
+--- truevision-0.3.10/src/undo.cc 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/undo.cc 2003-03-15 18:38:29.000000000 -0500
+@@ -181,7 +181,7 @@
+ }
+
+ // Undo layers creation / deletion / move
+-void UndoRedoManager::push( UndoAction act, ObjectLayer *lay, int sens = -1 )
++void UndoRedoManager::push( UndoAction act, ObjectLayer *lay, int sens )
+ {
+ UndoItem *item = new UndoItem( act, lay, sens );
+ UndoList.push_back( item );
+@@ -191,7 +191,7 @@
+ }
+
+ // Undo materials creation / deletion / move
+-void UndoRedoManager::push( UndoAction act, Material *mat, int position = -1 )
++void UndoRedoManager::push( UndoAction act, Material *mat, int position )
+ {
+ UndoItem *item = new UndoItem( act, mat, position );
+ UndoList.push_back( item );
+@@ -231,7 +231,7 @@
+ // The main function used
+ // in fact it is also used for redo ;-)
+ //***************************************************
+-void UndoRedoManager::undo( bool doredo = false )
++void UndoRedoManager::undo( bool doredo )
+ {
+ // Define source & destination lists
+ // The determine if we act as undo or redo...
+diff -U3 -r truevision-0.3.10/src/undo.h truevision-0.3.10-patched/src/undo.h
+--- truevision-0.3.10/src/undo.h 2002-01-01 06:43:01.000000000 -0500
++++ truevision-0.3.10-patched/src/undo.h 2003-03-15 18:38:29.000000000 -0500
+@@ -65,7 +65,7 @@
+ // one for undo and the other for redo
+ //**********************************************************
+ class UndoItem {
+- friend UndoRedoManager;
++ friend struct UndoRedoManager;
+
+ private:
+ UndoAction action;
diff --git a/media-gfx/truevision/files/truevision-0.3.10-gentoo3.patch b/media-gfx/truevision/files/truevision-0.3.10-gentoo3.patch
new file mode 100644
index 000000000000..dd96cf9c0a02
--- /dev/null
+++ b/media-gfx/truevision/files/truevision-0.3.10-gentoo3.patch
@@ -0,0 +1,18 @@
+--- truevision-0.3.10/Makefile.in 2002-01-01 11:43:00.000000000 +0000
++++ truevision-0.3.10/Makefile.in.new 2003-06-10 21:56:46.000000000 +0100
+@@ -407,11 +407,11 @@
+
+ install-data-local:
+ test -d pixmaps \
+- && install -d -m 0755 @PACKAGE_PIXMAPS_DIR@ \
+- && install -m 0644 pixmaps/* @PACKAGE_PIXMAPS_DIR@
++ && install -d -m 0755 $(PACKAGE_PIXMAPS_DIR) \
++ && install -m 0644 pixmaps/* $(PACKAGE_PIXMAPS_DIR)
+ test -d materials \
+- && install -d -m 0755 @PACKAGE_MATERIALS_DIR@ \
+- && cp -Rp materials/* @PACKAGE_MATERIALS_DIR@
++ && install -d -m 0755 $(PACKAGE_MATERIALS_DIR) \
++ && cp -Rp materials/* $(PACKAGE_MATERIALS_DIR)
+
+ dist-hook:
+ test -d pixmaps \
diff --git a/media-gfx/truevision/truevision-0.3.10.ebuild b/media-gfx/truevision/truevision-0.3.10.ebuild
index 55a1c79faada..6c03a50e9e48 100644
--- a/media-gfx/truevision/truevision-0.3.10.ebuild
+++ b/media-gfx/truevision/truevision-0.3.10.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/truevision-0.3.10.ebuild,v 1.1 2003/03/16 22:09:16 malverian Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/truevision/truevision-0.3.10.ebuild,v 1.2 2003/06/10 22:09:30 liquidx Exp $
DESCRIPTION="Gnome frontend to Povray"
HOMEPAGE="http://truevision.sourceforge.net"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/truevision/${P}.tar.gz http://unc.dl.sourceforge.net/sourceforge/truevision/${PN}-extramat-${PV}.tar.gz"
+SRC_URI="mirror://sourceforge/truevision/${P}.tar.gz
+ mirror://sourceforge/truevision/${PN}-extramat-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -12,21 +13,34 @@ KEYWORDS="~x86"
IUSE=""
DEPEND="=x11-libs/gtk+-1.2*
- media-gfx/povray"
-
-RDEPEND=${DEPEND}
-
-S="${WORKDIR}/${P}"
+ media-gfx/povray
+ sys-libs/zlib
+ virtual/opengl
+ <x11-libs/gtkglarea-1.99"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/truevision-0.3.10-gentoo2.patch || die
+ epatch ${FILESDIR}/truevision-0.3.10-gentoo3.patch || die
+}
src_compile() {
- epatch ${FILESDIR}/truevision-0.3.10-gentoo1.patch || die
- econf --prefix=${D}/usr --datadir=${D}/usr/share || die
+ econf || die
emake || die
}
src_install() {
- emake PREFIX=${D}/usr DATADIR=${D}/usr/share PACKAGE_MATERIALS_DIR=${D}/usr/share/truevision/materials PACKAGE_PIXMAPS_DIR=${D}/usr/share/pixmaps/truevision install || die
+ einstall \
+ PACKAGE_MATERIALS_DIR=${D}/usr/share/truevision/materials \
+ PACKAGE_PIXMAPS_DIR=${D}/usr/share/pixmaps/truevision || die
+
+
+ dodoc AUTHORS COPYING README ChangeLog INSTALL TODO
+ cp -r ${S}/examples ${D}/usr/share/doc/${PF}/examples
cd ${WORKDIR}/${PN}-extramat-${PV} || die
cp -R materials ${D}/usr/share/truevision/materials/ || die
+
+
+
}