summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-05 00:48:58 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-05 00:48:58 +0000
commitae372908caa1c178ef043e4f6b013680df92cd37 (patch)
tree6f2085c3f2e2b2709508740f01ee1097ab4e7877 /media-gfx/tic98/tic98-1.01.ebuild
parentMoved sys-apps/tmpreaper to app-admin/tmpreaper (diff)
downloadgentoo-2-ae372908caa1c178ef043e4f6b013680df92cd37.tar.gz
gentoo-2-ae372908caa1c178ef043e4f6b013680df92cd37.tar.bz2
gentoo-2-ae372908caa1c178ef043e4f6b013680df92cd37.zip
Moved from sys-apps/tic98 to media-gfx/tic98.
Diffstat (limited to 'media-gfx/tic98/tic98-1.01.ebuild')
-rw-r--r--media-gfx/tic98/tic98-1.01.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/tic98/tic98-1.01.ebuild b/media-gfx/tic98/tic98-1.01.ebuild
new file mode 100644
index 000000000000..ffd7c61732e6
--- /dev/null
+++ b/media-gfx/tic98/tic98-1.01.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/tic98/tic98-1.01.ebuild,v 1.1 2005/03/05 00:48:58 ciaranm Exp $
+
+inherit eutils
+
+DESCRIPTION="tic98 is a compressor for black-and-white images, in particular scanned documents. It gets very good compression, better than AT&T's DjVu system. tic98 also includes ppmd text compression (ppmd) and number compression (b_gamma_enc)"
+HOMEPAGE="http://www.cs.waikato.ac.nz/~singlis/"
+SRC_URI="http://www.cs.waikato.ac.nz/~singlis/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch $FILESDIR/${PN}.diff
+ emake all || die
+ emake all2 || die
+}
+
+src_install() {
+ dodir /usr
+ dodir /usr/bin
+ make BIN=${D}usr/bin install || die
+}