summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2005-09-08 12:40:45 +0000
committerMichael Januszewski <spock@gentoo.org>2005-09-08 12:40:45 +0000
commita5d804cfad197b6daf56195a3d6f398e89b2a220 (patch)
tree458fc4596faab1c557c765682a6486f9bcff5da9 /media-gfx/splashutils
parentMarked ~ppc (diff)
downloadgentoo-2-a5d804cfad197b6daf56195a3d6f398e89b2a220.tar.gz
gentoo-2-a5d804cfad197b6daf56195a3d6f398e89b2a220.tar.bz2
gentoo-2-a5d804cfad197b6daf56195a3d6f398e89b2a220.zip
Added a fix for #104251.
(Portage version: 1.589-cvs)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog7
-rw-r--r--media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild11
2 files changed, 14 insertions, 4 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index c5f06f4d4944..1a11db5dd95a 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.44 2005/09/02 19:42:33 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.45 2005/09/08 12:40:45 spock Exp $
+
+ 08 Sep 2005; Michał Januszewski <spock@gentoo.org>
+ splashutils-1.1.9.9-r1.ebuild:
+ Added a fix for bug #104251 -- try to support gcc built with the 'vanilla'
+ USE flag.
02 Sep 2005; Michael Hanselmann <hansmi@gentoo.org>
splashutils-1.1.9.8.ebuild:
diff --git a/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild b/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
index c315537d280f..f5bf5ad50091 100644
--- a/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
+++ b/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild,v 1.1 2005/08/28 19:33:33 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.1.9.9-r1.ebuild,v 1.2 2005/09/08 12:40:45 spock Exp $
inherit eutils multilib linux-mod
@@ -96,8 +96,13 @@ src_unpack() {
spl_conf yes CONFIG_FBSPLASH
fi
- # This should make splashutils compile on systems with hardened GCC.
- sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
+ if built_with_use gcc vanilla ; then
+ ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
+ ewarn "splashutils, you're on your own, as this configuration is not supported."
+ else
+ # This should make splashutils compile on systems with hardened GCC.
+ sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i ${S}/Makefile
+ fi
mkdir ${S}/kernel