summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-10 19:57:06 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-10 19:57:06 +0000
commit120d6449748ec3e57251f52e631956a81a901528 (patch)
tree12f6d93ecc3acdeeab225e0d30708e75e85595a8 /media-gfx/splashutils
parentRemove || die on enewuser and enewgroup. No version bump. (diff)
downloadgentoo-2-120d6449748ec3e57251f52e631956a81a901528.tar.gz
gentoo-2-120d6449748ec3e57251f52e631956a81a901528.tar.bz2
gentoo-2-120d6449748ec3e57251f52e631956a81a901528.zip
Remove old ebuilds.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
Diffstat (limited to 'media-gfx/splashutils')
-rw-r--r--media-gfx/splashutils/ChangeLog8
-rw-r--r--media-gfx/splashutils/files/openrc-splash-crash.patch11
-rw-r--r--media-gfx/splashutils/files/openrc-strlist-abi.patch424
-rw-r--r--media-gfx/splashutils/files/splashutils-gcc43-fix.patch13
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4-r1.ebuild220
-rw-r--r--media-gfx/splashutils/splashutils-1.5.4.1.ebuild210
6 files changed, 7 insertions, 879 deletions
diff --git a/media-gfx/splashutils/ChangeLog b/media-gfx/splashutils/ChangeLog
index 12ab02c495d8..e3ad660c0c55 100644
--- a/media-gfx/splashutils/ChangeLog
+++ b/media-gfx/splashutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/splashutils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.142 2008/09/08 20:34:00 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/ChangeLog,v 1.143 2008/09/10 19:57:05 spock Exp $
+
+ 10 Sep 2008; Michał Januszewski <spock@gentoo.org>
+ -files/splashutils-gcc43-fix.patch, -files/openrc-splash-crash.patch,
+ -files/openrc-strlist-abi.patch, -splashutils-1.5.4-r1.ebuild,
+ -splashutils-1.5.4.1.ebuild:
+ Remove old ebuilds.
08 Sep 2008; Markus Meier <maekke@gentoo.org> splashutils-1.5.4.2.ebuild:
amd64/x86 stable, bug #237000
diff --git a/media-gfx/splashutils/files/openrc-splash-crash.patch b/media-gfx/splashutils/files/openrc-splash-crash.patch
deleted file mode 100644
index 36eed3b703ad..000000000000
--- a/media-gfx/splashutils/files/openrc-splash-crash.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- splash.c.orig 2008-04-10 09:31:54.000000000 +0100
-+++ splash.c 2008-04-10 09:54:00.000000000 +0100
-@@ -441,6 +441,8 @@
- if (list_has(svcs_done, name))
- return 0;
-
-+ if (!svcs_done)
-+ svcs_done = rc_stringlist_new();
- rc_stringlist_add(svcs_done, name);
- svcs_done_cnt++;
- }
diff --git a/media-gfx/splashutils/files/openrc-strlist-abi.patch b/media-gfx/splashutils/files/openrc-strlist-abi.patch
deleted file mode 100644
index 4d6fe40a93b6..000000000000
--- a/media-gfx/splashutils/files/openrc-strlist-abi.patch
+++ /dev/null
@@ -1,424 +0,0 @@
---- splash.c.orig 2008-03-16 15:09:37.000000000 +0000
-+++ splash.c 2008-03-16 17:40:24.000000000 +0000
-@@ -26,6 +26,18 @@
- #include <rc.h>
- #include <fbsplash.h>
-
-+/* Some queue.h implenetations don't have this macro */
-+#ifndef TAILQ_CONCAT
-+#define TAILQ_CONCAT(head1, head2, field) do { \
-+ if (!TAILQ_EMPTY(head2)) { \
-+ *(head1)->tqh_last = (head2)->tqh_first; \
-+ (head2)->tqh_first->field.tqe_prev = (head1)->tqh_last; \
-+ (head1)->tqh_last = (head2)->tqh_last; \
-+ TAILQ_INIT((head2)); \
-+ } \
-+} while (0)
-+#endif
-+
- #define SPLASH_CMD "export SPLASH_XRES='%d'; export SPLASH_YRES='%d';" \
- "export SOFTLEVEL='%s'; export BOOTLEVEL='%s';" \
- "export DEFAULTLEVEL='%s'; export svcdir=${RC_SVCDIR};" \
-@@ -33,8 +45,8 @@
-
- static char *bootlevel = NULL;
- static char *defaultlevel = NULL;
--static char **svcs = NULL;
--static char **svcs_done = NULL;
-+static RC_STRINGLIST *svcs = NULL;
-+static RC_STRINGLIST *svcs_done = NULL;
- static int svcs_cnt = 0;
- static int svcs_done_cnt = 0;
- static pid_t pid_daemon = 0;
-@@ -46,37 +58,29 @@
- /*
- * Check whether a strlist contains a specific item.
- */
--static bool list_has(char **list, const char *item)
-+static bool list_has(RC_STRINGLIST *list, const char *item)
- {
-- for (; list && *list; list++) {
-- if (strcmp(*list, item) == 0)
-- return true;
-- }
-- return false;
--}
-+ RC_STRING *s;
-
--/*
-- * Merge two strlists keeping them sorted.
-- */
--static char** strlist_merge_sort(char **dest, char **src)
--{
-- int i;
--
-- for (i = 0; src && src[i]; i++) {
-- rc_strlist_addsort(&dest, src[i]);
-+ if (list) {
-+ TAILQ_FOREACH(s, list, entries)
-+ if (strcmp(s->value, item) == 0)
-+ return true;
- }
-- return dest;
-+ return false;
- }
-
- /*
- * Count the number of items in a strlist.
- */
--static int strlist_count(char **list)
-+static int strlist_count(RC_STRINGLIST *list)
- {
-- int c;
-+ RC_STRING *s;
-+ int c = 0;
-
-- for (c = 0; list && *list; list++)
-- c++;
-+ if (list)
-+ TAILQ_FOREACH(s, list, entries)
-+ c++;
-
- return c;
- }
-@@ -85,7 +89,7 @@
- * Create a strlist from a file pointer. Can be used
- * to get a list of words printed by an app/script.
- */
--static char **get_list_fp(char **list, FILE *fp)
-+static void get_list_fp(RC_STRINGLIST *list, FILE *fp)
- {
- char buffer[512];
- char *p;
-@@ -109,30 +113,25 @@
-
- while ((p = strsep(&token, " ")) != NULL) {
- if (strlen(p) > 1) {
-- rc_strlist_add(&list, p);
-+ rc_stringlist_add(list, p);
- }
- }
- }
--
-- return list;
- }
-
- /*
- * Create a strlist from a file. Used for svcs_start/svcs_stop.
- */
--static char **get_list(char **list, const char *file)
-+static void get_list(RC_STRINGLIST *list, const char *file)
- {
- FILE *fp;
-
- if (!(fp = fopen(file, "r"))) {
- ewarn("%s: `%s': %s", __func__, file, strerror(errno));
-- return list;
-+ } else {
-+ get_list_fp(list, fp);
-+ fclose(fp);
- }
--
-- list = get_list_fp(list, fp);
-- fclose(fp);
--
-- return list;
- }
-
- /*
-@@ -140,7 +139,7 @@
- */
- static int splash_config_gentoo(fbspl_cfg_t *cfg, fbspl_type_t type)
- {
-- char **confd;
-+ RC_STRINGLIST *confd;
- char *t;
-
- confd = rc_config_load("/etc/conf.d/splash");
-@@ -232,7 +231,7 @@
- }
- }
-
-- rc_strlist_free(confd);
-+ rc_stringlist_free(confd);
- return 0;
- }
-
-@@ -244,7 +243,7 @@
- {
- char *c;
- int l;
-- char *soft = getenv("RC_SOFTLEVEL");
-+ char *soft = getenv("RC_RUNLEVEL");
-
- if (!cmd || !soft)
- return -1;
-@@ -353,7 +352,7 @@
- */
- static int splash_init(bool start)
- {
-- char **tmp;
-+ RC_STRINGLIST *tmp;
-
- config->verbosity = FBSPL_VERB_QUIET;
- if (fbsplash_check_daemon(&pid_daemon)) {
-@@ -363,43 +362,61 @@
-
- config->verbosity = FBSPL_VERB_NORMAL;
-
-- if (svcs)
-+ if (svcs) {
- ewarn("%s: We already have a svcs list!", __func__);
-+ rc_stringlist_free(svcs);
-+ }
-+ svcs = rc_stringlist_new();
-
- /* Booting.. */
- if (start) {
-- svcs = get_list(NULL, FBSPLASH_CACHEDIR"/svcs_start");
-+ get_list(svcs, FBSPLASH_CACHEDIR"/svcs_start");
- svcs_cnt = strlist_count(svcs);
-
- svcs_done = rc_services_in_state(RC_SERVICE_STARTED);
-
- tmp = rc_services_in_state(RC_SERVICE_INACTIVE);
-- svcs_done = strlist_merge_sort(svcs_done, tmp);
-- rc_strlist_free(tmp);
-+ if (svcs_done && tmp) {
-+ TAILQ_CONCAT(svcs_done, tmp, entries);
-+ free(tmp);
-+ } else if (tmp)
-+ svcs_done = tmp;
-
- tmp = rc_services_in_state(RC_SERVICE_FAILED);
-- svcs_done = strlist_merge_sort(svcs_done, tmp);
-- rc_strlist_free(tmp);
-+ if (svcs_done && tmp) {
-+ TAILQ_CONCAT(svcs_done, tmp, entries);
-+ free(tmp);
-+ } else if (tmp)
-+ svcs_done = tmp;
-
- tmp = rc_services_in_state(RC_SERVICE_SCHEDULED);
-- svcs_done = strlist_merge_sort(svcs_done, tmp);
-- rc_strlist_free(tmp);
-+ if (svcs_done && tmp) {
-+ TAILQ_CONCAT(svcs_done, tmp, entries);
-+ free(tmp);
-+ } else if (tmp)
-+ svcs_done = tmp;
-
- svcs_done_cnt = strlist_count(svcs_done);
- /* .. or rebooting? */
- } else {
-- svcs = get_list(NULL, FBSPLASH_CACHEDIR"/svcs_stop");
-+ get_list(svcs, FBSPLASH_CACHEDIR"/svcs_stop");
- svcs_cnt = strlist_count(svcs);
-
- svcs_done = rc_services_in_state(RC_SERVICE_STARTED);
-
- tmp = rc_services_in_state(RC_SERVICE_STARTING);
-- svcs_done = strlist_merge_sort(svcs_done, tmp);
-- rc_strlist_free(tmp);
-+ if (svcs_done && tmp) {
-+ TAILQ_CONCAT(svcs_done, tmp, entries);
-+ free(tmp);
-+ } else if (tmp)
-+ svcs_done = tmp;
-
- tmp = rc_services_in_state(RC_SERVICE_INACTIVE);
-- svcs_done = strlist_merge_sort(svcs_done, tmp);
-- rc_strlist_free(tmp);
-+ if (svcs_done && tmp) {
-+ TAILQ_CONCAT(svcs_done, tmp, entries);
-+ free(tmp);
-+ } else if (tmp)
-+ svcs_done = tmp;
-
- svcs_done_cnt = svcs_cnt - strlist_count(svcs_done);
- }
-@@ -424,7 +441,7 @@
- if (list_has(svcs_done, name))
- return 0;
-
-- rc_strlist_add(&svcs_done, name);
-+ rc_stringlist_add(svcs_done, name);
- svcs_done_cnt++;
- }
-
-@@ -445,10 +462,11 @@
- */
- int splash_svcs_start()
- {
-- rc_depinfo_t *deptree;
-+ RC_DEPTREE *deptree;
- FILE *fp;
-- char **t, **deporder, *s, *r;
-- int i, j, err = 0;
-+ RC_STRINGLIST *t, *deporder;
-+ RC_STRING *s, *r;
-+ int i, err = 0;
-
- fp = fopen(FBSPLASH_CACHEDIR"/svcs_start", "w");
- if (!fp) {
-@@ -465,12 +483,13 @@
- deporder = rc_deptree_order(deptree, bootlevel, RC_DEP_START);
-
- /* Save what we've got so far to the svcs_start. */
-- i = 0;
-- if (deporder && deporder[0]) {
-- while ((s = deporder[i++])) {
-- if (i > 1)
-+ if (deporder) {
-+ i = 0;
-+ TAILQ_FOREACH(s, deporder, entries) {
-+ if (i > 0)
- fprintf(fp, " ");
-- fprintf(fp, "%s", s);
-+ fprintf(fp, "%s", s->value);
-+ i++;
- }
- }
-
-@@ -479,21 +498,18 @@
-
- /* Print the new services and skip ones that have already been started
- * in the 'boot' runlevel. */
-- i = 0;
-- if (deporder && deporder[0]) {
-- while ((s = deporder[i])) {
-- j = 0;
-- while ((r = t[j++])) {
-- if (!strcmp(deporder[i], r))
-- goto next;
-+ if (deporder) {
-+ TAILQ_FOREACH(s, deporder, entries) {
-+ TAILQ_FOREACH(r, t, entries) {
-+ if (!strcmp(s->value, r->value))
-+ break;
- }
-- fprintf(fp, " %s", s);
--next: i++;
-+ fprintf(fp, " %s", s->value);
- }
- }
-
-- rc_strlist_free(deporder);
-- rc_strlist_free(t);
-+ rc_stringlist_free(deporder);
-+ rc_stringlist_free(t);
- rc_deptree_free(deptree);
-
- out:
-@@ -506,8 +522,9 @@
- */
- int splash_svcs_stop(const char *runlevel)
- {
-- rc_depinfo_t *deptree;
-- char **deporder, *s;
-+ RC_DEPTREE *deptree;
-+ RC_STRINGLIST *deporder;
-+ RC_STRING *s;
- FILE *fp;
- int i, err = 0;
-
-@@ -524,17 +541,18 @@
- }
-
- deporder = rc_deptree_order(deptree, runlevel, RC_DEP_STOP);
--
-- i = 0;
-- if (deporder && deporder[0]) {
-- while ((s = deporder[i++])) {
-- if (i > 1)
-+
-+ if (deporder) {
-+ i = 0;
-+ TAILQ_FOREACH(s, deporder, entries) {
-+ if (i > 0)
- fprintf(fp, " ");
-- fprintf(fp, "%s", s);
-+ fprintf(fp, "%s", s->value);
-+ i++;
- }
- }
-
-- rc_strlist_free(deporder);
-+ rc_stringlist_free(deporder);
- rc_deptree_free(deptree);
- out:
- fclose(fp);
-@@ -547,8 +565,9 @@
- static int splash_start(const char *runlevel)
- {
- bool start;
-- int i, err = 0;
-+ int err = 0;
- char buf[2048];
-+ RC_STRING *s;
-
- /* Get a list of services that we'll have to handle. */
- /* We're rebooting/shutting down. */
-@@ -592,9 +611,9 @@
- return err;
-
- /* Set the initial state of all services. */
-- for (i = 0; svcs && svcs[i]; i++) {
-- splash_svc_state(svcs[i], start ? "svc_inactive_start" : "svc_inactive_stop", 0);
-- }
-+ if (svcs)
-+ TAILQ_FOREACH(s, svcs, entries)
-+ splash_svc_state(s->value, start ? "svc_inactive_start" : "svc_inactive_stop", 0);
-
- fbsplash_set_evdev();
- fbsplash_send("set autoverbose %d\n", config->autoverbose);
-@@ -640,7 +659,7 @@
- }
- }
-
--int rc_plugin_hook (rc_hook_t hook, const char *name)
-+int rc_plugin_hook(RC_HOOK hook, const char *name)
- {
- int i = 0;
- fbspl_type_t type = fbspl_bootup;
-@@ -665,18 +684,19 @@
- if (name && !strcmp(name, RC_LEVEL_SYSINIT)) {
- if (hook == RC_HOOK_RUNLEVEL_START_OUT && rc_service_in_runlevel("autoconfig", defaultlevel)) {
- FILE *fp;
-- char **list = NULL;
-- int i;
-+ RC_STRINGLIST *list;
-+ RC_STRING *s;
-
- fp = popen("if [ -e /etc/init.d/autoconfig ]; then . /etc/init.d/autoconfig ; list_services ; fi", "r");
- if (!fp)
- goto exit;
-
-- list = get_list_fp(NULL, fp);
-- for (i = 0; list && list[i]; i++) {
-- rc_service_mark(list[i], RC_SERVICE_COLDPLUGGED);
-- }
-+ list = rc_stringlist_new();
-+ get_list_fp(list, fp);
-+ TAILQ_FOREACH(s, list, entries)
-+ rc_service_mark(s->value, RC_SERVICE_COLDPLUGGED);
- pclose(fp);
-+ rc_stringlist_free(list);
- }
- goto exit;
- }
-@@ -920,12 +940,8 @@
- break;
- }
-
-- if (svcs) {
-- rc_strlist_free(svcs);
-- svcs = NULL;
-- }
--
--exit:
-+exit:
-+ rc_stringlist_free(svcs);
- free (runlev);
- return i;
- }
diff --git a/media-gfx/splashutils/files/splashutils-gcc43-fix.patch b/media-gfx/splashutils/files/splashutils-gcc43-fix.patch
deleted file mode 100644
index 518986b3bc84..000000000000
--- a/media-gfx/splashutils/files/splashutils-gcc43-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/core/libs/Makefile.am b/core/libs/Makefile.am
-index 3b598bf..6675ec1 100644
---- a/core/libs/Makefile.am
-+++ b/core/libs/Makefile.am
-@@ -13,7 +13,7 @@ PNGDEFS = -DPNG_NO_WRITE_TIME -DPNG_NO_FLOATING_POINT_SUPPORTED -DPNG_NO_WRITE_S
- -DPNG_NO_MMX_CODE
-
- # Flags for the kernel utilities
--K_CFLAGS = -Os -w -ffunction-sections -fdata-sections \
-+K_CFLAGS = -O2 -w -ffunction-sections -fdata-sections \
- -DWITH_ERRLIST -DTARGET_KERNEL -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER
-
- mostlyclean-local: \
diff --git a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild b/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
deleted file mode 100644
index b15fd1420526..000000000000
--- a/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild
+++ /dev/null
@@ -1,220 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4-r1.ebuild,v 1.5 2008/06/14 15:17:16 zmedico Exp $
-
-EAPI="1"
-
-inherit eutils multilib toolchain-funcs
-
-MISCSPLASH="miscsplashutils-0.1.8"
-GENTOOSPLASH="splashutils-gentoo-1.0.13"
-V_JPEG="6b"
-V_PNG="1.2.18"
-V_ZLIB="1.2.3"
-V_FT="2.3.5"
-
-ZLIBSRC="libs/zlib-${V_ZLIB}"
-LPNGSRC="libs/libpng-${V_PNG}"
-JPEGSRC="libs/jpeg-${V_JPEG}"
-FT2SRC="libs/freetype-${V_FT}"
-
-RESTRICT="test"
-IUSE="hardened +png +truetype +mng gpm fbcondecor"
-
-DESCRIPTION="Framebuffer splash utilities."
-HOMEPAGE="http://fbsplash.berlios.de"
-SRC_URI="mirror://berlios/fbsplash/${PN}-lite-${PV}.tar.bz2
- mirror://berlios/fbsplash/${GENTOOSPLASH}.tar.bz2
- mirror://gentoo/${MISCSPLASH}.tar.bz2
- mirror://sourceforge/libpng/libpng-${V_PNG}.tar.bz2
- ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v${V_JPEG}.tar.gz
- mirror://sourceforge/freetype/freetype-${V_FT}.tar.bz2
- http://www.gzip.org/zlib/zlib-${V_ZLIB}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND="gpm? ( sys-libs/gpm )
- truetype? ( >=media-libs/freetype-2 )
- png? ( >=media-libs/libpng-1.2.7 )
- mng? ( media-libs/lcms media-libs/libmng )
- >=media-libs/jpeg-6b
- >=sys-apps/baselayout-1.9.4-r5
- app-arch/cpio
- media-gfx/fbgrab"
-DEPEND="${RDEPEND}
- >=dev-libs/klibc-1.5
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${P/_/-}"
-SG="${WORKDIR}/${GENTOOSPLASH}"
-SM="${WORKDIR}/${MISCSPLASH}"
-
-pkg_setup() {
- if use hardened; then
- ewarn "Due to problems with klibc, it is currently impossible to compile splashutils"
- ewarn "with 'hardened' GCC flags. As a workaround, the package will be compiled with"
- ewarn "-fno-stack-protector. Hardened GCC features will not be used while building"
- ewarn "the splash kernel helper."
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- mv "${WORKDIR}"/{libpng-${V_PNG},jpeg-${V_JPEG},zlib-${V_ZLIB},freetype-${V_FT}} "${S}/libs"
- # We need to delete the Makefile and let it be rebuilt when splashutils
- # is being configured. Either that, or we end up with a segfaulting kernel
- # helper.
- rm "${S}/libs/zlib-${V_ZLIB}/Makefile"
-
- cd "${S}"
- ln -sf "${S}/src" "${WORKDIR}/core"
-
- if built_with_use sys-devel/gcc vanilla ; then
- ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
- ewarn "splashutils, you're on your own, as this configuration is not supported."
- else
- # This should make splashutils compile on systems with hardened GCC.
- sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i "${S}/Makefile.in"
- fi
-
- if ! use truetype ; then
- sed -i -e 's/fbtruetype kbd/kbd/' "${SM}/Makefile"
- fi
-
- if [ "$(gcc-version)" == "4.3" ]; then
- epatch "${FILESDIR}"/splashutils-gcc43-fix.patch
- fi
-
- cd "${SG}"
- if has_version sys-apps/openrc ; then
- epatch "${FILESDIR}"/openrc-strlist-abi.patch
- epatch "${FILESDIR}"/openrc-splash-crash.patch
- fi
-}
-
-src_compile() {
- cd "${SM}"
- emake LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils"
-
- cd "${S}"
- econf \
- $(use_with png) \
- $(use_with mng) \
- $(use_with gpm) \
- $(use_with truetype ttf) \
- $(use_with truetype ttf-kernel) \
- $(use_enable fbcondecor) \
- --with-freetype2-src=${FT2SRC} \
- --with-jpeg-src=${JPEGSRC} \
- --with-lpng-src=${LPNGSRC} \
- --with-zlib-src=${ZLIBSRC} || die "failed to configure splashutils"
-
- emake -j1 || die "failed to build splashutils"
-
- if has_version ">=sys-apps/baselayout-1.13.99"; then
- cd "${SG}"
- emake LIB=$(get_libdir) || die "failed to build the splash plugin"
- fi
-}
-
-src_install() {
- local LIB=$(get_libdir)
-
- cd "${SM}"
- make DESTDIR="${D}" LIB=${LIB} install || die
-
- cd "${S}"
- make DESTDIR="${D}" install || die
-
- mv "${D}"/usr/${LIB}/libfbsplash.so* "${D}"/${LIB}/
- gen_usr_ldscript libfbsplash.so
-
- echo 'CONFIG_PROTECT_MASK="/etc/splash"' > 99splash
- doenvd 99splash
-
- if use fbcondecor ; then
- newinitd "${SG}"/init-fbcondecor fbcondecor
- newconfd "${SG}"/fbcondecor.conf fbcondecor
- fi
- newconfd "${SG}"/splash.conf splash
-
- insinto /usr/share/${PN}
- doins "${SG}"/initrd.splash
-
- insinto /etc/splash
- doins "${SM}"/fbtruetype/luxisri.ttf
-
- if has_version ">=sys-apps/baselayout-1.13.99"; then
- cd "${SG}"
- make DESTDIR="${D}" LIB=${LIB} install || die "failed to install the splash plugin"
- else
- cp "${SG}"/splash-functions-bl1.sh "${D}"/sbin/
- fi
-
- sed -i -e "s#/lib/splash#/${LIB}/splash#" "${D}"/sbin/splash-functions.sh
- keepdir /${LIB}/splash/{tmp,cache,bin}
- dosym /${LIB}/splash/bin/fbres /sbin/fbres
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-1.0"
- previous_less_than_1_0=$?
-
- has_version "<${CATEGORY}/${PN}-1.5.3"
- previous_less_than_1_5_3=$?
-}
-
-pkg_postinst() {
- if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
- elog "This package has been designed with udev in mind. Other solutions, such as"
- elog "devfs or a static /dev tree might work, but are generally discouraged and"
- elog "not supported. If you decide to switch to udev, you might want to have a"
- elog "look at 'The Gentoo udev Guide', which can be found at"
- elog " http://www.gentoo.org/doc/en/udev-guide.xml"
- elog ""
- fi
-
- if [[ $previous_less_than_1_0 = 0 ]] ; then
- elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
- elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
- elog ""
- fi
-
- if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
- elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
- elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
- elog "to use fbcondecor, run:"
- elog " echo \"media-gfx/splashutils fbcondecor\" >> /etc/portage/package.use"
- elog "and re-emerge splashutils."
- fi
-
- if ! test -f /proc/cmdline ||
- ! egrep -q '(console|CONSOLE)=(tty1|/dev/tty1)' /proc/cmdline ; then
- elog "It is required that you add 'console=tty1' to your kernel"
- elog "command line parameters."
- elog ""
- elog "After these modifications, the relevant part of the kernel command"
- elog "line might look like:"
- elog " splash=silent,fadein,theme:emergence console=tty1"
- elog ""
- fi
-
- if ! has_version 'media-gfx/splash-themes-livecd' &&
- ! has_version 'media-gfx/splash-themes-gentoo'; then
- elog "The sample Gentoo themes (emergence, gentoo) have been removed from the"
- elog "core splashutils package. To get some themes you might want to emerge:"
- elog " media-gfx/splash-themes-livecd"
- elog " media-gfx/splash-themes-gentoo"
- fi
-
- elog "Please note that the 'fbsplash' kernel patch has now been renamed to"
- elog "'fbcondecor'. Accordingly, the old 'splash' initscript is now called"
- elog "'fbcondecor'. Make sure you update your system. See:"
- elog " http://dev.gentoo.org/~spock/projects/fbcondecor/#history"
- elog "for further info about the name changes."
- elog ""
- elog "Also note that splash_util has now been split into splash_util, fbsplashd"
- elog "and fbcondecor_ctl."
-}
diff --git a/media-gfx/splashutils/splashutils-1.5.4.1.ebuild b/media-gfx/splashutils/splashutils-1.5.4.1.ebuild
deleted file mode 100644
index 5724ab91aec8..000000000000
--- a/media-gfx/splashutils/splashutils-1.5.4.1.ebuild
+++ /dev/null
@@ -1,210 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/splashutils/splashutils-1.5.4.1.ebuild,v 1.2 2008/06/14 15:17:16 zmedico Exp $
-
-EAPI="1"
-
-inherit eutils multilib toolchain-funcs
-
-MISCSPLASH="miscsplashutils-0.1.8"
-GENTOOSPLASH="splashutils-gentoo-1.0.14"
-V_JPEG="6b"
-V_PNG="1.2.18"
-V_ZLIB="1.2.3"
-V_FT="2.3.5"
-
-ZLIBSRC="libs/zlib-${V_ZLIB}"
-LPNGSRC="libs/libpng-${V_PNG}"
-JPEGSRC="libs/jpeg-${V_JPEG}"
-FT2SRC="libs/freetype-${V_FT}"
-
-RESTRICT="test"
-IUSE="hardened +png +truetype +mng gpm fbcondecor"
-
-DESCRIPTION="Framebuffer splash utilities."
-HOMEPAGE="http://fbsplash.berlios.de"
-SRC_URI="mirror://berlios/fbsplash/${PN}-lite-${PV}.tar.bz2
- mirror://berlios/fbsplash/${GENTOOSPLASH}.tar.bz2
- mirror://gentoo/${MISCSPLASH}.tar.bz2
- mirror://sourceforge/libpng/libpng-${V_PNG}.tar.bz2
- ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v${V_JPEG}.tar.gz
- mirror://sourceforge/freetype/freetype-${V_FT}.tar.bz2
- http://www.gzip.org/zlib/zlib-${V_ZLIB}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-RDEPEND="gpm? ( sys-libs/gpm )
- truetype? ( >=media-libs/freetype-2 )
- png? ( >=media-libs/libpng-1.2.7 )
- mng? ( media-libs/lcms media-libs/libmng )
- >=media-libs/jpeg-6b
- >=sys-apps/baselayout-1.9.4-r5
- app-arch/cpio
- media-gfx/fbgrab"
-DEPEND="${RDEPEND}
- >=dev-libs/klibc-1.5
- dev-util/pkgconfig"
-
-S="${WORKDIR}/${P/_/-}"
-SG="${WORKDIR}/${GENTOOSPLASH}"
-SM="${WORKDIR}/${MISCSPLASH}"
-
-pkg_setup() {
- if use hardened; then
- ewarn "Due to problems with klibc, it is currently impossible to compile splashutils"
- ewarn "with 'hardened' GCC flags. As a workaround, the package will be compiled with"
- ewarn "-fno-stack-protector. Hardened GCC features will not be used while building"
- ewarn "the splash kernel helper."
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
- mv "${WORKDIR}"/{libpng-${V_PNG},jpeg-${V_JPEG},zlib-${V_ZLIB},freetype-${V_FT}} "${S}/libs"
- # We need to delete the Makefile and let it be rebuilt when splashutils
- # is being configured. Either that, or we end up with a segfaulting kernel
- # helper.
- rm "${S}/libs/zlib-${V_ZLIB}/Makefile"
-
- cd "${S}"
- ln -sf "${S}/src" "${WORKDIR}/core"
-
- if built_with_use sys-devel/gcc vanilla ; then
- ewarn "Your GCC was built with the 'vanilla' flag set. If you can't compile"
- ewarn "splashutils, you're on your own, as this configuration is not supported."
- else
- # This should make splashutils compile on systems with hardened GCC.
- sed -e 's@K_CFLAGS =@K_CFLAGS = -fno-stack-protector@' -i "${S}/Makefile.in"
- fi
-
- if ! use truetype ; then
- sed -i -e 's/fbtruetype kbd/kbd/' "${SM}/Makefile"
- fi
-}
-
-src_compile() {
- cd "${SM}"
- emake LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils"
-
- cd "${S}"
- econf \
- $(use_with png) \
- $(use_with mng) \
- $(use_with gpm) \
- $(use_with truetype ttf) \
- $(use_with truetype ttf-kernel) \
- $(use_enable fbcondecor) \
- --with-freetype2-src=${FT2SRC} \
- --with-jpeg-src=${JPEGSRC} \
- --with-lpng-src=${LPNGSRC} \
- --with-zlib-src=${ZLIBSRC} || die "failed to configure splashutils"
-
- emake -j1 || die "failed to build splashutils"
-
- if has_version ">=sys-apps/baselayout-1.13.99"; then
- cd "${SG}"
- emake LIB=$(get_libdir) || die "failed to build the splash plugin"
- fi
-}
-
-src_install() {
- local LIB=$(get_libdir)
-
- cd "${SM}"
- make DESTDIR="${D}" LIB=${LIB} install || die
-
- cd "${S}"
- make DESTDIR="${D}" install || die
-
- mv "${D}"/usr/${LIB}/libfbsplash.so* "${D}"/${LIB}/
- gen_usr_ldscript libfbsplash.so
-
- echo 'CONFIG_PROTECT_MASK="/etc/splash"' > 99splash
- doenvd 99splash
-
- if use fbcondecor ; then
- newinitd "${SG}"/init-fbcondecor fbcondecor
- newconfd "${SG}"/fbcondecor.conf fbcondecor
- fi
- newconfd "${SG}"/splash.conf splash
-
- insinto /usr/share/${PN}
- doins "${SG}"/initrd.splash
-
- insinto /etc/splash
- doins "${SM}"/fbtruetype/luxisri.ttf
-
- if has_version ">=sys-apps/baselayout-1.13.99"; then
- cd "${SG}"
- make DESTDIR="${D}" LIB=${LIB} install || die "failed to install the splash plugin"
- else
- cp "${SG}"/splash-functions-bl1.sh "${D}"/sbin/
- fi
-
- sed -i -e "s#/lib/splash#/${LIB}/splash#" "${D}"/sbin/splash-functions.sh
- keepdir /${LIB}/splash/{tmp,cache,bin}
- dosym /${LIB}/splash/bin/fbres /sbin/fbres
-}
-
-pkg_preinst() {
- has_version "<${CATEGORY}/${PN}-1.0"
- previous_less_than_1_0=$?
-
- has_version "<${CATEGORY}/${PN}-1.5.3"
- previous_less_than_1_5_3=$?
-}
-
-pkg_postinst() {
- if has_version sys-fs/devfsd || ! has_version sys-fs/udev ; then
- elog "This package has been designed with udev in mind. Other solutions, such as"
- elog "devfs or a static /dev tree might work, but are generally discouraged and"
- elog "not supported. If you decide to switch to udev, you might want to have a"
- elog "look at 'The Gentoo udev Guide', which can be found at"
- elog " http://www.gentoo.org/doc/en/udev-guide.xml"
- elog ""
- fi
-
- if [[ $previous_less_than_1_0 = 0 ]] ; then
- elog "Since you are upgrading from a pre-1.0 version, please make sure that you"
- elog "rebuild your initrds. You can use the splash_geninitramfs script to do that."
- elog ""
- fi
-
- if [[ $previous_less_than_1_5_3 = 0 ]] && ! use fbcondecor ; then
- elog "Starting with splashutils-1.5.3, support for the fbcondecor kernel patch"
- elog "is optional and dependent on the the 'fbcondecor' USE flag. If you wish"
- elog "to use fbcondecor, run:"
- elog " echo \"media-gfx/splashutils fbcondecor\" >> /etc/portage/package.use"
- elog "and re-emerge splashutils."
- fi
-
- if ! test -f /proc/cmdline ||
- ! egrep -q '(console|CONSOLE)=(tty1|/dev/tty1)' /proc/cmdline ; then
- elog "It is required that you add 'console=tty1' to your kernel"
- elog "command line parameters."
- elog ""
- elog "After these modifications, the relevant part of the kernel command"
- elog "line might look like:"
- elog " splash=silent,fadein,theme:emergence console=tty1"
- elog ""
- fi
-
- if ! has_version 'media-gfx/splash-themes-livecd' &&
- ! has_version 'media-gfx/splash-themes-gentoo'; then
- elog "The sample Gentoo themes (emergence, gentoo) have been removed from the"
- elog "core splashutils package. To get some themes you might want to emerge:"
- elog " media-gfx/splash-themes-livecd"
- elog " media-gfx/splash-themes-gentoo"
- fi
-
- elog "Please note that the 'fbsplash' kernel patch has now been renamed to"
- elog "'fbcondecor'. Accordingly, the old 'splash' initscript is now called"
- elog "'fbcondecor'. Make sure you update your system. See:"
- elog " http://dev.gentoo.org/~spock/projects/fbcondecor/#history"
- elog "for further info about the name changes."
- elog ""
- elog "Also note that splash_util has now been split into splash_util, fbsplashd"
- elog "and fbcondecor_ctl."
-}