summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-01-02 23:08:34 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-01-02 23:08:34 +0000
commiteb38c20f8634787f71345a849df68ac4069fe850 (patch)
treef5a586594c856bc338226b2b4c50fb77db0e48fe /media-gfx/sane-backends
parentDelete older ebuild. (diff)
downloadgentoo-2-eb38c20f8634787f71345a849df68ac4069fe850.tar.gz
gentoo-2-eb38c20f8634787f71345a849df68ac4069fe850.tar.bz2
gentoo-2-eb38c20f8634787f71345a849df68ac4069fe850.zip
Fixing a genesys specific problem, see bug #298578
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog10
-rw-r--r--media-gfx/sane-backends/files/genesys_io.patch30
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.20-r3.ebuild234
3 files changed, 272 insertions, 2 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index f20035edeac9..f50d1d64ad40 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/sane-backends
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.165 2009/11/22 20:22:19 phosphan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.166 2010/01/02 23:08:34 phosphan Exp $
+
+*sane-backends-1.0.20-r3 (02 Jan 2010)
+
+ 02 Jan 2010; Patrick Kursawe <phosphan@gentoo.org>
+ +sane-backends-1.0.20-r3.ebuild, +files/genesys_io.patch:
+ Fixing a genesys specific problem, see bug #298578
*sane-backends-1.0.20-r2 (22 Nov 2009)
diff --git a/media-gfx/sane-backends/files/genesys_io.patch b/media-gfx/sane-backends/files/genesys_io.patch
new file mode 100644
index 000000000000..5871f4779cae
--- /dev/null
+++ b/media-gfx/sane-backends/files/genesys_io.patch
@@ -0,0 +1,30 @@
+commit 980f83da6c61577dca7789c025af1a4cbb06b1c1
+Author: Pierre Willenbrock <pierre@pirsoft.dnsalias.org>
+Date: Wed Jun 3 00:16:16 2009 +0200
+
+ Always send registers before trying to acquire a line
+
+diff --git a/backend/genesys_gl841.c b/backend/genesys_gl841.c
+index 5d7addc..d1d20c1 100644
+--- a/backend/genesys_gl841.c
++++ b/backend/genesys_gl841.c
+@@ -4948,9 +4948,6 @@ gl841_offset_calibration (Genesys_Device * dev)
+ return status;
+ }
+
+- RIE (gl841_bulk_write_register
+- (dev, dev->calib_reg, GENESYS_GL841_MAX_REGS));
+-
+ used_res = dev->current_setup.xres;
+ num_pixels = dev->current_setup.pixels;
+
+@@ -4999,6 +4996,9 @@ gl841_offset_calibration (Genesys_Device * dev)
+
+ do {
+
++ RIE (gl841_bulk_write_register
++ (dev, dev->calib_reg, GENESYS_GL841_MAX_REGS));
++
+ for (j=0; j < channels; j++) {
+ off[j] = (offh[j]+offl[j])/2;
+ dev->frontend.offset[j] = off[j];
diff --git a/media-gfx/sane-backends/sane-backends-1.0.20-r3.ebuild b/media-gfx/sane-backends/sane-backends-1.0.20-r3.ebuild
new file mode 100644
index 000000000000..d849ae0bbbf3
--- /dev/null
+++ b/media-gfx/sane-backends/sane-backends-1.0.20-r3.ebuild
@@ -0,0 +1,234 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.20-r3.ebuild,v 1.1 2010/01/02 23:08:34 phosphan Exp $
+
+EAPI="1"
+
+inherit eutils flag-o-matic
+
+# gphoto and v4l are handled by their usual USE flags.
+# The pint backend was disabled because I could not get it to compile.
+IUSE_SANE_BACKENDS="
+ abaton
+ agfafocus
+ apple
+ artec
+ artec_eplus48u
+ as6e
+ avision
+ bh
+ canon
+ canon630u
+ canon_dr
+ canon_pp
+ cardscan
+ coolscan
+ coolscan2
+ coolscan3
+ dc25
+ dc210
+ dc240
+ dell1600n_net
+ dmc
+ epjitsu
+ epson
+ epson2
+ fujitsu
+ genesys
+ gt68xx
+ hp
+ hp3500
+ hp3900
+ hp4200
+ hp5400
+ hp5590
+ hpsj5s
+ hpljm1005
+ hs2p
+ ibm
+ leo
+ lexmark
+ ma1509
+ matsushita
+ microtek
+ microtek2
+ mustek
+ mustek_pp
+ mustek_usb
+ mustek_usb2
+ nec
+ net
+ niash
+ pie
+ pixma
+ plustek
+ plustek_pp
+ qcam
+ ricoh
+ rts8891
+ s9036
+ sceptre
+ sharp
+ sm3600
+ sm3840
+ snapscan
+ sp15c
+ st400
+ stv680
+ tamarack
+ teco1
+ teco2
+ teco3
+ test
+ u12
+ umax
+ umax_pp
+ umax1220u
+ xerox_mfp"
+
+IUSE="avahi usb gphoto2 ipv6 v4l doc"
+
+for backend in ${IUSE_SANE_BACKENDS}; do
+ IUSE="${IUSE} +sane_backends_${backend}"
+done
+
+DESCRIPTION="Scanner Access Now Easy - Backends"
+HOMEPAGE="http://www.sane-project.org/"
+
+RDEPEND="
+ sane_backends_dc210? ( >=media-libs/jpeg-6b )
+ sane_backends_dc240? ( >=media-libs/jpeg-6b )
+ sane_backends_dell1600n_net? ( >=media-libs/jpeg-6b )
+ avahi? ( >=net-dns/avahi-0.6.24 )
+ x86? (
+ sane_backends_canon_pp? ( sys-libs/libieee1284 )
+ sane_backends_hpsj5s? ( sys-libs/libieee1284 )
+ sane_backends_mustek_pp? ( sys-libs/libieee1284 )
+ )
+ amd64? (
+ sane_backends_canon_pp? ( sys-libs/libieee1284 )
+ sane_backends_hpsj5s? ( sys-libs/libieee1284 )
+ sane_backends_mustek_pp? ( sys-libs/libieee1284 )
+ )
+ usb? ( virtual/libusb:0 )
+ gphoto2? (
+ media-libs/libgphoto2
+ >=media-libs/jpeg-6b
+ )
+ v4l? ( sys-kernel/linux-headers
+ arm? ( media-libs/libv4l )
+ alpha? ( media-libs/libv4l )
+ amd64? ( media-libs/libv4l )
+ ppc? ( media-libs/libv4l )
+ ppc64? ( media-libs/libv4l )
+ x86? ( media-libs/libv4l )
+ )"
+
+DEPEND="${RDEPEND}
+ doc? (
+ virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/tetex app-text/ptex )
+ )
+ >=sys-apps/sed-4"
+
+# We now use new syntax construct (SUBSYSTEMS!="usb|usb_device)
+RDEPEND="${RDEPEND}
+ !<sys-fs/udev-114"
+
+# Could not access via ftp on 2006-07-20
+SRC_URI="http://alioth.debian.org/frs/download.php/2318/${P}.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/${P}/${P}.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/old-versions/${P}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# the blank is intended - an empty string would result in building ALL backends.
+BACKENDS=" "
+
+pkg_setup() {
+
+ enewgroup scanner
+
+ use gphoto2 && BACKENDS="gphoto2"
+ use v4l && BACKENDS="${BACKENDS} v4l"
+ for backend in ${IUSE_SANE_BACKENDS}; do
+ if use "sane_backends_${backend}"; then
+ BACKENDS="${BACKENDS} ${backend}"
+ fi
+ done
+ IEEE1284_BACKENDS="canon_pp hpsj5s mustek_pp"
+ if ! use x86 && ! use amd64; then
+ tmp="${IUSE_SANE_BACKENDS}"
+ for backend in ${IEEE1284_BACKENDS}; do
+ if [[ "${tmp/$backend/}" != "${IUSE_SANE_BACKENDS}" ]]; then
+ ewarn "You selected a backend which is disabled because it's not usable in your arch."
+ fi
+ done
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cat >> backend/dll.conf.in <<-EOF
+ # Add support for the HP-specific backend. Needs net-print/hplip installed.
+ hpaio
+ EOF
+ epatch "${FILESDIR}/${PV}-unbreak-udev.diff"
+ epatch "${FILESDIR}/udev-rule-6.patch"
+ epatch "${FILESDIR}/genesys_io.patch"
+}
+
+src_compile() {
+ append-flags -fno-strict-aliasing
+
+ myconf=$(use_enable usb libusb)
+ if ! use doc; then
+ myconf="${myconf} --disable-latex"
+ fi
+ if use sane_backends_mustek_pp; then
+ myconf="${myconf} --enable-parport-directio"
+ fi
+ SANEI_JPEG="sanei_jpeg.o" SANEI_JPEG_LO="sanei_jpeg.lo" \
+ BACKENDS="${BACKENDS}" econf \
+ $(use_with gphoto2) \
+ $(use_enable ipv6) \
+ $(use_enable avahi) \
+ ${myconf} || die "econf failed"
+
+ emake VARTEXFONTS="${T}/fonts" || die
+
+ if use usb; then
+ cd tools/hotplug
+ grep -v '^$' libsane.usermap > libsane.usermap.new
+ mv libsane.usermap.new libsane.usermap
+ fi
+}
+
+src_install () {
+ make INSTALL_LOCKPATH="" DESTDIR="${D}" install \
+ docdir=/usr/share/doc/${PF}
+ keepdir /var/lib/lock/sane
+ fowners root:scanner /var/lib/lock/sane
+ fperms g+w /var/lib/lock/sane
+ dodir /etc/env.d
+ if use usb; then
+ cd tools/hotplug
+ insinto /etc/hotplug/usb
+ exeinto /etc/hotplug/usb
+ doins libsane.usermap
+ doexe libusbscanner
+ newdoc README README.hotplug
+ echo >> "${D}"/etc/env.d/30sane "USB_DEVFS_PATH=/dev/bus/usb"
+ cd ../..
+ fi
+ cd tools/udev
+ dodir /etc/udev/rules.d
+ insinto /etc/udev/rules.d
+ newins libsane.rules 70-libsane.rules
+ cd ../..
+ dodoc NEWS AUTHORS ChangeLog* README README.linux
+ echo "SANE_CONFIG_DIR=/etc/sane.d" >> "${D}"/etc/env.d/30sane
+}