summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-08 19:35:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2011-05-08 19:35:19 +0000
commita70d18026491760aa19ef0f9badc9e478d38ce3c (patch)
treef5fc0623bdd4e0b245a985c60ea445fc6d49f020 /media-gfx/sane-backends
parentamd64 stable, bug 295613 (diff)
downloadgentoo-2-a70d18026491760aa19ef0f9badc9e478d38ce3c.tar.gz
gentoo-2-a70d18026491760aa19ef0f9badc9e478d38ce3c.tar.bz2
gentoo-2-a70d18026491760aa19ef0f9badc9e478d38ce3c.zip
Non-maintainer version bump for sane-backends-1.0.22, see bug #355827. Add similar comments for epkowa as it is done with hplip; use emake for install; port to EAPI=4; avoid changing directories so often.
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/sane-backends')
-rw-r--r--media-gfx/sane-backends/ChangeLog10
-rw-r--r--media-gfx/sane-backends/sane-backends-1.0.22.ebuild217
2 files changed, 226 insertions, 1 deletions
diff --git a/media-gfx/sane-backends/ChangeLog b/media-gfx/sane-backends/ChangeLog
index 62f0bd4125e6..a6447536ad60 100644
--- a/media-gfx/sane-backends/ChangeLog
+++ b/media-gfx/sane-backends/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/sane-backends
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.182 2011/02/25 08:52:40 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/ChangeLog,v 1.183 2011/05/08 19:35:19 flameeyes Exp $
+
+*sane-backends-1.0.22 (08 May 2011)
+
+ 08 May 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ +sane-backends-1.0.22.ebuild:
+ Non-maintainer version bump for sane-backends-1.0.22, see bug #355827. Add
+ similar comments for epkowa as it is done with hplip; use emake for install;
+ port to EAPI=4; avoid changing directories so often.
25 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
sane-backends-1.0.21-r1.ebuild:
diff --git a/media-gfx/sane-backends/sane-backends-1.0.22.ebuild b/media-gfx/sane-backends/sane-backends-1.0.22.ebuild
new file mode 100644
index 000000000000..81a0f9a6be8c
--- /dev/null
+++ b/media-gfx/sane-backends/sane-backends-1.0.22.ebuild
@@ -0,0 +1,217 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sane-backends/sane-backends-1.0.22.ebuild,v 1.1 2011/05/08 19:35:19 flameeyes Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic multilib
+
+# gphoto and v4l are handled by their usual USE flags.
+# The pint backend was disabled because I could not get it to compile.
+# The mustek_usb2 backend would force us to use --enable-pthreads which is off
+# by default for linux. Let's keep this one out until we find a way how to
+# handle this cleanly.
+IUSE_SANE_BACKENDS="
+ abaton
+ agfafocus
+ apple
+ artec
+ artec_eplus48u
+ as6e
+ avision
+ bh
+ canon
+ canon630u
+ canon_dr
+ canon_pp
+ cardscan
+ coolscan
+ coolscan2
+ coolscan3
+ dc25
+ dc210
+ dc240
+ dell1600n_net
+ dmc
+ epjitsu
+ epson
+ epson2
+ fujitsu
+ genesys
+ gt68xx
+ hp
+ hp3500
+ hp3900
+ hp4200
+ hp5400
+ hp5590
+ hpsj5s
+ hpljm1005
+ hs2p
+ ibm
+ kodak
+ kvs1025
+ kvs20xx
+ leo
+ lexmark
+ ma1509
+ magicolor
+ matsushita
+ microtek
+ microtek2
+ mustek
+ mustek_pp
+ mustek_usb
+ nec
+ net
+ niash
+ p5
+ pie
+ pixma
+ plustek
+ plustek_pp
+ qcam
+ ricoh
+ rts8891
+ s9036
+ sceptre
+ sharp
+ sm3600
+ sm3840
+ snapscan
+ sp15c
+ st400
+ stv680
+ tamarack
+ teco1
+ teco2
+ teco3
+ test
+ u12
+ umax
+ umax_pp
+ umax1220u
+ xerox_mfp"
+
+IUSE="avahi usb gphoto2 ipv6 v4l doc"
+
+for backend in ${IUSE_SANE_BACKENDS}; do
+ IUSE="${IUSE} +sane_backends_${backend}"
+done
+
+DESCRIPTION="Scanner Access Now Easy - Backends"
+HOMEPAGE="http://www.sane-project.org/"
+
+RDEPEND="
+ sane_backends_dc210? ( virtual/jpeg )
+ sane_backends_dc240? ( virtual/jpeg )
+ sane_backends_dell1600n_net? ( virtual/jpeg )
+ avahi? ( >=net-dns/avahi-0.6.24 )
+ sane_backends_canon_pp? ( sys-libs/libieee1284 )
+ sane_backends_hpsj5s? ( sys-libs/libieee1284 )
+ sane_backends_mustek_pp? ( sys-libs/libieee1284 )
+ usb? ( virtual/libusb:0 )
+ gphoto2? (
+ media-libs/libgphoto2
+ virtual/jpeg
+ )
+ v4l? ( media-libs/libv4l )"
+
+DEPEND="${RDEPEND}
+ v4l? ( sys-kernel/linux-headers )
+ doc? (
+ virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/ptex )
+ )
+ >=sys-apps/sed-4"
+
+# We now use new syntax construct (SUBSYSTEMS!="usb|usb_device)
+RDEPEND="${RDEPEND}
+ !<sys-fs/udev-114"
+
+SRC_URI="ftp://ftp.sane-project.org/pub/sane/${P}/${P}.tar.gz
+ ftp://ftp.sane-project.org/pub/sane/old-versions/${P}/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2 public-domain"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_setup() {
+ enewgroup scanner
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ cat >> backend/dll.conf.in <<-EOF
+ # Add support for the HP-specific backend. Needs net-print/hplip installed.
+ hpaio
+ # Add support for the Epson-specific backend. Needs media-gfx/iscan installed.
+ epkowa
+ EOF
+ #epatch "${DISTDIR}/${P}-i18n.patch"
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # the blank is intended - an empty string would result in building ALL backends.
+ local BACKENDS=" "
+
+ use gphoto2 && BACKENDS="gphoto2"
+ use v4l && BACKENDS="${BACKENDS} v4l"
+ for backend in ${IUSE_SANE_BACKENDS}; do
+ if use "sane_backends_${backend}"; then
+ BACKENDS="${BACKENDS} ${backend}"
+ fi
+ done
+
+ local myconf=$(use_enable usb libusb)
+ if ! use doc; then
+ myconf="${myconf} --disable-latex"
+ fi
+ if use sane_backends_mustek_pp; then
+ myconf="${myconf} --enable-parport-directio"
+ fi
+ if ! ( use sane_backends_canon_pp || use sane_backends_hpsj5s || use sane_backends_mustek_pp ); then
+ myconf="${myconf} sane_cv_use_libieee1284=no"
+ fi
+ SANEI_JPEG="sanei_jpeg.o" SANEI_JPEG_LO="sanei_jpeg.lo" \
+ BACKENDS="${BACKENDS}" econf \
+ $(use_with gphoto2) \
+ $(use_enable ipv6) \
+ $(use_enable avahi) \
+ ${myconf}
+}
+
+src_compile() {
+ emake VARTEXFONTS="${T}/fonts" || die
+
+ if use usb; then
+ cd tools/hotplug
+ grep -v '^$' libsane.usermap > libsane.usermap.new
+ mv libsane.usermap.new libsane.usermap
+ fi
+}
+
+src_install () {
+ emake INSTALL_LOCKPATH="" DESTDIR="${D}" install \
+ docdir=/usr/share/doc/${PF} || die
+ keepdir /var/lib/lock/sane
+ fowners root:scanner /var/lib/lock/sane
+ fperms g+w /var/lib/lock/sane
+ dodir /etc/env.d
+ if use usb; then
+ insinto /etc/hotplug/usb
+ exeinto /etc/hotplug/usb
+ doins tools/hotplug/libsane.usermap
+ doexe tools/hotplug/libusbscanner
+ newdoc tools/hotplug/README tools/hotplug/README.hotplug
+ echo >> "${D}"/etc/env.d/30sane "USB_DEVFS_PATH=/dev/bus/usb"
+ fi
+ insinto /$(get_libdir)/udev/rules.d
+ newins tools/udev/libsane.rules 41-libsane.rules
+
+ dodoc NEWS AUTHORS ChangeLog* README README.linux
+ echo "SANE_CONFIG_DIR=/etc/sane.d" >> "${D}"/etc/env.d/30sane
+}