summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-23 21:15:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-23 21:15:03 +0000
commita012a1c81f381834a7a4a8760f3e28d279de5638 (patch)
treea4469478baef3e0ed337a6cb12f89d9328649f8f /media-gfx/sam2p
parentarm stable, bug #333421 (diff)
downloadgentoo-2-a012a1c81f381834a7a4a8760f3e28d279de5638.tar.gz
gentoo-2-a012a1c81f381834a7a4a8760f3e28d279de5638.tar.bz2
gentoo-2-a012a1c81f381834a7a4a8760f3e28d279de5638.zip
Workaround bug in ccdep.pl with GCC 4.5.x wrt #315619.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/sam2p')
-rw-r--r--media-gfx/sam2p/ChangeLog5
-rw-r--r--media-gfx/sam2p/sam2p-0.47.ebuild34
2 files changed, 25 insertions, 14 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index 6d269dc970f7..be4c44827dce 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/sam2p
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.39 2010/06/11 20:21:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.40 2010/08/23 21:15:03 ssuominen Exp $
+
+ 23 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> sam2p-0.47.ebuild:
+ Workaround bug in ccdep.pl with GCC 4.5.x wrt #315619.
*sam2p-0.47 (11 Jun 2010)
diff --git a/media-gfx/sam2p/sam2p-0.47.ebuild b/media-gfx/sam2p/sam2p-0.47.ebuild
index 7bbfc8a60722..c7d15443cef1 100644
--- a/media-gfx/sam2p/sam2p-0.47.ebuild
+++ b/media-gfx/sam2p/sam2p-0.47.ebuild
@@ -1,40 +1,48 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.47.ebuild,v 1.1 2010/06/11 20:21:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.47.ebuild,v 1.2 2010/08/23 21:15:03 ssuominen Exp $
-inherit toolchain-funcs eutils autotools
+EAPI=2
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
HOMEPAGE="http://code.google.com/p/sam2p/"
SRC_URI="http://sam2p.googlecode.com/files/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="examples gif"
-DEPEND="dev-lang/perl"
RDEPEND=""
+DEPEND="dev-lang/perl"
RESTRICT="test"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PN}-0.45-fbsd.patch"
- epatch "${FILESDIR}/${PN}-0.45-nostrip.patch"
- epatch "${FILESDIR}/${PN}-0.45-cflags.patch"
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.45-fbsd.patch \
+ "${FILESDIR}"/${PN}-0.45-nostrip.patch \
+ "${FILESDIR}"/${PN}-0.45-cflags.patch
+
+ touch stdafx.h bts2.tth #315619
+
eautoreconf
}
-src_compile() {
+src_configure() {
tc-export CXX
- econf --enable-lzw $(use_enable gif) || die "econf failed"
- emake || die "make failed"
+ econf \
+ --enable-lzw \
+ $(use_enable gif)
+
+ rm -f stdafx.h bts2.tth
}
src_install() {
- dobin sam2p || die "Failed to install sam2p"
+ dobin sam2p || die
dodoc README
+
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins examples/*