summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-24 18:48:05 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-24 18:48:05 +0000
commit45439e62f6272ae1428a55ae0b1c3de815600c79 (patch)
tree33d32ed0d62f14acef2aea4699f1e207ed7a8d5a /media-gfx/sam2p
parentadd keywords (bug #275124); tidy (diff)
downloadgentoo-2-45439e62f6272ae1428a55ae0b1c3de815600c79.tar.gz
gentoo-2-45439e62f6272ae1428a55ae0b1c3de815600c79.tar.bz2
gentoo-2-45439e62f6272ae1428a55ae0b1c3de815600c79.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/sam2p')
-rw-r--r--media-gfx/sam2p/ChangeLog9
-rw-r--r--media-gfx/sam2p/sam2p-0.46.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index ae8eeea38303..d7de6951da94 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/sam2p
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.36 2009/03/18 19:19:09 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.37 2009/06/24 18:48:05 aballier Exp $
+
+*sam2p-0.46 (24 Jun 2009)
+
+ 24 Jun 2009; Alexis Ballier <aballier@gentoo.org> +sam2p-0.46.ebuild:
+ version bump
18 Mar 2009; Raúl Porcel <armin76@gentoo.org> sam2p-0.45-r1.ebuild:
arm/s390/sh stable wrt #253551
diff --git a/media-gfx/sam2p/sam2p-0.46.ebuild b/media-gfx/sam2p/sam2p-0.46.ebuild
new file mode 100644
index 000000000000..633a660efd6d
--- /dev/null
+++ b/media-gfx/sam2p/sam2p-0.46.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.46.ebuild,v 1.1 2009/06/24 18:48:05 aballier Exp $
+
+inherit toolchain-funcs eutils autotools
+
+DESCRIPTION="Utility to convert raster images to EPS, PDF and many others"
+HOMEPAGE="http://www.inf.bme.hu/~pts/sam2p/"
+SRC_URI="http://www.inf.bme.hu/~pts/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="examples gif"
+DEPEND="dev-lang/perl"
+RDEPEND="virtual/libc"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.45-fbsd.patch"
+ epatch "${FILESDIR}/${PN}-0.45-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-0.45-cflags.patch"
+ eautoreconf
+}
+
+src_compile() {
+ tc-export CXX
+ econf --enable-lzw $(use_enable gif) || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dobin sam2p || die "Failed to install sam2p"
+ dodoc README
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+}