summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-27 21:00:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-27 21:00:58 +0000
commit2e89eccd4daeacda1819d2b42e5b1e5c54dc304c (patch)
tree93d497ad8ab5874733758ad46a33e770d89ac962 /media-gfx/sam2p
parentDrop insecure version wrt cleanup for security bug 481186. ACK by prometheanf... (diff)
downloadgentoo-2-2e89eccd4daeacda1819d2b42e5b1e5c54dc304c.tar.gz
gentoo-2-2e89eccd4daeacda1819d2b42e5b1e5c54dc304c.tar.bz2
gentoo-2-2e89eccd4daeacda1819d2b42e5b1e5c54dc304c.zip
Fix build with gcc 4.8, bug #463434 by Philipp
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-gfx/sam2p')
-rw-r--r--media-gfx/sam2p/ChangeLog8
-rw-r--r--media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch39
-rw-r--r--media-gfx/sam2p/sam2p-0.49.1.ebuild7
3 files changed, 49 insertions, 5 deletions
diff --git a/media-gfx/sam2p/ChangeLog b/media-gfx/sam2p/ChangeLog
index 025e933cba97..092df077d921 100644
--- a/media-gfx/sam2p/ChangeLog
+++ b/media-gfx/sam2p/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/sam2p
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.56 2012/09/09 16:55:29 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/ChangeLog,v 1.57 2013/08/27 21:00:58 aballier Exp $
+
+ 27 Aug 2013; Alexis Ballier <aballier@gentoo.org> sam2p-0.49.1.ebuild,
+ +files/sam2p-0.49.1-gcc48.patch:
+ Fix build with gcc 4.8, bug #463434 by Philipp
09 Sep 2012; Raúl Porcel <armin76@gentoo.org> sam2p-0.49.1.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #419071
diff --git a/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch b/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch
new file mode 100644
index 000000000000..d427c2076d3c
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.49.1-gcc48.patch
@@ -0,0 +1,39 @@
+Index: ccdep.pl
+===================================================================
+--- ccdep.pl (revision 123)
++++ ccdep.pl (revision 125)
+@@ -137,13 +137,20 @@
+
+ my @DS=find_ds();
+ my @DSQ=map{shq$_}@DS;
+-my $R="$GCCP -DOBJDEP -M -MG -E 2>&1 @DSQ";
+-$R=backtick($R);
++my $DIAG=" -fno-diagnostics-show-caret";
++my $Q="$GCCP -DOBJDEP$DIAG -M -MG -E 2>&1 @DSQ";
++my $R=backtick($Q);
++if ($R=~/\berror: .*-fno-diagnostics-show-caret\b/) {
++ # gcc-4.6 and earlier don't have this flag, and they fail.
++ $Q=~s@ -fno-diagnostics-show-caret(?=\s)@@;
++ $DIAG="";
++ $R=backtick($Q);
++}
+
+ if ($R!~/: warning: #warning\b/) {
+ # config2.h:314:4: warning: #warning REQUIRES: c_lgcc3.o
+ # Dat: g++-3.3 ignores #warning with -M -MG -E
+- $R.="\n".backtick("$GCCP -DOBJDEP -E 2>&1 >/dev/null @DSQ");
++ $R.="\n".backtick("$GCCP -DOBJDEP$DIAG -E 2>&1 >/dev/null @DSQ");
+ }
+
+ ## die $R;
+--- rule.hpp 2013-04-18 12:14:20.385333527 +0200
++++ rule.hpp 2013-04-18 12:14:35.818870070 +0200
+@@ -88,7 +88,7 @@
+ PR_PNGAuto=15,
+ PR_PNGAutoMaybe=25,
+ PR_PNGAutoBadUnsigned=45,
+- PR_PNGAutoBadSigned=55,
++ PR_PNGAutoBadSigned=55
+ END_STATIC_ENUM()
+ pr_t Predictor;
+
diff --git a/media-gfx/sam2p/sam2p-0.49.1.ebuild b/media-gfx/sam2p/sam2p-0.49.1.ebuild
index 531c47eeb727..ef9f32224e1c 100644
--- a/media-gfx/sam2p/sam2p-0.49.1.ebuild
+++ b/media-gfx/sam2p/sam2p-0.49.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.49.1.ebuild,v 1.9 2012/09/09 16:55:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/sam2p/sam2p-0.49.1.ebuild,v 1.10 2013/08/27 21:00:58 aballier Exp $
EAPI=4
inherit autotools eutils toolchain-funcs
@@ -22,7 +22,8 @@ RESTRICT="test"
src_prepare() {
epatch \
"${FILESDIR}"/${PN}-0.45-fbsd.patch \
- "${FILESDIR}"/${PN}-0.49.1-build.patch
+ "${FILESDIR}"/${PN}-0.49.1-build.patch \
+ "${FILESDIR}"/${PN}-0.49.1-gcc48.patch
eautoreconf
tc-export CXX
}