summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-03-10 09:19:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-03-10 09:19:20 +0000
commitef5b33f9124f5aefc16b7a31c0d71baf0b28087b (patch)
treea725bfd1a3a725b005783e7fdb84d59a95b7774e /media-gfx/pixie
parent[bump] dev-perl/Text-CSV_XS-0.870.0 (diff)
downloadgentoo-2-ef5b33f9124f5aefc16b7a31c0d71baf0b28087b.tar.gz
gentoo-2-ef5b33f9124f5aefc16b7a31c0d71baf0b28087b.tar.bz2
gentoo-2-ef5b33f9124f5aefc16b7a31c0d71baf0b28087b.zip
Fix building with sys-libs/zlib >= 1.2.5.2 wrt #406899 by Helmut Jarausch
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/pixie')
-rw-r--r--media-gfx/pixie/ChangeLog6
-rw-r--r--media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch73
-rw-r--r--media-gfx/pixie/pixie-2.2.6-r1.ebuild5
3 files changed, 81 insertions, 3 deletions
diff --git a/media-gfx/pixie/ChangeLog b/media-gfx/pixie/ChangeLog
index c591023032b0..f31216df68d8 100644
--- a/media-gfx/pixie/ChangeLog
+++ b/media-gfx/pixie/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/pixie
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/ChangeLog,v 1.58 2012/02/29 02:21:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/ChangeLog,v 1.59 2012/03/10 09:19:20 ssuominen Exp $
+
+ 10 Mar 2012; Samuli Suominen <ssuominen@gentoo.org> pixie-2.2.6-r1.ebuild,
+ +files/pixie-2.2.6-zlib-1.2.5.2.patch:
+ Fix building with sys-libs/zlib >= 1.2.5.2 wrt #406899 by Helmut Jarausch
29 Feb 2012; Jeroen Roovers <jer@gentoo.org> pixie-2.2.6-r1.ebuild:
Do not link statically (bug #383035).
diff --git a/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch b/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
new file mode 100644
index 000000000000..6d022f02fdb1
--- /dev/null
+++ b/media-gfx/pixie/files/pixie-2.2.6-zlib-1.2.5.2.patch
@@ -0,0 +1,73 @@
+http://bugs.gentoo.org/406899
+
+--- src/ri/rib.l
++++ src/ri/rib.l
+@@ -17,7 +17,7 @@
+
+ // Overwrite the YYinput so that it uses libz
+ #undef YY_INPUT
+-#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread(ribin,buf,maxlen)) < 0) \
++#define YY_INPUT(buf, retval, maxlen) if ( (retval = gzread((gzFile)ribin,buf,maxlen)) < 0) \
+ YY_FATAL_ERROR( "input in flex scanner failed" );
+
+ #endif
+@@ -223,7 +223,7 @@
+ TRibFile *nextFile = ribStack->next;
+ rib_delete_buffer( YY_CURRENT_BUFFER );
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif
+@@ -243,7 +243,7 @@
+ rib_delete_buffer( YY_CURRENT_BUFFER );
+
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif
+--- src/ri/ribOut.cpp
++++ src/ri/ribOut.cpp
+@@ -162,7 +162,7 @@
+
+ #ifdef HAVE_ZLIB
+ if (outputCompressed) {
+- gzclose(outFile);
++ gzclose((gzFile)outFile);
+ } else {
+ fclose(outFile);
+ }
+--- src/ri/ribOut.h
++++ src/ri/ribOut.h
+@@ -237,7 +237,7 @@
+ const int l = vsprintf(scratch,mes,args);
+
+ #ifdef HAVE_ZLIB
+- if (outputCompressed) gzwrite(outFile,scratch,l);
++ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
+ else fwrite(scratch,1,l,outFile);
+ #else
+ fwrite(scratch,1,l,outFile);
+@@ -258,7 +258,7 @@
+ const int l = vsprintf(scratch,mes,args);
+
+ #ifdef HAVE_ZLIB
+- if (outputCompressed) gzwrite(outFile,scratch,l);
++ if (outputCompressed) gzwrite((gzFile)outFile,scratch,l);
+ else fwrite(scratch,1,l,outFile);
+ #else
+ fwrite(scratch,1,l,outFile);
+--- src/ri/rib.y
++++ src/ri/rib.y
+@@ -2940,7 +2940,7 @@
+
+ if (ribin != NULL) {
+ #ifdef HAVE_ZLIB
+- gzclose(ribin);
++ gzclose((gzFile)ribin);
+ #else
+ fclose(ribin);
+ #endif
diff --git a/media-gfx/pixie/pixie-2.2.6-r1.ebuild b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
index a757591b292f..5f6d359432c0 100644
--- a/media-gfx/pixie/pixie-2.2.6-r1.ebuild
+++ b/media-gfx/pixie/pixie-2.2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-2.2.6-r1.ebuild,v 1.9 2012/02/29 02:21:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pixie/pixie-2.2.6-r1.ebuild,v 1.10 2012/03/10 09:19:20 ssuominen Exp $
EAPI="2"
@@ -44,9 +44,10 @@ DEPEND="${RDEPEND}
sys-devel/bison"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-zlib-1.2.5.2.patch
# FIX: missing @includedir@
# https://sf.net/tracker/?func=detail&aid=2923415&group_id=59462&atid=491094
- epatch "${FILESDIR}/${P}-autotools.patch"
+ epatch "${FILESDIR}"/${P}-autotools.patch
eautoreconf
# FIX: removing pre-compiled shaders