summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-05-19 12:03:35 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-05-19 12:03:35 +0000
commit2be9f7248d8085b326dc704afe420a84b3202778 (patch)
treead6be0979c4d411698af6f9b1ce97801c3e14aa0 /media-gfx/optipng
parentFix build problems with gcc-4.4 (bug #269452) and glibc-2.10.1 (bug #270263) ... (diff)
downloadgentoo-2-2be9f7248d8085b326dc704afe420a84b3202778.tar.gz
gentoo-2-2be9f7248d8085b326dc704afe420a84b3202778.tar.bz2
gentoo-2-2be9f7248d8085b326dc704afe420a84b3202778.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'media-gfx/optipng')
-rw-r--r--media-gfx/optipng/ChangeLog9
-rw-r--r--media-gfx/optipng/optipng-0.6.3.ebuild (renamed from media-gfx/optipng/optipng-0.6.2.ebuild)22
2 files changed, 21 insertions, 10 deletions
diff --git a/media-gfx/optipng/ChangeLog b/media-gfx/optipng/ChangeLog
index 84056e1e2446..e0baa529a8c2 100644
--- a/media-gfx/optipng/ChangeLog
+++ b/media-gfx/optipng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/optipng
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/ChangeLog,v 1.49 2009/03/06 16:27:44 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/ChangeLog,v 1.50 2009/05/19 12:03:35 nyhm Exp $
+
+*optipng-0.6.3 (19 May 2009)
+
+ 19 May 2009; Tristan Heaven <nyhm@gentoo.org> +optipng-0.6.3.ebuild:
+ Version bump
06 Mar 2009; Raúl Porcel <armin76@gentoo.org> optipng-0.6.2-r1.ebuild:
alpha stable wrt #260265
diff --git a/media-gfx/optipng/optipng-0.6.2.ebuild b/media-gfx/optipng/optipng-0.6.3.ebuild
index d43293413af5..e53f8baaebb5 100644
--- a/media-gfx/optipng/optipng-0.6.2.ebuild
+++ b/media-gfx/optipng/optipng-0.6.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.6.2.ebuild,v 1.5 2008/12/07 13:41:52 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.6.3.ebuild,v 1.1 2009/05/19 12:03:35 nyhm Exp $
+EAPI=2
inherit toolchain-funcs
DESCRIPTION="Compress PNG files without affecting image quality"
@@ -10,19 +11,24 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
-KEYWORDS="alpha amd64 ppc x86"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e '/^C/s: -O2.*: $(GENTOO_CFLAGS) -Wall:' \
-e '/^LD/s: -s$: $(GENTOO_LDFLAGS):' \
- src/scripts/gcc.mak \
- lib/libpng/scripts/makefile.gcc \
+ src/scripts/gcc.mak.in \
lib/pngxtern/scripts/gcc.mak \
|| die "sed failed"
+ rm -rf lib/{libpng,zlib}
+}
+
+src_configure() {
+ ./configure \
+ -with-system-libpng \
+ -with-system-zlib \
+ || die "configure failed"
}
src_compile() {