summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-06-03 08:33:40 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-06-03 08:33:40 +0000
commit19f2691b520758d494c7fb5da2ec1fd6aeec68a9 (patch)
treec621605cb4cfdd8ecffb312f791c4de0b38234d4 /media-gfx/optipng
parentchange description, better way of selecting mmx. (Manifest recommit) (diff)
downloadgentoo-2-19f2691b520758d494c7fb5da2ec1fd6aeec68a9.tar.gz
gentoo-2-19f2691b520758d494c7fb5da2ec1fd6aeec68a9.tar.bz2
gentoo-2-19f2691b520758d494c7fb5da2ec1fd6aeec68a9.zip
add a warning about ext- use flags
Diffstat (limited to 'media-gfx/optipng')
-rw-r--r--media-gfx/optipng/optipng-0.4.5.ebuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/media-gfx/optipng/optipng-0.4.5.ebuild b/media-gfx/optipng/optipng-0.4.5.ebuild
index 7bf25da5eabd..6d05adde573b 100644
--- a/media-gfx/optipng/optipng-0.4.5.ebuild
+++ b/media-gfx/optipng/optipng-0.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.4.5.ebuild,v 1.2 2004/06/03 08:25:00 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/optipng/optipng-0.4.5.ebuild,v 1.3 2004/06/03 08:33:40 taviso Exp $
inherit eutils flag-o-matic
@@ -46,7 +46,7 @@ src_compile() {
usemmx=0
fi
- # only defined in bundled zlib?
+ # only defined in bundled zlib
if use ext-zlib || use ext-png; then
append-flags -DZ_RLE=3
fi
@@ -85,3 +85,17 @@ src_install() {
dodoc ${S}/doc/{CAVEAT,DESIGN,FEATURES,HISTORY,LICENSE,README,TODO,USAGE}
dohtml ${S}/doc/index.html
}
+
+pkg_postinst() {
+ if use ext-zlib || use ext-png; then
+ ewarn "the ext-zlib and ext-png USE flags are designed for users"
+ ewarn "that require special modifications to libpng or zlib."
+ ewarn
+ ewarn "the bundled libraries are highly optimised specifically"
+ ewarn "for use with compressing png files, and should be used if"
+ ewarn "possible."
+ ewarn
+ ewarn "if you set these flags in error, please unset them and"
+ ewarn "re-merge ${PN}."
+ fi
+}