summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-03-15 02:31:35 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-03-15 02:31:35 +0000
commitc2dcd208dff0dfec308a30a3f621d5fdc4ec847c (patch)
treec09d1e41c7a44967d9c836488487a415999cc749 /media-gfx/opendx
parentFixed to not override portage readonly variables (Manifest recommit) (diff)
downloadgentoo-2-c2dcd208dff0dfec308a30a3f621d5fdc4ec847c.tar.gz
gentoo-2-c2dcd208dff0dfec308a30a3f621d5fdc4ec847c.tar.bz2
gentoo-2-c2dcd208dff0dfec308a30a3f621d5fdc4ec847c.zip
Initial commit to close #22217. Ebuild by myself and Patrick Kursawe <phosphan@gentoo.org>.
Diffstat (limited to 'media-gfx/opendx')
-rw-r--r--media-gfx/opendx/ChangeLog11
-rw-r--r--media-gfx/opendx/Manifest2
-rw-r--r--media-gfx/opendx/files/digest-opendx-4.3.21
-rw-r--r--media-gfx/opendx/metadata.xml5
-rw-r--r--media-gfx/opendx/opendx-4.3.2.ebuild110
5 files changed, 129 insertions, 0 deletions
diff --git a/media-gfx/opendx/ChangeLog b/media-gfx/opendx/ChangeLog
new file mode 100644
index 000000000000..4e6b1bc7896e
--- /dev/null
+++ b/media-gfx/opendx/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for media-gfx/opendx
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opendx/ChangeLog,v 1.1 2004/03/15 02:31:35 spyderous Exp $
+
+*opendx-4.3.2 (14 Mar 2004)
+
+ 14 Mar 2004; Donnie Berkholz <spyderous@gentoo.org>; metadata.xml,
+ opendx-4.3.2.ebuild:
+ Initial commit to close #22217. Ebuild by myself and Patrick Kursawe
+ <phosphan@gentoo.org>.
+
diff --git a/media-gfx/opendx/Manifest b/media-gfx/opendx/Manifest
new file mode 100644
index 000000000000..c96028f58b75
--- /dev/null
+++ b/media-gfx/opendx/Manifest
@@ -0,0 +1,2 @@
+MD5 7353c294c49d44a7e3ceafe0132b21ac opendx-4.3.2.ebuild 3056
+MD5 e8b3b97f7766dc0b83d6dfd1cd0b753e files/digest-opendx-4.3.2 61
diff --git a/media-gfx/opendx/files/digest-opendx-4.3.2 b/media-gfx/opendx/files/digest-opendx-4.3.2
new file mode 100644
index 000000000000..189444d56482
--- /dev/null
+++ b/media-gfx/opendx/files/digest-opendx-4.3.2
@@ -0,0 +1 @@
+MD5 201afdd86a5ddcfda0dc60fc7b6d3fea dx-4.3.2.tar.gz 9904514
diff --git a/media-gfx/opendx/metadata.xml b/media-gfx/opendx/metadata.xml
new file mode 100644
index 000000000000..b229aec85b8f
--- /dev/null
+++ b/media-gfx/opendx/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+</pkgmetadata>
diff --git a/media-gfx/opendx/opendx-4.3.2.ebuild b/media-gfx/opendx/opendx-4.3.2.ebuild
new file mode 100644
index 000000000000..1a66cd8320f9
--- /dev/null
+++ b/media-gfx/opendx/opendx-4.3.2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/opendx/opendx-4.3.2.ebuild,v 1.1 2004/03/15 02:31:35 spyderous Exp $
+
+# Set SMP="no" to force disable of SMP compilation.
+# Set SMP="yes" to force enable of SMP compilation.
+# Otherwise it will be autodetected from /usr/src/linux.
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A 3D data visualization tool"
+HOMEPAGE="http://www.opendx.org/"
+SRC_URI="http://opendx.npaci.edu/source/${P/open}.tar.gz"
+
+# There are a few jar files that can be added to enhance JX.
+# These are java40.jar from the Netscape libraries
+# (we've provided them in the OpenDX.org lib area) nscosmop211.jar
+# from the Cosmo Player libs.
+# http://opendx.npaci.edu/libs/
+#SRC_URI="${SRC_URI}
+# http://opendx.npaci.edu/libs/netscape-java40.tar.gz
+# http://opendx.npaci.edu/libs/cosmoplayer-jar.tar.gz"
+
+LICENSE="IPL-1"
+SLOT="0"
+# Should work on x86, ppc, alpha at least
+KEYWORDS="~x86"
+
+IUSE="hdf cdf netcdf tiff imagemagick" # java doc"
+
+DEPEND="virtual/x11
+ x11-libs/openmotif
+ hdf? ( dev-libs/hdf )
+ cdf? ( app-sci/cdf )
+ netcdf? ( app-sci/netcdf )
+ tiff? ( media-libs/tiff )
+ imagemagick? ( >=media-gfx/imagemagick-5.3.4 )"
+# waiting on bug #36349 for media-libs/jasper in imagemagick
+# java support gives some trouble - deprecated api and other unresolved symbols
+# java? ( virtual/jdk
+# dev-java/java-config )"
+
+S="${WORKDIR}/${P/open}"
+
+smp() {
+ has "$1" "${SMP}"
+}
+
+smp_check() {
+ if [ -e /usr/src/linux/.config ]
+ then
+ if [ "`grep SMP /usr/src/linux/.config | cut -d= -f2`" = "y" ]
+ then
+ return 0
+ else
+ return 1
+ fi
+ else
+ die "SMP check failed. Make sure /usr/src/linux/.config exists."
+ fi
+}
+
+src_compile() {
+ local myconf="--with-x \
+ --host=${CHOST}"
+
+ # Check for SMP
+ # This needs to be done for /usr/src/linux, NOT the running kernel
+ # Allow override using smp().
+ if smp no
+ then
+ myconf="${myconf} --disable-smp-linux"
+ einfo "Disabling SMP capabilities"
+ elif smp yes || smp_check
+ then
+ myconf="${myconf} --enable-smp-linux"
+ einfo "Enabling SMP capabilities"
+ else
+ myconf="${myconf} --disable-smp-linux"
+ einfo "Disabling SMP capabilities"
+ fi
+
+ # with gcc 3.3.2 I had an infinite loop on src/exec/libdx/zclipQ.c
+ append-flags -fno-strength-reduce
+
+ # szlib is used by hdf package, have to link with it here aswell
+
+ local GENTOOARCH="${ARCH}"
+ # opendx uses this variable
+ unset ARCH
+ # use java && myconf="${myconf} JNIPATH=$(java-config -O)/include:$(java-config -O)/include/linux"
+ econf LIBS="-lsz" \
+ `use_with cdf` \
+ `use_with netcdf` \
+ `use_with hdf` \
+ `use_with tiff` \
+ `use_with imagemagick magick` \
+ ${myconf} || die
+
+ # `use_with java javadx`
+ # This is broken
+ # `use_enable doc installhtml`
+
+ make || die
+ ARCH="${GENTOOARCH}"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}