summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-10-28 13:07:32 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-10-28 13:07:32 +0000
commit592cd7ddcfacd6df7cfa2833ba4b2e1b1c8a2209 (patch)
treeae4b35e95085a91824c154ad018d63595d76277f /media-gfx/kst/files
parentMarked ppc-macos for bug #109040 and removed ppc-macos conditional *libtoolize (diff)
downloadgentoo-2-592cd7ddcfacd6df7cfa2833ba4b2e1b1c8a2209.tar.gz
gentoo-2-592cd7ddcfacd6df7cfa2833ba4b2e1b1c8a2209.tar.bz2
gentoo-2-592cd7ddcfacd6df7cfa2833ba4b2e1b1c8a2209.zip
Patch configure so that it doesn not link to netcdf unconditionally, thanks to Lucas Chiesa <lucas.chiesa@gmail.com> for providing the patch.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'media-gfx/kst/files')
-rw-r--r--media-gfx/kst/files/digest-kst-1.1.0-r11
-rw-r--r--media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch76
2 files changed, 77 insertions, 0 deletions
diff --git a/media-gfx/kst/files/digest-kst-1.1.0-r1 b/media-gfx/kst/files/digest-kst-1.1.0-r1
new file mode 100644
index 000000000000..5189a462d526
--- /dev/null
+++ b/media-gfx/kst/files/digest-kst-1.1.0-r1
@@ -0,0 +1 @@
+MD5 68a38073fa6de1e52d55dd9db4e85b4d kst-1.1.0.tar.gz 10598874
diff --git a/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch b/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch
new file mode 100644
index 000000000000..cf2d0fe35c92
--- /dev/null
+++ b/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch
@@ -0,0 +1,76 @@
+--- configure.in 2005-10-27 00:25:05.000000000 -0300
++++ configure.in 2005-10-27 00:22:25.000000000 -0300
+@@ -156,7 +156,7 @@
+ AC_HELP_STRING([--with-cdf=DIR],[where the root of CDF is installed ]),
+ [ ac_cdf_includes="-I$withval/include"
+ ac_cdf_libraries="-L$withval/lib"
+- ])
++ ])
+
+ all_includes_save="$all_includes"
+ all_includes="$all_includes $ac_cdf_includes"
+@@ -182,32 +182,43 @@
+ # netCDF Test
+ ac_netcdf_includes=""
+ ac_netcdf_libraries=""
+-AC_ARG_WITH(netcdf,
+- AC_HELP_STRING([--with-netcdf=DIR],[where the root of NetCDF is installed ]),
+- [ ac_netcdf_includes="-I$withval/include"
+- ac_netcdf_libraries="-L$withval/lib"
+- ])
+-
+-all_includes_save="$all_includes"
+-all_includes="$all_includes $ac_netcdf_includes"
+-KDE_CHECK_HEADER(netcdfcpp.h, AC_DEFINE(HAVE_NETCDFCPP_H, 1, [If we have NetCDF CPP headers]) have_netcdfcpp_h=yes NETCDFINCLUDES="$ac_netcdf_includes", , )
+-all_includes="$all_includes_save"
++NETCDFLIBS=""
+
+-ldflags_save="$LDFLAGS"
+-LDFLAGS="$LDFLAGS $ac_netcdf_libraries"
+-KDE_CHECK_LIB(netcdf, nc_open, NETCDFLIBS="$ac_netcdf_libraries -lnetcdf_c++ -lnetcdf $NETCDFLIBS", , )
+-LDFLAGS="$ldflags_save"
+-
+-if test $ac_cv_lib_netcdf_nc_open = yes; then
+- if test $have_netcdfcpp_h = yes; then
+- AC_SUBST(NETCDFLIBS)
+- AC_SUBST(NETCDFINCLUDES)
+- AC_DEFINE(KST_HAVE_NETCDF, 1, [If we have the NetCDF libraries.])
+- fi
++AC_MSG_CHECKING([--enable-netcdf argument])
++AC_ARG_ENABLE(netcdf,
++ [ --enable-netcdf enable netcdf support.],
++ [ enable_netcdf=$enableval ],
++ [ enable_netcdf="no" ])
++
++if test "$enable_netcdf" = "yes"; then
++ AC_ARG_WITH(netcdf,
++ AC_HELP_STRING([--with-netcdf=DIR],[where the root of NetCDF is installed ]),
++ [ ac_netcdf_includes="-I$withval/include"
++ ac_netcdf_libraries="-L$withval/lib"
++ ])
++
++ all_includes_save="$all_includes"
++ all_includes="$all_includes $ac_netcdf_includes"
++ KDE_CHECK_HEADER(netcdfcpp.h, AC_DEFINE(HAVE_NETCDFCPP_H, 1, [If we have NetCDF CPP headers]) have_netcdfcpp_h=yes NETCDFINCLUDES="$ac_netcdf_includes", , )
++ all_includes="$all_includes_save"
++
++ ldflags_save="$LDFLAGS"
++ LDFLAGS="$LDFLAGS $ac_netcdf_libraries"
++ KDE_CHECK_LIB(netcdf, nc_open, NETCDFLIBS="$ac_netcdf_libraries -lnetcdf_c++ -lnetcdf $NETCDFLIBS", , )
++ LDFLAGS="$ldflags_save"
++
++ if test $ac_cv_lib_netcdf_nc_open = yes; then
++ if test $have_netcdfcpp_h = yes; then
++ AC_SUBST(NETCDFLIBS)
++ AC_SUBST(NETCDFINCLUDES)
++ AC_DEFINE(KST_HAVE_NETCDF, 1, [If we have the NetCDF libraries.])
++ fi
++ fi
+ fi
+
+ AM_CONDITIONAL(include_netcdf, test -n "$NETCDFLIBS")
+
++
+ # Readline and ncurses check
+ KDE_CHECK_HEADER(readline/readline.h, AC_DEFINE(HAVE_READLINE_H, 1, [If we have libreadline headers]) have_readline_h=yes, , )
+ KDE_CHECK_LIB(readline, rl_cleanup_after_signal, LIBREADLINE="-lreadline -lncurses", , -lncurses)