summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-07-06 14:54:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-07-06 14:54:56 +0000
commitb9351819e4a7d1601ab586b35b4706ad714abd45 (patch)
tree00ad06e0a6c1da967c4d8351ddfb3a11ae1c6059 /media-gfx/k3d
parentia64/s390/sparc stable wrt #274558 (diff)
downloadgentoo-2-b9351819e4a7d1601ab586b35b4706ad714abd45.tar.gz
gentoo-2-b9351819e4a7d1601ab586b35b4706ad714abd45.tar.bz2
gentoo-2-b9351819e4a7d1601ab586b35b4706ad714abd45.zip
Fix building with GCC 4.4 and BOOST by applying a Fedora patch wrt #276660, thanks to Diego E. Pettenò for reporting.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/k3d')
-rw-r--r--media-gfx/k3d/ChangeLog7
-rw-r--r--media-gfx/k3d/files/k3d-0.7.11.0-gcc44.patch60
-rw-r--r--media-gfx/k3d/k3d-0.7.11.0-r1.ebuild7
3 files changed, 70 insertions, 4 deletions
diff --git a/media-gfx/k3d/ChangeLog b/media-gfx/k3d/ChangeLog
index 1015be3d779a..b692a61ed236 100644
--- a/media-gfx/k3d/ChangeLog
+++ b/media-gfx/k3d/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/k3d
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/ChangeLog,v 1.45 2009/04/23 20:32:52 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/ChangeLog,v 1.46 2009/07/06 14:54:56 ssuominen Exp $
+
+ 06 Jul 2009; Samuli Suominen <ssuominen@gentoo.org>
+ k3d-0.7.11.0-r1.ebuild, +files/k3d-0.7.11.0-gcc44.patch:
+ Fix building with GCC 4.4 and BOOST by applying a Fedora patch wrt
+ #276660, thanks to Diego E. Pettenò for reporting.
*k3d-0.7.11.0-r1 (23 Apr 2009)
diff --git a/media-gfx/k3d/files/k3d-0.7.11.0-gcc44.patch b/media-gfx/k3d/files/k3d-0.7.11.0-gcc44.patch
new file mode 100644
index 000000000000..6917170b8cbc
--- /dev/null
+++ b/media-gfx/k3d/files/k3d-0.7.11.0-gcc44.patch
@@ -0,0 +1,60 @@
+--- k3d-source-0.7.11.0/k3dsdk/gzstream.cpp~ 2009-03-19 21:28:50.000000000 +0100
++++ k3d-source-0.7.11.0/k3dsdk/gzstream.cpp 2009-03-22 22:19:03.000000000 +0100
+@@ -29,6 +29,7 @@
+ #include "gzstream.h"
+ #include "path.h"
+
++#include <stdio.h>
+ #include <zlib.h>
+ #include <string.h>
+
+--- k3d-source-0.7.11.0/k3dsdk/gil/boost/gil/color_base_algorithm.hpp~ 2009-03-19 21:28:53.000000000 +0100
++++ k3d-source-0.7.11.0/k3dsdk/gil/boost/gil/color_base_algorithm.hpp 2009-03-22 22:33:45.000000000 +0100
+@@ -70,7 +70,7 @@
+ template <typename ColorBase, int K> struct kth_semantic_element_reference_type {
+ BOOST_STATIC_CONSTANT(int, semantic_index = (mpl::at_c<typename ColorBase::layout_t::channel_mapping_t,K>::type::value));
+ typedef typename ColorBase::template kth_element_reference_type<semantic_index>::type type;
+- static type get(ColorBase& cb) { return at_c<semantic_index>(cb); }
++ static type get(ColorBase& cb) { return boost::gil::at_c<semantic_index>(cb); }
+ };
+
+ /// \brief Specifies the return type of the constant semantic_at_c<K>(color_base);
+@@ -78,7 +78,7 @@
+ template <typename ColorBase, int K> struct kth_semantic_element_const_reference_type {
+ BOOST_STATIC_CONSTANT(int, semantic_index = (mpl::at_c<typename ColorBase::layout_t::channel_mapping_t,K>::type::value));
+ typedef typename ColorBase::template kth_element_const_reference_type<semantic_index>::type type;
+- static type get(const ColorBase& cb) { return at_c<semantic_index>(cb); }
++ static type get(const ColorBase& cb) { return boost::gil::at_c<semantic_index>(cb); }
+ };
+
+ /// \brief A mutable accessor to the K-th semantic element of a color base
+--- k3d-source-0.7.11.0/k3dsdk/path.cpp~ 2009-03-19 21:28:55.000000000 +0100
++++ k3d-source-0.7.11.0/k3dsdk/path.cpp 2009-03-22 22:48:31.000000000 +0100
+@@ -24,6 +24,7 @@
+ #include "result.h"
+ #include "system.h"
+
++#include <stdio.h>
+ #include <glibmm/convert.h>
+
+ #ifdef K3D_API_WIN32
+--- k3d-source-0.7.11.0/modules/inotify/inotify-cxx.cpp~ 2009-03-19 21:29:01.000000000 +0100
++++ k3d-source-0.7.11.0/modules/inotify/inotify-cxx.cpp 2009-03-22 23:16:31.000000000 +0100
+@@ -20,6 +20,7 @@
+ */
+
+
++#include <stdio.h>
+ #include <errno.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+--- k3d-source-0.7.11.0/modules/pdiff/Metric.cpp~ 2009-03-19 21:29:02.000000000 +0100
++++ k3d-source-0.7.11.0/modules/pdiff/Metric.cpp 2009-03-22 23:34:09.000000000 +0100
+@@ -19,6 +19,7 @@
+ #include "RGBAImage.h"
+ #include "LPyramid.h"
+ #include <math.h>
++#include <stdio.h>
+
+ #ifndef M_PI
+ #define M_PI 3.14159265f
diff --git a/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild b/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
index 2a84648963ce..ea3ceeac40ad 100644
--- a/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
+++ b/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild,v 1.1 2009/04/23 20:30:22 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/k3d/k3d-0.7.11.0-r1.ebuild,v 1.2 2009/07/06 14:54:56 ssuominen Exp $
EAPI="2"
@@ -68,8 +68,9 @@ k3d_use_module() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-fix-potfiles.patch
- epatch "${FILESDIR}"/${P}-cuda.patch
+ epatch "${FILESDIR}"/${P}-fix-potfiles.patch \
+ "${FILESDIR}"/${P}-cuda.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
[[ -f CMakeCache.txt ]] && rm CMakeCache.txt
}